Skip to main content

Boot error before AND after restore, Stop 0x0000007B

Beginner
Posts: 1
Comments: 3

I have a STOP error during boot which resulted from a failed Windows update.  After restoring the OS partition with Acronis True Image, I still have the stop error.

This is on a Dell Inspiron 530 desktop computer with Windows Vista SP2.

1. Cause of the problem.  I attempted Windows update KB3216775.  It got stuck with the install progress bar at 100% but not completing for an hour.  I tried to cancel.  Cancelling did not work.  Attempting to shutting down cleanly did not work.  I did a hard poweroff.  After this, the system would not boot:
Stop 0x0000007B (0x80399BB0,0x0000034,0x00000000,0x00000000)

2. Booting into safe mode did not work -- same stop error.  Booting into Windows Recovery environment works.  Here is what I tried from Windows Recovery:
- The option for "automatically checking disk for error" results in "Startup Repair cannot repair this computer automatically".
- In advanced repair mode command line, I tried running BootRec /FixBoot, then restarted.  Unsuccessful.
- In advanced repair mode command line, I tried BootRec /ScanOs.  Total identified Windows installations: 0.  I tried BootRec /FixBoot, then restarted.  Unsuccessful.
- In advanced repair mode command line, I tried BootRec /FixMbr.  Then BootRec /RebuildBcd.  Total identified Windows installations: 0.  I ran chkdsk /r c: (label OS).  It found no problems.  I rebooted, and it was unsuccessful.
- In advanced repair mode command line, I tried sfc /scannow, then rebooted.  Also unsuccessful.

- Because of the odd behavior of BootRec (not finding any installations of Windows), I tried the approach in Windows Recovery command line referenced in:
http://www.troublefixers.com/unable-to-boot-in-windows-vista-windows-boot-configuration-data-file-is-missing-required-information/
> Bcdedit /export C:\BCD_Backup
> c:
> cd boot
> attrib bcd -s -h -r
> ren c:\boot\bcd bcd.old
> bootrec /RebuildBcd

This found one windows installation.  I added thisto the boot list, then restarted.  But I got another error:
Stop 0x0000007B (0x80799BB0,0xC0000034,0x00000000,0x00000000)

- Attempting to use sytem restore points did not work.  Either there would be an unspecified error for a given restore point, or the restoration would appear to execute but not complete the job.  In the latter case, a dialog box showed "preparing to restore" with a progress bar.  The dialog box disappeared, then nothing else happened.  "System Recover Options" dialog box was still displayed, with no other apparent activity.  And no successful reboot.

3. Here is what I consider the weird part.  This is where Acronis True Image comes in.  I regularly image my system with Acronis True Image 2014.  Using ATI 2014 boot version, I recovered from the image that I had made shortly before the failed Windows update that caused the trouble.  I have now tried this several times.  Recovered objects: 1) OS [C:]; 2) Dell Utilities [FAT16, unlabeled, type "Dell Server Utilities"]; 3) MBR and Track 0, selected recover disk signature.
Note: I also tried other recovery permutions like recovering only C: without the rest of the objects, or recovering everything but without the disk signature.
Also note: When imaging my system I always validate the archive after making a new image.  I also validate the archive before recovering from the image.  Of course there are no errors reported for any of these.
The ATI 2014 recovery completed without error, I rebooted, and I got another error:
Stop 0x0000007B (0x80399BB0,0xC0000034,0x00000000,0x00000000)

4. Other notes and steps along the way
The sytem was running fine before the failed Windows update, with no symptoms of trouble.  I have thoroughly tested the memory and the disk.
- Memory: Booted into Memtest86 4.3.7 and ran for 7 passes (8h:7m) without errors.  Booted into Memtest86+ 5.01 and ran for 11 passes (13h:57m) without errors.  Tried removing one DIMM and booting; tried removing a different DIMM and booting; neither avoided the stop error.

- Disk (a Seagate): Booted into SeaTools for DOS 2.23 (via Ultimate Boot CD), ran long drive self-test.  Completed without errors after 3.5 hr.  Also connected the hard drive to another system running Windows 8.1 to run chkdsk /f on the OS partition of the recovered partition; no problems found.  Also tested in Windows recovery command line with chkdsk /r .

Legend
Posts: 43
Comments: 12992

Top

McGuffin, welcome to these user forums.

Couple of thoughts here.  

Windows Vista was the first version to start using a separate Microsoft System Reserved (MSR) partition to hold boot data though not all installations have this (I have a laptop with Vista without a MSR partition where the boot data is on the C: drive).  It may be best to completely wipe your boot drive, assuming that your ATIH 2014 backup of this drive is a full backup that includes all partitions, and then do a full disk recovery from the Acronis bootable Rescue Media so that everything is put back exactly as it was when you created the backup image.

See the following webpages with information on trying to resolve the Stop 007B error if you want to continue down that path.  

Windows Vista Startup Blue Screen STOP: 0X0000007B - read through all the whole pages of this article including checking BIOS settings for the disk controller mode (AHCI versus IDE mode).  

Error 0x7B - Installing Windows updates  

T61p Vista BSOD with STOP: 0x0000007B (0x80399BB0, 0xC0000034, 0x00000000, 0x00000000)  same codes as you are seeing, again pointing to the SATA mode in BIOS being AHCI causing the problem.

 

Beginner
Posts: 1
Comments: 3

Top

Thanks for getting back to me.  The drive does not have a Microsoft System Reserved partition.  I do not image the entire drive.  I image the OS (C:) partition, MBR, and "RECOVERY" partition.  The drive's partition map is fine; I can connect the drive to another host system and access all partitions and files.  It does seem that I should be able to image only those partitions, then later restore the OS partition and possibly MBR, and have a running system.  This is one of the reasons we partition drives in the first place -- to separate data from system files, then use, backup, and generally manage each accordingly.

>Windows Vista Startup Blue Screen STOP: 0X0000007B - read through all the whole pages of this article including checking BIOS settings for the disk controller mode (AHCI versus IDE mode).

In the above thread on answers.microsoft.com, the original poster (username "Ericthegreat") never indicates that his problem was actually solved by any of the responses.  He presented the problem of a persistent STOP error after a sudden power loss.  One of the messages labeled as "Answer", posted by username "SpiritX MS MVP", is just a general laundry-list of possible causes of STOP errors.  Unfortunately, nearly everything in the list is glaringly irrelevant to the actual problem described.  If boot-time STOP errors happen after a power loss, it makes no sense to suggest it might be due to, for example: viruses; bad data cables; old video or audio drivers; BIOS problems; recently added hardware; failed boot device; etc.  Those can be culprits at times, but are not created by a yanked AC plug.  In that discussion, I do observe that some >other< users piled into the thread to say they resolved >their own< STOP-error problems by changing BIOS settings for hard-drive mode from AHCI to IDE; but that has nothing to do with the original poster's situation.

In my case, the problem was introduced due to some combination of 1) the failure of a Windows update; and 2) the subsequent hard poweroff which I had to do because Windows Update locked up my system.  Before that time the system was fine.  Immediately after that time, there was this bootup STOP problem.  I did not make any adjustments to BIOS or hardware.  Checking my BIOS settings, I can confirm: 1) There is no option available for AHCI mode; and 2) of the two selectable SATA modes (IDE or RAID), the setting is and always has been IDE.

>Error 0x7B - Installing Windows updates  

The message marked answer in the above thread is another general laundry-list.  The original poster never indicated his problem was solved.  He said a botched Windows update caused boot-time STOP errors.  One reply which was marked "Answer" suggests some possibilities that are irrelevant to what really happened: viruses; faulty disk drive or disk cables; computer BIOS or the disk controller firmware are incompatible with Windows Vista; etc.  These problems do not get introduced by a failed Windows update.  But a failed Windows update can certainly mess up an OS installation.  In my case, I have confirmed that the drive, cables, hard drive partition map, and the filesystems on the partitions are all good.

>T61p Vista BSOD with STOP: 0x0000007B (0x80399BB0, 0xC0000034, 0x00000000, 0x00000000)

Does not apply here: no AHCI or compatibility mode selectable in my BIOS.

Legend
Posts: 43
Comments: 12992

Top

McGuffin, the only other suggestions that I have for this situation would be as follows:

If you have a spare drive you can use, ensure that this is totally formatted then try restoring your Vista OS & Recovery partitions, plus the MBR to that spare drive and see if that will boot into Windows on the original computer?

If that doesn't work, then using the spare drive, do a vanilla basic install of Vista from your original installation DVD media to the point where you have Vista able to open to the Windows desktop, then try restoring just the Vista OS partition back over the top of the vanilla OS partition?  
Note: Make a backup of the vanilla install of Vista as a precaution in case you need to do a full clean install of Vista, to save yourself doing this more than once.

I would normally suggest doing an in-place upgrade of the OS but this is only possible from within a running Windows installation, not possible if you cannot boot into Windows other than to let the Windows install process try to do a repair of the original Vista OS install.

Beginner
Posts: 1
Comments: 3

Top

I tried a number of things and still have not solved this.

 

- I found that some earlier images (Dec. 2016 - Jan 2017) will give me a bootable system.  However, after a few reboots with various software or Windows updates, I get the stop error again.  There is no single update that causes the stop error.  But the tricky thing is that a given image increment may be rebootable once, but not twice; and this may depend on what I do with the system while it is running.

 

- various runs of chkdsk /f and sfc /scannow along the way indicate no problems

 

- scanned everything possible with three malware utilities outside of Windows: Kaspersky Rescue Disk 10, F-Secure Rescue Disk, and Windows Defender Offline.  No malware.

- reset the BIOS.  Unplugged the power cable and all other cables; removed the CMOS battery; and used the CMOS reset jumper to reset.  Then in the BIOS menu, loaded defaults, then changed a few things (set the time, disabled the floppy disk controller, etc.).  SATA mode is still set to IDE, not RAID, and there is not mention of AHCI anywhere.

- After one of the stop errors, I examined the OS registry from Windows Recovery Environment to see if the system had switched to AHCI mode while my BIOS was set to IDE.  The AHCI entries were set to inactive and the IDE entry was active, as it should be.

 

- tried another disk.  Same behavior as with the original disk.  ATI 2014 was a nuisance when restoring the OS partition to the new disk.  It cost me about a day of dedicated trying and retrying.  This was due to a bug in Acronis True Image that many people have asked about in these forums over many years: "Number of copied sectors differs from counted" (0x70001).  Eventually I found a workaround, so I will describe this as a side note, in case it might save people a few hundred-thousand person-hours.

Side note about the ATI error.  You try to recover a partition to a destination partition, everything seems to run to completion, but at the end you get a failure message.  The log shows "Number of copied sectors differs from counted" (0x70001).  I concluded that this is not a user error (as in stupid, like trying to restore 80 GB of actual data to a destination 40 GB partition), but rather a bug in ATI.  To restore my 3 partition images and MBR to a new hard drive, my initial approach was to create the partition table on the destination drive using GParted.  I set up 3 partitions with plenty of capacity for the data that I was restoring, in the same order as on the original drive: 1) Dell Utility; 2) Recovery; 3) OS; and some more partitions for data, not covered by my ATI backups.  The ATI 2014 boot disk restored the first two small partitions (Dell Utility and Recovery) with no problems.  But when restoring to the OS partition, I kept getting the error; and the outcome was unallocated space where the OS partition should have been.  I tried setting a ridiculously large partition size for the OS destination partition (500 GB for a partition that was originally 90 GB and had 60 GB of data).  Same error.  I tried setting up the target disk within ATI itself instead of using GParted, using the "Add a New Disk" tool.  This also did not work.  Eventually I found the workaround for the bug.  The trick was to recover partitions only to unallocated space on the destination hard drive, and to use the default size for the OS partition.  In other words, I could not partition the drive first, then restore data to it.  The third partition (OS) had to be restored using the default partition size to unallocated space -- that is, not recovering to a partition that was already set up, and also not recovering to unallocated space >with a change of size<.  The destination partition had to be exactly 90.02 GB to restore without error because the original partition that was imaged was 90.02 GB.  This also means that if the original partition had been very large -- say, 1.7 TB on a 2 TB disk -- and there were not that much unallocated space available on the destination, there would be no way to recover the image without error.

Anyway, I worked with the new drive for a while, checking some things, and eventually reproducing stop errors reliably from the same images and sequences of steps as with the original drive.  So I am back to working with my original drive.

Legend
Posts: 43
Comments: 12992

Top

Thanks for the detailed update with your results of further testing etc.

The only other suggestion I can think to offer is to take your spare / second disk drive and do a new install of Windows Vista SP2 on this and then test rebooting this install a number of times to prove that this is not all coming from a hardware issue on the Dell computer.

If you don't have your Vista install media available for testing in this way, then pay a visit to webpage: Microsoft Windows and Office ISO Download Tool where you can download a utility program that will let you download the install media of Windows 7 or later, which you could test drive for upto 30 days.

Beginner
Posts: 1
Comments: 3

Top

> I would normally suggest doing an in-place upgrade of the OS but this is only possible from within a running Windows installation, not possible if you cannot boot into Windows other than to let the Windows install process try to do a repair of the original Vista OS install .

 

Is this the procedure that reverts the sytem back to whatever is installable on the DVD, but leaves your third-party software installed?  It might work as an experiment, but not as a solution; left undone would be the task of re-installing 9 years' worth of Windows Updates via the slow, hazardous Windows Update.

 

Legend
Posts: 43
Comments: 12992

Top

See webpage: Repair A Vista Installation Using The Upgrade Option Of The Vista DVD for information about doing an in-place upgrade and what it means.

Beginner
Posts: 0
Comments: 3

Top

There are lots of causes of Stop 0x0000007B error, some of them are: 

  1. Boot-Sector Viruses
  2. Device Driver Issues
  3. Hardware Issues

General Troubleshooting

  1. Update the computer BIOS
  2. Update Device Drivers
  3. Use the Last Known Good Configuration feature.
  4. Restore a registry backup.

Source: Microsoft

https://sites.google.com/site/fixyourpcerror/