Skip to main content

AB 12.5 - Probleme beim Backup Windows DomainController

Thread needs solution
Beginner
Posts: 5
Comments: 2

Hallo zusammen,

wir setzen auf einem ESX Server (noch Release 5.5u2) das Acronis Backup 12.5 (Build 7641) ein.

U.a. läuft auf dem ESX Server ein Windows Server 2012 R2 als ActiveDirectory DomainController.

Sichere ich nun die VM via AB 12.5 OHNE ActiveDirectory, läuft dies fehlerfrei.

Da ich aber auch das AD sichern möchte bzw. muss, startet sehr oft das Backup, bleibt aber dann irgendwann stehen - leider ohne erkennbaren Grund.

Siehe Bild AB125_24-11-2017_2.png.

Auffällig ist, das im Fehlerfalle, im VMWare vSphere Client im ca. 4 Sekunden-Takt die Aktion "Prozesse im Gastbetriebssystem auflisten" ausgeführt wird.

Siehe Bild AB125_24-11-2017.png.

Anschließend startet das Backup erst wieder, nachdem die betroffene VM (DC) UND die Acronis Appliance neu gestartet wurden.

Es kann dann sein, das 1-2 Sicherungen klappen können, anschließend geht das Spiel von vorne los.

Das Problem ist ursprünglich auch im Release 12.0.1.3622 aufgetreten, weshalb wir auch das Update auf 12.5.7641 gemacht haben - jedoch ohne Verbesserung.

Was können wir tun, damit das Backup des Domain Controller's wieder fehlerfrei läuft? Ansonsten ist das Backup aktuell nutzlos ...

 

Gruß Sebastian

 

Attachment Size
AB125_24-11-2017_2.png 19.33 KB
AB125_24-11-2017.png 319.37 KB
0 Users found this helpful
Beginner
Posts: 5
Comments: 2

#1

So, nachdem niemand antwortete, beantworte ich mir den Thread selbst ;-)

Acronis hat, zumindest in meiner Konstellation, Probleme mit dem agentenlosen Backup eines virt. DCs unter VMWare.

Ich habe Anfang verg. Woche auf dem DC den Acronis Agent installiert und der VM den Sicherungsplan neu zugewiesen. Seitdem her läuft das Backup fehlerfrei - zumindest nun seit über einer Woche.

D.h.

- Backup der VM OHNE AD und OHNE Agent = problemlos

- Backup der VM MIT AD und OHNE Agent = Problem - siehe Thread

- Backup der VM MIT AD und MIT Agent in VM = problemlos

 

Ich werde es weiter beobachten und ggf. wieder berichten.

Gruß Sebastian

Forum Moderator
Posts: 122
Comments: 4633

#2

Hallo Sebastian,

Einiges Nachdenken zum Problem: laut Ihrer Beschreibung und den beigefügten Screenshots das Problem taucht bei etwa 20 Prozenten auf, wenn genau ein Snapshot vom System erstellt wird. Beim Erstellen eines Snapshots einer VMware VM werden zwei Technologien eingesetzt - VMware Tools und die VSS Komponenten innerhalb des Gastbetriebssystems der VM. Dabei werden die VSS Komponenten für die konsistente Sicherung von den laufenden Datenbanken wie SQL, Exchange oder AD verwendet. Beim Backup ohne VSS-konformen Applikationen sind die VSS Writers auch nicht aktiv. 

Da das Problem ausschließlich beim agentlosen Backup von der VM mit Active Directory aufkommt, würde ich die VSS-Komponenten innerhalb der VM prüfen. Die folgenden Artikel könnten dabei behilflich sein

Acronis Backup: VSS Troubleshooting Guide
Acronis Backup: virtual machine backup troubleshooting guide​​​​​​​

Vielen Dank,