Skip to main content

Acronis 2021 prevents computer going to sleep

Thread needs solution
Beginner
Posts: 1
Comments: 11

After upgrading from Acronis 2020 to 2021, my computer refuses to go to sleep. According to powercfg, the process preventing the computer from going to sleep is: 'Acronis Scheduler2 Service'

Rebooting the computer doesn't help. 

Any ideas?

 

 

0 Users found this helpful
Forum Star
Posts: 191
Comments: 4544

Not sure why that is happening; I notice that my Dell notebook which I used by beta testing has not been going in into sleep mode since I loaded the release version, just low power mode - display turns off.

I will investigate further tomorrow - it is past my bed time ....

Ian

Legend
Posts: 106
Comments: 26325

Frank, I am not seeing any such problems with my computer going to sleep after upgrading from 2020 to 2021.

The Acronis Scheduler2 service should not prevent sleep unless you have an active scheduled task with this set (prevent sleep or hibernation) in the Advanced Schedule options.

One option that you can try is to download the Acronis Scheduler Manager tool (link below) and use this to remove all scheduled tasks by using the 'task zap' command.

Note: make a note of what your current task schedules are before using the tool, so that you can reset these again later.  The tool is standalone and does not get installed.

Beginner
Posts: 1
Comments: 11

Hi,

thanks for you reply. There are no active tasks running. I'd rather not delete the tasks, since I have to reconfigure everything then.

For now I've solved it by adding a powerrequest override to Windows. Now my system goes to sleep again after the specified amount of time. Planned scheduled tasks are still running ok and when they are finished, my system goes to sleep again.

Frank.

Legend
Posts: 106
Comments: 26325

Frank, the task zap does not remove any of your backup tasks, it just removes the schedule for those tasks, hence why I advised to note what the schedule are before running it.

One other suggestion to allay your worries about the backup task configuration - in the ATI GUI, open the Settings page, scroll to the bottom of the page, and use the Backup setting transfer option shown there to save your backup task settings to a zip file.  The zip file could always be used to import those settings back again if needed.

Beginner
Posts: 1
Comments: 11

Hi,

ok, thanks. I'll try that.

Frank.

Beginner
Posts: 1
Comments: 11

Hi,

unfortunate clearing the schedules didn't work. System doesn't go to sleep. The only way to get the system go to sleep again is creating a powerequest override for the scheduler service.

Beginner
Posts: 0
Comments: 1

I have the same problem.  Using ATI 2018-2020 I had no issues, but 2021 is causing this, even right after a fresh install.  I thought that turning off the checkbox that was auto-set in the backup advanced options for "prevent computer from going to sleep" would do it, but it didn't change anything.  I was hoping that would've been falsely programmed for "all" sleep options, rather than for only during backup, but no go.

Beginner
Posts: 1
Comments: 11

I got a reply from acronis support:

This is an update regarding case where you had reported issues with "Computer doesn't go to sleep after upgrading to Acronis 2021 " and found it is known issue with Acronis True Image 2021.

Unfortunately, the fix for this issue is currently not available. But we have notified this to our Development team and they are working on a fix for the issue.

Since we do not have a specific ETA about the release of a solution, I would suggest that we close this case for now.

However, please be assured that we would not consider the issue as ‘Resolved’.

The issue would be fixed in future builds of the product and hence I kindly request you to use the in-product notification option.

Please make sure “Automatically check for updates at startup” option is selected under settings tab which notifies you when a new build is released.

 

Regular Poster
Posts: 4
Comments: 176

Thanks Frank for the information

Legend
Posts: 106
Comments: 26325

Folks, I have also hit this same issue but have managed to resolve it on my main laptop as I have described in my own forum topic: ATI2021 significant critical issues

The issue is being caused by one of the new Protection tasks which is scheduled to run from 00:00:00 to 23:59:00 at an interval of 5 minutes and with the flags set to PREVENT SLEEP.!!!

One of the easiest ways to see this and all other scheduled tasks is to create an Acronis System Report then extract the schedule.txt file from the zip file.

schedule.txt lists all the scheduled tasks in detail and most will relate to your own backup tasks.

The offending task looked as below on my laptop.

----------
Task   2-4  
----------
Flags: 0x8819 (TOKEN HIDDEN TIME EXECUTED ENABLED)
FlagsEx: 0x628004 (RUN_AFTER_DELAY EXCLUSIVE MAX_DELAY_FOR_TRIGGER RETRY_FAILED SHELL_AUTO)
FlagsEx2: 0x1 (PREVENT_FROM_SLEEPING)
FlagsLater: 0xFFFFFFFF (all set!)
Time:  0:00:00
TimeInterval: 300
EndTime: 23:59:00
Type: weekly
Extra: all days enabled!
ExecCmd: C:\Program Files (x86)\Acronis\Agent\bin\adp-rest-util.exe post /av/update

The TimeInterval is shown in seconds - 300 seconds = 5 minutes.

The task identifier (2-4) will vary according to your own systems.

The Acronis Scheduler Manager tool can be used to remove or change the task (link to the tool in my signature) by using the following commands:

Launch the schedmgr.exe program (no install is involved). A black command window opens.

get list      (shows a list of all tasks and identifiers but doesn't get the detail above)

task 2-4    (selects the individual task)

task delete  (will remove the selected task)

You can use the command: help to get a list of all commands, or task ? to get help about a specific command, i.e. the task command.

Note: I have completely turned off all the new Protection feature and reverted back to just using Windows Defender to avoid Acronis re-enabling this issue!

Frank, you are welcome to pass on the above information to the person dealing with your support case.

Beginner
Posts: 1
Comments: 11

Hi Steve,

thanks for the detailed report. I've forwarded your findings to the support engineer.

Forum Star
Posts: 159
Comments: 1566

Steve,

After deleting the task, what do you think would happen if you tried to turn protection back on... would it work?

I think a better option is to disable the task rather than delete it. In the Scheduler Manager, after selecting the task the command would be
set enabled=off

I'm going to look into changing the time interval. I feel every five minutes is too often.

Legend
Posts: 106
Comments: 26325

I have been looking at my Dell laptop this afternoon which has the perpetual version of ATI 2021 where only AAP was enabled as I rejected the offer to take the trial of the other antivirus protection features.

On this laptop there were 3 added tasks that really should not be present without the antivirus feature being enabled or used, i.e. why check for antivirus updates when not enabled?

I used the Acronis Scheduler Manager to remove those 3 tasks but if I opened the Settings page of Protection the deleted tasks were added back again!  I have now turned off all Protection on that laptop and deleted the tasks again, this time it looks to be kept deleted!

Using schedmgr.exe get list to identify the 3 tasks let me create a short batch file to run an automatic delete of the unwanted tasks when needed:

schedmgr.exe task 2-3 task delete
schedmgr.exe task 2-2 task delete
schedmgr.exe task 2-1 task delete

Bruno, I tried both set ENABLED=OFF and set PREVENT_FROM_SLEEPING=OFF but again opening the Protection Settings page reversed any changes made!

Beginner
Posts: 0
Comments: 4

Frank wrote:

I got a reply from acronis support:

This is an update regarding ca................

That is almost an identical reply to that which I got when reporting the massive increases in backup and validate times after the introduction of ATI 2020.

That has not been correct yet so I wouldn’t hold my breath for something here. Regression testing seems to be absent from the development schedule

How long do we need to wait for the system to make the correct transistion from one version to the next?

 

Legend
Posts: 106
Comments: 26325

Quick further update from testing on the Dell laptop.

I found that when one of my scheduled backup tasks ran, the unwanted tasks then got put back again and I needed to do a Windows restart to get the Protection change to stick better - I had just turned off in the ATI GUI Protection Settings but I suspect there was still something running in the background!

I modified my batch file and have now set this as a Post Command for my backup tasks to ensure that the last action of the task is to delete the unwanted scheduled tasks if have been reinstated!

c:
cd c:\mvp
@echo off
c:\mvp\schedmgr.exe task 2-3 task delete > deltasks.log
c:\mvp\schedmgr.exe task 2-2 task delete >> deltasks.log
c:\mvp\schedmgr.exe task 2-1 task delete >> deltasks.log
c:\mvp\schedmgr.exe get list >> deltasks.log

I have put a copy of the schedmgr.exe tool in my c:\mvp folder and directed output from the commands used in the batch file to a log file in that folder so that I can check what is happening, including a list of remaining tasks.

I will watch and wait to see what happens!

Beginner
Posts: 2
Comments: 7

Hi everybody,

My experience so far - still not a "sleeping" computer :(

1. I did what Steve suggests/suggested by deleting the ATI2021 tasks with the schedmgr.exe

2. I switched off all the items in ATI2021/Protection - ATI2021 says 'Active Protection is turned off'

3. Disabled Acronis Active Protection Service and Acronis Cyber Protection Service in WIN10-services.msc

3. Rebooted the PC

4. ATI2021 still says 'Active Protection is turned off'

5. Acronis Active Protection Service and Acronis Cyber Protection Service in WIN10-services.msc are RUNNING again :(

6. in WIN10/cmd : powercfg -requests says :

Program Files (x86)\Common Files\Acronis\Schedule2\schedul2.exe (AcrSch2Svc) Acronis Scheduler2 Service  is ACTIVE and is preventing the Computer going into sleepmode

 

BTW - Why do WE have to find a solution for this? Where is ACRONIS SUPPORT? We pay a license for solving this!!

 

Legend
Posts: 106
Comments: 26325

Luk, taking your last point first, we should not need to find solutions for this type of issue!  Acronis support has to fix this and the more users who open support tickets for it, the greater focus it will get!

My own laptop is going to sleep fine since my actions to turn off all ATI 2021 Protection, restart the computer and delete the unwanted extra Acronis Scheduler tasks.  Note: the schedmgr tool needs to be run as Administrator to correctly delete unwanted tasks.

Forum Star
Posts: 191
Comments: 4544

I know Acronis are taking this issue seriously. When it was first reported on the forum I reported it to the product manager. The NDA means I can say no more than than the started an immediate investigation.

When tinkering with code it is easy to break something. They so need to find the cause of the problem,   then implement a solution, then do some rigorous testing. 

Ian

Beginner
Posts: 2
Comments: 7

@Steve & @Ian: Thanks for your sympathy. Keep the ball rolling ;-)

Beginner
Posts: 1
Comments: 11

I used the following requestsoverrides and my system is going to sleep again without fiddling with the schedules or AV settings.

 

powercfg /requestsoverride SERVICE "Acronis Scheduler2 Service" EXECUTION

powercfg /requestsoverride SERVICE AcrSch2Svc EXECUTION

powercfg /requestsoverride PROCESS schedul2.exe EXECUTION

Forum Hero
Posts: 55
Comments: 9123

I have found that the reason for sleep not working on my PC, running a freshly updated version of Win 10 Pro 1909 is because of a power request error which results from the Scheduler2 Service upon restart or cold startup of the machine.  This is true regardless of whether or not the offending tasks revealed by the Schedule Manager tool have been deleted.  In my experience, once deleted these task reappear after a restart or shutdown/cold startup of Windows.

To check for this condition upon Windows startup open a PowerShell admin prompt and run the command 

powercfg /requests

This command will show any errors in the power plan configuration caused be application of hardware.  For applications errors will be shown as

EXECUTION:

[SERVICE] \Device\HarddiskVolume#\ProgramFiles (86)\Common files\Acronis\Schedule2\schedul2.exe (AcrSch2Svc)

To get sleep working as set in your Windows power plan it is necessary to open the Windows Services App.  In the Search field type Services, then select the Services App from the results. In the Services App locate Acronis Schedule2 Service. Click on it to select it.  On the left side a description of the service will appear along with two options, Stop and Restart.  Click on Stop to stop the service.  Once stopped, you will see your options will change to Start and a notification should appear on your desktop screen telling you the service has stopped.  Click on the Start option to start the service again. 

Once started again you can close the Services App.  Now run the PowerShell command and the result will show the error is now gone.  Normal sleep will now be working.

Forum Hero
Posts: 55
Comments: 9123

Frank,

Are the overrides you applied persistent?  In other words do they still work after a restart or a shutdown/cold start?

Beginner
Posts: 1
Comments: 11

Yes, they are persistent across reboots.

Forum Hero
Posts: 55
Comments: 9123

Thanks, I will give those a try on mine and see if the same holds true.

Forum Hero
Posts: 55
Comments: 9123

Frank,

Well, I gave your commands a try.  They were all accepted however, I found them not persistent. Additionally they introduced a new error for me. I now find an error in

PERFBOOST:

[DRIVER] Legacy Kernel Caller

Power Manager

This is shown with command powercfg /requests

 

I was able to reverse this by running the following:

powercfg /requestsoverride SERVICE "Acronis Scheduler2 Service"

powercfg /requestsoverride SERVICE AcrSch2Svc

powercfg /requestsoverride PROCESS schedul2.exe

EDIT: to clear the PERFBOOST error above I had to modify the last command above by changing PROCESS to SERVICE

Forum Hero
Posts: 55
Comments: 9123

New release version 30480 fixes the sleep mode issue.

Forum Star
Posts: 159
Comments: 1566

I've installed 30480 on two laptops, one running Windows 10 1909 and the other Windows 10 2004. Sleep is working on both.

Forum Hero
Posts: 55
Comments: 9123

Bruno,

Do you have Protection turned ON?  With my original install of 30290, Protection was turned ON by default.  I think that is why I could never get it to clear the prevent sleep instruction.  I have not tried turning Protection on yet with this new build, it was OFF by default.

Forum Star
Posts: 191
Comments: 4544

Good, I was told that this build would fix the problem - it was released a bit earlier than I expected. Less than a week between the time I reported it and the time it was fixed. They seem to have engineers working 24/7 at the moment I did a TeamViewer session 2 days ago and it 5.30 am in Moscow. 

Ian

Beginner
Posts: 2
Comments: 7

Hello,

powercfg /requestsoverride SERVICE "Acronis Scheduler2 Service"

powercfg /requestsoverride SERVICE AcrSch2Svc

powercfg /requestsoverride PROCESS schedul2.exe

and ATI2021 Protection OFF (all items switched Off)

works for me

I'll try New release version 30480 later today

 

Regular Poster
Posts: 4
Comments: 176

@Luk

Has been fixed with the version

Legend
Posts: 106
Comments: 26325

I can confirm that the sleep issue looks to be fixed for the systems I have installed #30480 on so far but will do further checks as I update my other ATI 2021 boxes.

Forum Star
Posts: 159
Comments: 1566

Enchantech wrote:

Bruno,

Do you have Protection turned ON?  With my original install of 30290, Protection was turned ON by default.  I think that is why I could never get it to clear the prevent sleep instruction.  I have not tried turning Protection on yet with this new build, it was OFF by default.

I have protection turned off (as I'm running Avast).

 

Forum Hero
Posts: 55
Comments: 9123

Thanks Bruno,  Others are reporting this sleep issue fixed as well so I will take that as a issue resolved status.

Beginner
Posts: 0
Comments: 5

Sleep issue seems to be fixed for me with b30480. AV protection off. Just in time, I was about to revert to 2020.

Beginner
Posts: 0
Comments: 1

I am having exactly the same issue. 

Forum Moderator
Posts: 206
Comments: 6600

Arthur Kopelman wrote:

I am having exactly the same issue. 

Hello Arthur,

the issue is fixed in build 30480 https://forum.acronis.com/comment/550605#comment-550605  Please install the recent update.

Beginner
Posts: 2
Comments: 7

ATI2021 - Build30480 : Sleep issue is fixed for me. Active Protection is completely switched off. Up until now, everything seems to be stable.

Beginner
Posts: 1
Comments: 3

Does anyone else still have this issue after installing that fixed build? One of my three PC's has this problem on Build 35860.

 

Protection is turned off.

Beginner
Posts: 0
Comments: 2

Same for me - I installed the update when prompted a few days ago and my computer never sleeps.

Same build 35860 - Windows 10 on Dell micro.

 

Legend
Posts: 106
Comments: 26325

I haven't seen any sleep issues since one of the earlier builds fixed this for my PC's when it was caused by some or one of the hidden background tasks that ATI 2021 introduced.  I would recommend reading back through this topic from around post #10 and perhaps clearing out all the 'extra' background tasks using the Acronis Scheduler Manager (again shown in the further posts later in the topic).

If this issue is only happening on just one of your PC's then there may be something left behind from an earlier build that had the problem?  One quick option, using the Scheduler Manager, is to use the command 'task zap' to clear all schedule manager entries which will stop your tasks from running on schedule along with all the other entries.  See if the sleep issue is sorted, and if so, then reset the schedules for your backup tasks again via the GUI.

Beginner
Posts: 0
Comments: 2

Thanks - the 'task zap' seems to have fixed the issue. I tested by setting sleep to 10 minutes.

I have set my sleep time back to 1 hour and re-enabled the anti-virus and will keep an eye on it.

Beginner
Posts: 1
Comments: 3

Steve Smith wrote:

One quick option, using the Scheduler Manager, is to use the command 'task zap' to clear all schedule manager entries which will stop your tasks from running on schedule along with all the other entries.

Thanks Steve. I hadn't used any prior versions as I'm new to ATI but that seems to have resolved it. Did the task zap and then set up my scheduled backups again and the PC appears to be sleeping (at least it has the last 2 days). 

Beginner
Posts: 6
Comments: 16

I have three computers that can no longer go to sleep. When is Acronis going to fix this problem?

Legend
Posts: 106
Comments: 26325

Edward, have you tried any of the suggestions given in this topic above?

I am not seeing any issues with my own PC's running ATI 2021 going to sleep, and not seeing other users reporting this type of issue in the forums.

Beginner
Posts: 6
Comments: 16

I tried all the suggestions but the problem came back the next day.

One computer had unrelated crashing issues. I had to do a complete Windows 10 resinstallation on it. When I was done I reinstalled Acronis True Image 2021 (Build 35860). I set up the backups from scratch. It would not stay asleep after that. That is not good because this is a laptop and it is annoying for the battery to run down instead of sleeping.

I have three computers that wake up at midnight and do a backup using ATI. They should go back to sleep after the backup is done. Unfortunately every morning they are still awake when I check on them. To get them to sleep again I have restart Scheduler2 on each one. I have to do this each morning because Scheduler2 stops sleep after every backup.

If this problem is not resolved soon I going to uninstall the three copies of ATI 2021 and resinstall the old copies I have of ATI 2017 and 2018. t least they let my computers stay asleep.

Is there any way for Acronis to let me know when the problem is fixed for sure?

Legend
Posts: 106
Comments: 26325

Edward, if restarting the Scheduler2 service will help resolve this sleep issue for your PC then there is a way that this can be automated at the end of your backup by using a combination of a Post Command along with a Windows Task Scheduler task which runs the service restart.

The Post Command is as below: WriteEvent.bat

@echo off

eventcreate /L "Windows PowerShell" /T Information /ID 002 /D "Acronis backup finished"

exit /b 0

The Task Scheduler also uses a small batch file: RunPS.bat

@echo off

set PS="c:\windows\system32\WindowsPowerShell\v1.0\powershell.exe"
set script="D:\RestartService.ps1"

%PS% -ExecutionPolicy RemoteSigned -windowstyle Hidden -file %script%

exit /b 0

In the above script, a small PowerShell script is used to perform the restart of the Scheduler2 service: RestartService.ps1
Note:
the user should adjust the script location(s) for these script files.

# PowerShell cmdlet to Restart the Scheduler2 service
Clear-Host
Start-Sleep 30
$srvName = "AcrSch2Svc"
Restart-Service $srvName -Force -ErrorAction SilentlyContinue
Write-EventLog -LogName "Windows PowerShell" -Source "PowerShell" -EventID 3001 -Message "Acronis Scheduler2 restarted"

exit 0

The key part of the Task Scheduler task Restart Scheduler 2 service is the Trigger which is used to launch the RunPS.bat script where the trigger is the Event Log ID created by the WriteEvent.bat script for the Post Command.

See the attached screen images from my Windows Task Scheduler for the task:

Attachment Size
566077-210844.png 75.19 KB
566077-210845.png 46.67 KB
566077-210848.png 67.3 KB
566077-210850.png 44.44 KB
566077-210852.png 88.87 KB
566077-210854.png 81.6 KB
Beginner
Posts: 6
Comments: 16

Apparently restarting Scheduler 2 service is not a fix because when I got up this morning my two desktops computers were awake when they should have gone back to sleep after the scheduled backup at 12:05am.

Last night after my main desktop had finished its backup I restarted Schedl2. The powercfg command verified that there was nothing to prevent sleep. Something happened after that to keep the computer from sleeping.

=======================================================

My laptop does a backup at 6:01pm every day. I shut it off a few hours later. Note before I shut it off I try to check to make sure the backup is done.

I just turned on my laptop. I ran the following command: powercfg -requests and go the following result:

DISPLAY:
None.

SYSTEM:
None.

AWAYMODE:
None.

EXECUTION:
[SERVICE] \Device\HarddiskVolume3\Program Files (x86)\Common Files\Acronis\Schedule2\schedul2.exe (AcrSch2Svc)
Acronis Scheduler2 Service

PERFBOOST:
None.

ACTIVELOCKSCREEN:
None.

I restarted schedul2. Now the output is this:

DISPLAY:
None.

SYSTEM:
None.

AWAYMODE:
None.

EXECUTION:
None.

PERFBOOST:
None.

ACTIVELOCKSCREEN:
None.

At least my laptop will sleep now. However, that is only temporary because later on ATI will trigger some event to prevent sleep again.

Why has Acronis not fixed this problem yet?

Legend
Posts: 106
Comments: 26325

Edward, I am not seeing this issue with sleep on any of my own laptops etc which all wake up to perform backups then go back to sleep again.

Acronis will only fix the issue for you if you have opened a Support case with them to allow collection of all relevant diagnostic data needed.  Otherwise they will regard all reported issues in this area of sleep to have been resolved already with the existing new updates for ATI 2021.

Running powercfg -requests on my main laptop shows no mention of the Scheduler 2 service.

PS D:\powershell> powercfg -requests
DISPLAY:
None.

SYSTEM:
None.

AWAYMODE:
None.

EXECUTION:
None.

PERFBOOST:
None.

ACTIVELOCKSCREEN:
None.

Beginner
Posts: 6
Comments: 16

Do I need to do three support cases since all three of my computers have this problem?

I submitted Support Request for my primary desktop computer. I couldn't attach System Report because it was too large. It is 43MB  when max size allowed is 25MB.