Skip to main content

Upgrade installation fails to register mapi_proxy_32.dll, HRESULT-2147024770

Thread needs solution
Posts: 1
Comments: 0

Upgrading from True Image 11 Home initially. Received the error described in the Title. Uninstalled the complete product, removed the folder from the Program files folder, used Eusing Free Registry Cleaner to clean up the registry and restarted the system so I'd have a clean version of XP (SP3) (all MS updates installed).

Reinstalled True Image 11 Home, and the installed the upgrade again. Same failure.

Went through the same steps to completely remove all traces of both True Image 11 Home and also the True Image 2011 Home upgrade.

This time I decided to skip installing True Image 11 Home and just install the True Image 2011 Home upgrade. Only difference was having to insert the True Image 11 Home serial key in addition to the True Image 2011 Home serial key. Installing this way didn't change the end result, I received the same error message. This time, I clicked IGNORE and let the program finish installing. No other errors, however, I haven't tried actually using the program yet, I wanted to check the Support area for any solutions to this problem. No luck, someone else has posted a topic on the same problem, (2010_12_16), but using the free version of the product. There's been no reply so I'm guessing Acronis just ignores problems associated with the free version. Since I paid for both the initial version of True Image 11 Home, as well as for the True Image 2011 Home upgrade, I'm hoping they'll consider looking into this problem.

0 Users found this helpful
Forum Star
Posts: 24
Comments: 3268


Hello Thomas!

Welcome to our Forum, we're glad to greet you here! I understand your concern, and will do my best to address it properly.

I've checked all our internal resources, and found no mention of a known issue that would match your description. Actually, you and John Kenney are the only ones who reported about this problem. Still it's considered to be a minor issue, which should affect the product productivity: the *.dll mentioned is not required for processing the backups, restores and other main product procedures.

Since this is an unknown issue, it requires investigation. But before we proceed with obtaining the diagnostic information, I'd like to offer you a workaround: 

The error indicates the glitch of some component that is required for successful registration of the mapi_proxy_32.dll. Unfortunately due to the lack of diagnostic information I cannot say which one, but we can solve this problem by doing the following:

  1. Download and install CCleaner - it's  free
  2. Run CCleaner, and then go to Registry tab. Select all the options mentioned (Missing shared dlls, etc..) and click "Scan for issues"
    It will scan your registry for existing issues
  3. As soon as the scan is finished, please select the entire list and click "Fix selected issues"

After that please either restart the installation file and select "Repair" option, or register the *.dll manually: 

  1.  Go to Start -> Run
  2. Issue there the following command:
    regsvr32 <path & filename of dll>
    Default path of the mapi_proxy_32.dll is C:\ProgramFiles\Acronis\TrueImageHome\mapi_proxy_32.dll, so the command should look like
    regsvr32 C:\ProgramFiles\Acronis\TrueImageHome\mapi_proxy_32.dll

This should fix the problem.

We would also appreciate a chance to investigate the issue, and would be very grateful if you could send us the following information: 

  1. Acronis Info
  2. MSI log

from the problem machine.

Should you need anything else or have any further questions - feel free to contact us at your earliest convenience, we will be happy to help you!

Thank you!

Posts: 0
Comments: 1


I own three licenses of TI Home 11 and experience the same problem in one of my three XPSP3 machines. Did you find any solutions? CCleaner did'nt help. Also TI 10 did'nt have any problems.

Thank you

Posts: 0
Comments: 1


I have the same problem with the installation of Acronis True Image 2012th
I bought three licenses ..

Thank you

Posts: 1
Comments: 2


I have the same problem. I tried to upgrade overtop 2011. I tried after removing 2011. I tried after running your cleanup tool. All to no avail. I have sent in a support request.


Posts: 1
Comments: 2


After weeks of working through this with tech support, it's been resolved.

During the troubleshooting, it was decided that I should install Outlook 2003 to see about getting the files corrected.

During this process, I realized what the problem was. I use Eudora for email. It's been around a lot longer than any MS mail products, and has it's own mapi server.

When this was disabled, and Outlook was installed, Acronis finished it's install.

Eudora mapi server is back on, and they all seem to be happy together now.

Hope this helps someone with their problems.


Posts: 0
Comments: 1


Earlier this week, I tried again to upgrade from TIH 9.0 to TIH 2011, after I thoroughly removed all traces of TIH 9.0, using Revo Uninstaller Pro. The TIH 9.0 uninstall went fine, and everything related to Acronis was removed from my PC and registry.

I'm using Win XP 32-bit SP3, with 4GB of RAM, on my PC.

I first tried to upgrade from TIH 9.0 to TIH 2011, using my original downloaded version of TIH 2011, dated 11-26-2010. When that did not work, because of the failure to register the mapi_proxy_32.dll file, I again removed everything related to Acronis using Revo Uninstaller Pro. The uninstall worked fine.

Then, I downloaded TIH 2011, Build #6942, and tried to upgrade again, disconnecting from the Internet and shutting off my virus protection program. Again, this version of TIH 2011 did not install properly because of the failure to register the file, mapi_proxy_32.dll, with the HRESULT-2147024770, Contact Your Support Personnel, error message. 

I hit Ignore, and the install proceeded. But, the TIHLauncher.exe program would not start or run from the icon on the desktop. The TrueImage.exe program would not start when I double-clicked on the file.

I searched the Forum for info on this problem and found this thread.

I tried to manually register the mapi_proxy_32.dll file, as noted in Yana's post #1 above. But, I could never get the mapi_proxy_32.dll file to register, no matter what I did. I could see the mapi_proxy_32.dll file in the TrueImageHome folder. I tried the following commands (one at a time) in the Start - Run box:

regsvr32 C:\ProgramFiles\Acronis\TrueImageHome\mapi_proxy_32.dll

regsvr32 "C:\Program Files\Acronis\TrueImageHome\mapi_proxy_32.dll" (with quotes because of the space between the words Program Files)

I even tried to register the mapi_proxy_32.dll file by placing it in the C:\Windows\System32 folder and using this in the Start – Run box:
regsvr32 C:\Windows\System32 folder\mapi_proxy_32.dll

None of these commands worked. Because the upgrade failed to complete properly, I again removed everything involving TIH 2011, using Revo Uninstaller Pro, and went back to TIH 9.0, which still works fine.

I’m at a loss to see why the mapi_proxy_32.dll file will not register.

How can I get TIH 2011 to install properly?
What am I doing wrong?

Is there something else I can try, to install my copy of TIH 2011?

Forum Member
Posts: 0
Comments: 27


Dear Jerry!

Thank you for using Acronis products.

In order to resolve this issue please do the following:

1- Download the latest build of the product from your personal account at Follow this link for more information.

2- Install the product as follows in this instructions.

3- If the issue persists, make sure you have fixmapi.exe in your machine and then run it in order to fix it: C:\Windows\system32\fixmapi.exe

If there is something else I can do for you, please let me know.

Thank you, have a good day!