Skip to main content

Code 39 error on usb external drives and flash drives with tdrpman273 problem.

Thread needs solution
Posts: 1
Comments: 2

Running Windows 7 Professional 64 bit

I purchased ATIH2011 around two weeks before ATIH2012 was available, and have upgraded.

I have had problems with on-line back up which I have tried to get working successfully, and it is much better since purchasing on-line storage rather than the free trial, although it does pick random folders and uploads them from time to time.

I have a problem now which results in no usb hard drives of any type working. This applies to iPod, Blackberry, WD usb3 and usb2 external hard drives and Sandisk Cruzer. All were working until yesterday morning when I found non-stop backup had stopped. Reason being the usb3 hard drive was no longer connected.

Internal raid array and internal data hard drives work correctly.

Device manager properties reports 'Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)'. I did have code 39 errors with XP, but it was related to cd/dvd drives, not hard drives.

Uninstalling drivers and reinstalling makes no difference.

Computer Management / event viewer / reports:-

The driver \Driver\tdrpman273 failed to load for the device USBSTOR\Disk&Ven_WD&Prod_My_Book_3.0_1123&Rev1006\574d159303039383335350&0

It seems tdrpman273 is related to ATIH2012 Try & Decide.

Has any one seen this issue, and if so, how did you resolve it.

I don't want to dump ATIH2012 because it does everything I need, in a simple easy to use GUI.

Any help appreciated.

0 Users found this helpful
Posts: 1
Comments: 2


Further to my above post, it seems all I need is the tdrpman273 driver. I have removed ATIH2012 with the removal tool and re-installed, but still get the same error. Where do I find this driver?

Looking in Windows / system32/ drivers/ I find can only find tdrpman.sys

Administarative events report that The following boot-start or system-start driver(s) failed to load: tdrpman273

Many thanks.

Regular Poster
Posts: 13
Comments: 314


For reasons unknown (to me at least) it appears that TIH2012 installs two (2) "Try&Decide Volume Filter Driver" files into the Windows/system32/drivers/ subfolder. Their filenames are tdrpm273.sys (version and tdrpman.sys (version However, only the latter file is listed under my registry's HKLM\SYSTEM\Services key for direct loading on system start-up. Is your registry attempting to load both?

Also, for the 64-bit version of Windows 7, the registry should include "WOW64"=dword:00000001 for that tdrpman service entry. Does it?

And lastly, I've found to my own sorrow that Western Digital's external "My Book" drives and their built-in controller cards do have a few compatibility issues of their own. Do you see similar problems with other externals?

Posts: 1
Comments: 2


Thanks for your help Richard.

The problem was when ATIH was uninstalled in did not completely remove the registry entries for the vidsflt58 or tdrpman drivers. I was able to get my system working correctly after removing these entries from the registry as per Acronis KB14871.

Reinstalling ATIH2012 led to the same problem occuring again, so sadly ATIH2012 is destined for the bin.

It is a cracking program, but sadly it just does not work for me.

Regular Poster
Posts: 13
Comments: 314


Glad to hear that you managed to sort things out for yourself, Shaun. Might be worth another try after they release the first or second TIH2012 "bug fix" revision if you're still interested by then.

As for incomplete uninstalls, they do offer a "cleanup" utility that might help. Main thing is to get rid of all the old Acronis driver services making sure that the HKLM\SYSTEM\Services entries have been removed from the registry. Only then is it safe to get rid of the old driver files themselves.

Posts: 0
Comments: 20


Hi Richard and all,

I think I have the same problem as Shaun had --

1) I'm running W7 HPE SP1 x64 on a HP Pavilion dm4 laptop.
2) USB storage devices do not show in Disk Management, nor do they show in Windows Explorer. When introduced to USB, I get the "code 39" designation and yellow triangle for each device I attempt to introduce. Uninstalling, "scan for hardware changes" etc did not work.
3) Non-storage-related USB devices (wireless mouse, scanner, etc) are recognized and perform normally.
4) I also have the following TIH installation history:
a) Installed TIH 2012, got bsod immediately on first reboot
b) Uninstalled TIH 2012
c) Performed "clean-up" utility
d) Installed/uninstalled TIH 2011 a few times. Installation was successful but USB ports failed to mount USB storage devices.
e) Called Acronis 3 times -- they wanted me to install TIH 2012 (build 6131) which I did, which installed successfully, but USB storage devices still not working.
f) So my current state is TIH 2012 (build 6131) with USB storage devices not working (see #1 above).
5) I've checked registry key {36FC9E60...} and find no "LowerFilters" or "UpperFilters"
6) I've checked registry key {4D36E967...} and find "LowerFilters = vidsflt58 vidsflt61 hpdskflt" and "UpperFilters = tdrpman258 PartMgr tdrpman258 (again, it is there twice!) fltsrv}

7) I was going to delete the key in #6, but thought better of it after reading your caution!

So what can I do to PLEASE get my USB storage devices running properly once again? It is interesting that I can correctly mount an external eSata volume. Any help would be enormously appreciated!

Forum Hero
Posts: 87
Comments: 9255



I faced the same issue when installing 2012 the first time. The way I resolved it may not be the silver bullet.
- I restored an image that I had with 2011 installed,
- I turned off my security software,
- I installed 2012 on top of 2011.

That solved it for me.

Posts: 0
Comments: 20


That's interesting, Pat. May I inquire as to what "security software" you are/were running? I have Norton Internet Security ("NIS"). Did you just happen to try the "2012 on top of 2011 with no security software" solution, or was it one which you were advised to try? Thanks so much for your help! -Dennis

Forum Hero
Posts: 87
Comments: 9255


Actually I have Norton 360. Typically, when you upgrade ATI, it is better to uninstall the previous version and then install the new. When I did that, I left Norton on, and the installation was a disaster: couldn't see the disk, had all these driver issues you describe with my card reader, etc. This is when I tried the solution above.

Posts: 0
Comments: 20



Let the heavens rejoice! (Although I think the heavens have more to worry about than the slipshod work of Acronis developers, frankly! : )

My "code 39"s are gone! My USB ports are active again, and appear to be working normally!!!

Here is what I did, and a BIG debt of gratitude to Richard Virtue especially for most of the inspiration for this, as shown here (, 11/19 post). I think there is one mistake in his script however. Here is what I did:

1. Edit Registry - Class - Disk Drives - Lowerfilters - deleted all references to Lowerfilters vdsft* (I had two such references from garbage from earlier installs of 2011 apparently)

2. Edit Registry - Class - Disk Drives - Upperfilters - deleted TWO references to tdrpman256 (I have no idea why the identical driver appeared twice)

3. Edit Registry - Class - Storage Volumes - Lowerfilters - deleted the one reference to tdrpman258.

4. Reboot - voilà !

Those 3 actions were enough to reactivate my USB ports, and thank heavens I have a functioning system again!!

Acronis is gone, gone, gone!! An Acronis product will never EVER be installed on a system of mine EVER again. The very people who sell SECURITY almost wrecked my system. This is unacceptable. We rely on the CORE functions of ATIH to safeguard our precious data, and instead it nearly destroyed me. Their tech support it turns out was pretty much worthless to me and mostly a waste of time. It was Richard Virtue actually who saved me.

NOW I have a big question to pose to everyone here on the forum. Now that Acronis is gone, gone, gone, the question is -- what the heck am I going to do for backups?? I have begun to rely more and more of course on cloud backups of critical data -- I am a big fan of DropBox and also use iCloud. However, I am old fashioned enough to want to have some physical media not in the cloud as the ultimate backup. Unfortunately there is no peer to Acronis in terms of functionality as best I can tell. I loveD the email notification feature, the virtual disk mount of backup volumes, and well, let's just say I will miss ATIH. So what shall I move to?

Regular Poster
Posts: 13
Comments: 314


Glad to hear that you were able to get it all sorted out, Dennis. It's not so much a mistake in the script that you linked as it is an impossiblity for any single script to cover all of the situations that can arise from various Acronis "leftovers" in the registry and elsewhere -- some of which can, in fact, be fatal or nearly so. As a single user, I simply don't know enough precise details about the total range of catastrophic possibilities and their permutations, and I'm not ungrateful for that small mercy.

As for an alternative, you could try Win7's own Control Panel > Backup and Restore, at least as a temporary protection measure, assuming you can get that native Win7 feature working after uninstalling ATIH. Check it out. It doesn't have all of the "bells and whistles", but it does seem to work dependably with any hardware supported by Windows itself. I'm currently using it as part of my own "belt and suspenders" protection scheme while awaiting further Acronis developments.

P.S.: If your native Win7 Backup and Restore doesn't work properly, see et seq. You may need to modify permissions on the registry key as explained in that thread.

Forum Member
Posts: 6
Comments: 30


Dennis: I share your gratitude to Richard. He saved my two computers. As for other backup options, I have gone with Paragon Hard Disk Manager 11 Suite. It is essentially both Disk Director and ATIH in one package, at less price than either Acronis product individually. The interface is not as intuitive and it does have its own "eccentricities" but it has worked well for me so far. The help file is not all that helpful.

I also took Richard's advice and did a Windows Backup and Restore, once I had done the registry hack to get Acronis "deintegrated" and get it working. I never again want to have all my backups in one proprietary container.

Hope this is of some help ... and thanks again, Richard! Have a great day.


Posts: 1
Comments: 2


Hi all,

I solved the same problem even easier.

I ran Regedit with administrator rights. Searched for "tdrpman273" throughout the registry and deleted the "tdrpman273" word where ever I found it.

And hé presto! All works well again.

Thanks for your input, Dennis and Richard.

Paul Guijt
The Netherlands

Posts: 0
Comments: 1


I realize this is a "late to the game" post but I stumbled upon this thread googling because I too had this issue where the USB drives would not install when plugged in. This thread gave me some insight as to what I was seeing when the driver was unsuccessfully being installed and also from the Sysinternals Autoruns. My problem came after I had some issues with NIS2012 and had their support try to resolve the issue. After they had done numerous things thru remote connections I discovered afterwards that my USB hard drives would not work. I was getting the code 39 which led me this thread. I had also seen other threads where it stated to remove the lower/upper
registry settings to see if that worked. I saw in this thread where the tdrpman273 showed up in Autoruns as not loading and ran Autoruns to see that it also showed up in mine. I too use acronis but did not uninstall the product. Luckily I found a copy of tdrpman273.sys in a backup windows directory and copied that missing file to the drivers section of the current windows driver directory. I rebooted and my USB hard drives started showing up.

Posts: 0
Comments: 1


Hi guys, you rescued me too ! 

I had Code 39 with my Acronis Trueimage home 2015 and my external USB drive was not found . 

I went through Dennis Steps:

1. search  Registry for LowerFilters and eventually found a tdrpman258 entry

2. searched Registry - for tdrpman258 and found several entries  - deleted all (> 4)  references  to tdrpman258 from the found keys.

4. Reboot - voilà - USB works again and I can use Acronis 2015 for backups again.

I decided to continue with this installation but probably never to upgrade again !