Direkt zum Inhalt

Qns: Unable to recover VM using command line Util getting error "Unknown Component Error: 0x30002"

Thread needs solution
Beginner
Beiträge: 3
Kommentare: 2

Hi Team,

I was unable to restore vm from backup using command "recover vm". all credentials in the command and servers are accurate , but getting the below error : . Any quick support well appreciated.

 

Command :

acrocmd recover vm --vmname=my_vm_1 --vmserver_name=esxicluster --vmstorage=datastorenameonvcenter --loc=\\server1\Images --credentials="domain\user",pass1 --arc="Archive" --backup=E61C51BD-073D-4B85-B668-F955B4S5GVCV --host=computer1 --credentials=".\Administrator",pass2 --service=ams

 

Error when executing above recover vm command :

An error occurred while executing the command.
    Error: 0x1510008
    $module = "acrocmd_vsa64_16318"
    `anonymous-namespace'::PrintPerformingResult : d:\195\enterprise\command_line\engine\impl\engine.cpp(65)
UnknownComponent
    Error: 0x30002
    $module = "asyncipc_vsa64_16318"
    AsyncIpc::Rpc10Handler::OnRequest : d:\195\enterprise\common\async_ipc\async\rpc10_handler_imp.cpp(430)

 

Thank you !

 

0 Users found this helpful
Forum Moderator
Beiträge: 162
Kommentare: 5708

#1

Hello PCN VA,

sorry for the delayed response! I'd start with checking that the user account specified for backup and recovery in vSphere has all necessary privileges, see Privileges for VM backup and recovery.

Support specialist
Beiträge: 0
Kommentare: 1521

#2

Hello PCN VA.

Please also clarify whether the computer1 as a parameter in your command:

--host=computer1

is the host where this command will be executed. 

Please also check whether the computer1 has Acronis Management Server since you specified

--service=ams

If there is only Acronis Agent component installed on the computer1 machine, then please replace the above parameter with this one:

 --service=acronis_mms

Beginner
Beiträge: 3
Kommentare: 2

#3
Ekaterina wrote:

Hello PCN VA,

sorry for the delayed response! I'd start with checking that the user account specified for backup and recovery in vSphere has all necessary privileges, see Privileges for VM backup and recovery

I would like to let you know our deployment structure first,

four Acronis virtual appliances deployed on vCenter and connected to the same vCenter with service account having all privileges required for restoration and backup. We are not facing any issue when doing backup/restore jobs using acronis cyber backup application UI console, only when recovering vm from command line utility. I am running these commands from where acronis cyber backup deployed management server (Windows deployment with agent).

Please let us know where exactly the problem I am facing with . Thank You!

Beginner
Beiträge: 3
Kommentare: 2

#4
Maria Belinskaya wrote:

Hello PCN VA.

Please also clarify whether the computer1 as a parameter in your command:

--host=computer1

is the host where this command will be executed. 

Please also check whether the computer1 has Acronis Management Server since you specified

--service=ams

If there is only Acronis Agent component installed on the computer1 machine, then please replace the above parameter with this one:

 --service=acronis_mms

Yes, --host=computer1 is parameter in the command where the Acronis Management Server Service running. Also from the same computer we are executing the command too.