Direkt zum Inhalt

Dependency issue on older 2.4 installations (CentOS 7 - epel)

Thread needs solution
Forum Member
Beiträge: 9
Kommentare: 50

Hello,

I ran a yum update on our older v2.4 Acronis storage servers, and there's a dependency issue with the latest oniguruma package that epel provides and archive3 requires.

---> Package oniguruma.x86_64 0:5.9.5-3.el7 will be updated
--> Processing Dependency: libonig.so.2()(64bit) for package: archive3-1.5.29-1.as7.x86_64
--> Finished Dependency Resolution
Error: Package: archive3-1.5.29-1.as7.x86_64 (@vstorage-updates)
           Requires: libonig.so.2()(64bit)
           Removing: oniguruma-5.9.5-3.el7.x86_64 (@epel)
               libonig.so.2()(64bit)
           Updated By: oniguruma-6.8.2-1.el7.x86_64 (epel)
              ~libonig.so.5()(64bit)

Is v2.4 completely unsupported now, or is there a change of a fix?

1 Users found this helpful
Acronis Engineer
Beiträge: 0
Kommentare: 2

#1

Hello George,

In accordance with documentation article ( https://dl.acronis.com/u/storage2/html/AcronisStorage_2_admins_guide_en-US/managing-storage/managing-updates.html ) it is strongly recommended to perform update procedure via UI, since manual "yum update" without proper preparations may lead to unexpected system misbehavior. You can also see how to prepare for upgrade from 2.4 to 2.5 version from the following KB article - https://kb.acronis.com/content/62188 . Have in mind that 3-rd party repositories (like EPEL) are strictly not allowed to be enabled during upgrade procedure. If some problems caused by "yum update" command appeared, feеl free to open a ticked to our support team, they will assist you with fix.

Have a nice day!
Borislav