Direkt zum Inhalt

My USB drive - any drive - comes up as Acronis Drive... and I do not like it. Attn: Steve Smith

Thread solved
Beiträge: 2
Kommentare: 3

The subject says it all.  I plugged in a USB thumb drive that is used exclusively to hold MP3 files that I plug into my car - it has never been used as a backup device - and instead of showing up under Devices and Drives like it always has, with a proper drive letter, it is now showing up under Network Locations, with no drive letter, and now named Acronis Drive.

As I stated in the subject, I do not like it.  I do not use USB drives for backups from my PC, and I never have.  I back up either to my NAS or to the cloud.  Up until recently, this wasn't an issue.  I did recently upgrade to True Image 2019, so I'm not sure if that may be the cause.  I've tried to find out how to turn this totally unwanted option off, but I cannot find anything about it, just some link to change the drive letter in True Image 2017 which involved way too much work for something I never asked for in the first place.

Is there a way to turn this off, to let my USB drives be normal USB drives again, with drive letter that are shown, and located in the correct place?

*** I apologize for double posting this, I clicked the "mark as solution" button a little hastily, as the solution that Steve Smith had given didn't work for me.  I disabled both services, but neither of them were running in the first place, so that didn't solve the issue.  Also, it was mentioned that the default drive letter is M:, but mine is set to H:, which is the default USB drive letter.  As a side note, the drive does work correctly, although I cannot look at the properties to see drive size, etc. ***

Thank you very much in advance for any help in this matter!

0 Users found this helpful
Beiträge: 100
Kommentare: 22058


The forum moderator is aware of the issue with marking topics as solved preventing any further updates and this is being worked on to allow the original poster to have a change of mind!

Strange that Acronis Drive is taking the drive letter H: as that suggests that someone has followed the steps in the KB document to make that change.  Acronis Drive has always been M: on all of my computers with ATI installed with all default options.

I tried following the steps from the KB to change my Acronis Drive from M: to Z: then did a restart and found that it was still showing as M:....!

Going back to basics here, can you display the Properties for Acronis Drive on your computer and check that it is this that is using drive H: and not the default of M: ??

Beiträge: 2
Kommentare: 3


Hi Steve, thanks for the response.

I checked, and it does show as H:.



I inserted another USB stick and went into Disk Management and changed the USB stick to I:, so that now shows up correctly, and Acronis Drive is still sitting there at H:. 

I don't have anything that needs to access the USB as a specific drive letter so this will work for me, but I'm confused as to why it's still there with the services disabled.  And why it's H:.

Thanks again for your help!

*edit*  It no longer shows as H:, it is now showing as being located in %APPDATA%.  Setting the USB back to H: doesn't change the Acronis Drive letter back, but now my USB doesn't show up as a drive, unless I set it to something other than H:.  Very odd.

Beiträge: 2
Kommentare: 3


Thanks again for your help, Steve.  I ran into the same issue that you did with the mapping not working, but when I tried it again it worked fine.  I think the issue is I already have my M: drive mapped to a network share, and then Acronis Drive just grabbed H.  My USB drives now show up as H: as they should, and I no longer have any Acronis Drive shortcuts showing up.

I'll mark your answer as a solution.