31213: [RESOLVED] samba and ntlmv1 problem

8 replies [Last post]
Nicolas Di Gregorio
Offline
Beginner
Joined: 2011-09-16
Posts: 6

Hello,

I've a nas running under gentoo that share folders with samba to windows 7 laptop. I can access the shares with windows 7 without any problem. I'm using acronis true image to backup my laptop on the gentoo nas and it does not work(access denied). When looking in samba logs I see this:

[2012/04/16 20:20:43.936984, 0] ../libcli/auth/ntlm_check.c:54(smb_pwd_check_ntlmv1)
smb_pwd_check_ntlmv1: incorrect password length (72)

here is my configuration /etc/samba/smb.conf:
http://pastebin.com/AsiN9gQu

Can anyone help me to fix that issue?


Mark Wharton
Mark Wharton's picture
Offline
Acronis MVP Volunteer
MVP
Joined: 2009-08-15
Posts: 1979

Nicolas:

It may be because TI runs as SYSTEM instead of as a user, and your NAS may reject the SYSTEM credentials or the authentication method being used by the system. You may want to try the "universal" Vista/Windows 7 authentication fix. By default, Vista and Windows 7 use only NTLMv2 authentication, and not all NAS boxes support NTLMv2. I see that your log contains an error message from NTLMv1, so that's a clue.

Try setting your Windows 7 PC to use NTLMv2 security only if negotiated. To do this, go to the following registry key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\LSA\ and change LmCompatibilityLevel from "3" to "1". If the key does not exist, create it.

__________________

Acronis TI 9, TI 10, TI 2011, TI 2013, TI 2014, TI2015, TI 2016, DD 10, DD 11, DD12 user. Amateur Radio K0LO


Nicolas Di Gregorio
Offline
Beginner
Joined: 2011-09-16
Posts: 6

I tried to change the registry key but it does not work.

Remember that I can access the shares from windows explorer.

Any other idea?


Mark Wharton
Mark Wharton's picture
Offline
Acronis MVP Volunteer
MVP
Joined: 2009-08-15
Posts: 1979

Nicolas:

Make sure that you have rebooted the PC after changing the registry key.

Some other troubleshooting suggestions are here: http://sourceforge.net/apps/phpbb/freenas/viewtopic.php?f=46&t=5782

When you are backing up, are you using the recovery CD version or the Windows version of TI 2012?

There is a large thread with various NAS issues on this forum here: http://forum.acronis.com/forum/24769

__________________

Acronis TI 9, TI 10, TI 2011, TI 2013, TI 2014, TI2015, TI 2016, DD 10, DD 11, DD12 user. Amateur Radio K0LO


Nicolas Di Gregorio
Offline
Beginner
Joined: 2011-09-16
Posts: 6

Hello,

Nothing of the posts that you gave me worked. I think I'll stop using true image home, it have more and more bugs, I'm sick of it. Every updates broken more stuff..

Anyway, thanks for your help!


caustic
Offline
Beginner
Joined: 2010-12-19
Posts: 12

I know a little bit late but I say better late then never.

set lanman auth to Yes in global section of smb.conf

lanman auth = Yes

After this I was able to connect and store with my logindata for backing up.
you can tryout theses two settings too (global section):
client lanman auth = yes
client plaintext auth = yes

Nevertheless, I'm getting a short disconnect of my networkdrives when Acronis begins to work.


Nicolas Di Gregorio
Offline
Beginner
Joined: 2011-09-16
Posts: 6

You gave me some hope but it does not work for me.

Maybe I'll try out to go back to the 2011 version, it worked at a time..


caustic
Offline
Beginner
Joined: 2010-12-19
Posts: 12

Hi another try... ;)
in your smb.conf there is an entry security this is set to share tryout this:

security = USER

Which sambarelease you are using?


Nicolas Di Gregorio
Offline
Beginner
Joined: 2011-09-16
Posts: 6

Hello,

It works!

Great thanks