5940: Howto do backup generations (GFS-Grandfather,Father,Son) with Acronis TI. (chain2gen)

250 replies [Last post]
oracledba
Offline
Regular Poster
MVP
Joined: 2009-09-16
Posts: 240

groverh requested a change to the comments with script my_acronis_pretask.bat The file with the revised comments has been republished into the v2.5 zip. There is NO code change to script just the addition of a comment block. Normally any change to code would mean a change to the versions number. However in this one instance I made an exception because many people just upgraded to v2.5 and there is zero need for them to think they need to upgrade yet again.

Hope
Offline
Forum Member
Joined: 2009-08-30
Posts: 98

@oracledba
I've decided to try the full backup on Sunday scenario because I'm scheduling a defrag on Sunday prior to the Sunday full Acronis backup, but do I need to put BOTH of these lines in the .bat script or only the Sunday trigger line??
set TRGR_ON_MAX_TIB_CNT=7

set TRGR_ON_DAY1=Sun
EDIT:
Nevermind, I just read one of your earlier posts in which you say that it doesn't matter if you have one or BOTH of those lines. I think I'll try the suggestion of setting the count to 10.

Also, am I the only one who has had the notification emails stop with version 2.5? I went back to the previous version and just changed the necessary two .bat files so I could still get my emails from the Acronis software.
Thanks, oracledba, for all the great work you've done.

semko
Offline
Beginner
Joined: 2010-01-21
Posts: 4

@oracledba

Thank you for your very helpful scripts.

I just encountered a little problem with the TrimSpaces subroutines which on my system do not remove any leading and/or trailing spaces from the variables. They seem to work after I changed the for command in TrimSpaces2 to:

for /f "tokens=2*" %%A in ("%*") do set %%A=%%B

Could you please check. Thanks.

Sem

oracledba
Offline
Regular Poster
MVP
Joined: 2009-09-16
Posts: 240

to user hope:
if by "email notifications"
you mean batch script sendemail_on_full_backup.bat.bat

then yes, that file is "owned" by you.
To use this bat file you need to edit that file and change the params to fit your email configuration (ports/server/username/password ect...)
Furthermore that file depends on freeware utility "sendemail" the url to obtain the utility is in comments of your this script.

I do not include the sendemail.exe in the published zip file to you mostly because I didn't want to field questions about is an .exe I supply a virus or not, if anyone wants the freeware utility they can download it themselves and either trust (or not) the source supplier is honest (or not).

you are correct that the virginal sendemail file supplied only contains placeholder values for all email params.

anyone upgrading chain2gen that happens to use the bat to send email on full backup will need to reenter their params into that file. The reason why you need to do this of course is you change the file after downloading. This section could have been written better/more param driven but that wasn't the focus of chain2gen it was a script supplied as a courtsey use it (or not).

oracledba
Offline
Regular Poster
MVP
Joined: 2009-09-16
Posts: 240

to user semko
the original code works on this end.

Instead of filling this thread with code snippets/banter between us lets take a dicussion offline via PM.

However to get us started here is a test script to get our discussion started. on this end at least, variables are trimmed correctly.

@echo off
:: This is a test script to see if code will correctly trim leading/trailing spaces.
::
:: step 1 create a variable containing leading/trailing spaces....
set t1=" the cat in the hat "
:: Remove quotes
SET _string=###%t1%###
SET _string=%_string:"###=%
SET _string=%_string:###"=%
SET t1=%_string:###=%
::
::
:: step 2 write a timestamped record into a logfile displaying the contents of our test variable
:: we SHOULD see the leading/trailing spaces....
echo at %time% before t1=[%t1%] >>logfile.txt
::
::
:: step 3 make the call to trim spaces...
call :TrimSpaces t1
::
:: step 4 write a timestamped record into a logfile displaying the contents of our test variable
:: we should NOT see the leading/trailing spaces....
echo at %time% after t1=[%t1%] >>logfile.txt
::
::
::
type logfile.txt
exit /b
::
::
::
::
:TrimSpaces varref -- trims spaces around string variable
:: -- varref [in,out] - variable to be trimmed
::$source http://www.dostips.com
call call:trimSpaces2 %~1 %%%~1%%
EXIT /b

:trimSpaces2 retval string -- trims spaces around string and assigns result to variable
:: -- retvar [out] variable name to store the result in
:: -- string [in] string to trim, must not be in quotes
::$source http://www.dostips.com
for /f "tokens=1*" %%A in ("%*") do set "%%A=%%B"
EXIT /b

semko
Offline
Beginner
Joined: 2010-01-21
Posts: 4

@oracledba
Thank you for your test script which did remove the spaces as expected and for the hints you gave me in private messages.

After the test I tried your chain2gen 2.5 version again and this time it worked perfectly without any changes. I have no idea what caused my problem the other day.

So, sorry for the false alarm and thanks again for your help and patience.

Sem

Rick W
Offline
Forum Member
Joined: 2010-01-26
Posts: 33

Thanks for this oraclebda! I have been looking for this since I installed my Seagate NAS-220. (My previous backup software, Ghost< had this option.) The Seagate software (BlackArmor Backup) is derived from the Acronis package and the screens in your !readme file sure look familiar.

Do you see any risks of trying Chain2Gen with the BlackArmor software? My guess is it would work ... or it wouldn't.

Thoughts appreciated. Thanks.

Rick

PS: If this was a built-in option in the Acronis package I'd be upgrading!!!

oracledba
Offline
Regular Poster
MVP
Joined: 2009-09-16
Posts: 240

My guess is it would work as expected.

Rick W
Offline
Forum Member
Joined: 2010-01-26
Posts: 33

oracledba wrote:
My guess is it would work as expected.

Thanks for your prompt reply. I'll give it a try and report back in the next day or two.

Rick

Rick W
Offline
Forum Member
Joined: 2010-01-26
Posts: 33

Well I've run into a problem. The validation process passed (as per Figure 5 in the documentation) indicating FYI: Folder does NOT exist. However, when I try to run Acronis_PreProcessing_task.bat I get the following message in the CMD.exe window:

The network name could not be found
The network name could not be found

and Alert:

ctrl c=copy
could not reach device [pushd\\Ba-07xxxx]

Where \\Ba-07xxxx is my network storage device path.

The clipboard string is correct:

\\Ba-07xxxx\Rick\Chain2Gen\Bk_C\set0\

But the PreProcess bombs. Any thoughts?

Thanks, Rick

oracledba
Offline
Regular Poster
MVP
Joined: 2009-09-16
Posts: 240

I have seen the error you mentioned caused via three ways:

1) there is a typo/spelling issue in the \\node\device\folder\ syntax
typically the windows syntax is two slashes followed by the computer name
then a slash followed by the device name
then a slash and the folder structure(s) seperated by slashes.
in your example your computer name appears to be ba-07xxxx
your device name is Rick
and your folder on that device is \Chain2Gen\Bk_C\
assuming there are no typos/mistakes in the above the values
then your userparams file would be look like this...
set TARGET_UNC_N_DEVICE=\\Ba-07xxxx\Rick
set TARGET_GENERATIONS_FOLDER=\Chain2Gen\Bk_C\

2) you have every value typed exactly correct but still to have an issue.
I have seen windows "lose" the ablity to reach a device. I do not know why.
When you see this error if you were to open up windows explorer
and paste that same path name into the address bar of windows explorer it too would fail.
This is a clear indication of a problem. Clearly if the OS itself can not reach the device then chain2gen clearly could not.
When this situation exists if you reboot, all is well with the world once again.
I don't know why this happens, just know if you reboot, windows becomes sane/happy again.
To date I have only seen this with USB drives attached to a docking station with laptops entering/leaving that station.
I suspect an improper dock/undock procedures were being utilized which caused the issue.

3) you have everything typed correctly and windows explorer can reach the target folder but the issue still exists.
in this instance the permissions on the target drive are such that
the account used does not have read/write access. The easiest solution is to use the biggest hammer
and set the root of the usb drive full access to everyone. The are better more sane/secure
ways to give permissions to a drive but that is a discussion outside of simply trying to get things working.

hope this helps.

Philip Avery
Offline
Beginner
Joined: 2009-12-19
Posts: 6

Some feedback following my earlier post and your suggestions.

Everything looked OK but I still couldn't get it to work.

After hours of frustration and bad language, I set up a test system with very little data so that I could create the generations in seconds rather than hours. This worked 'out of the box' but I still couldn't get the 'real' system to work.

Running the bat file manually appeared to work but Acronis still hung. Going through it all again today I got an XP security message! Accepting the file run and off Acronis went.

Let me stress, this is the first time they have shown since I originally accepted the files should run.

Haven't the faintest idea what could have happened with the notifications but it's seems to be an XP thing.

oracledba
Offline
Regular Poster
MVP
Joined: 2009-09-16
Posts: 240

@phillip
Its absolutly an xp thing.
make sure you check and unblock EVERY .bat and .vbs file of chain2gen as not every file is called with every run, if conditions are such that chain2gen calls a new/different portion of the code tree than what was used in prior runs and you havn't unblocked that script then you will have a re-occurance of this same issue.
I don't want you fighting the same problem over and over again.

The above is discussed in post 50 of this thread.
http://forum.acronis.com/forum/5940#comment-17719

Philip Avery
Offline
Beginner
Joined: 2009-12-19
Posts: 6

Thanks for the help and advice, oracledba. Ok, I'm off to unblock them all but it's still curious that it appears a previously unblocked Acronis_PreProcessing_task.bat should have become locked...

Rick W
Offline
Forum Member
Joined: 2010-01-26
Posts: 33

SOLVED!

Rather than fight with the path for my network drive I mapped a directory as Drive: W and SUCCESS!

Now on to the next steps.

Thanks again for the help oracledba.

Rick

Rick W
Offline
Forum Member
Joined: 2010-01-26
Posts: 33

I've set-up a test process and have an image of my HDD with several backups. I did several manual STARTs and all the set0, set1, set2 and set3 folders are now full. (For my Test image Chain2Gen is set to a weekly calendar allowing 3 generations with full backup and NO incrementals).

However, on the RECOVERY menu, there is only one copy of my Test Image. The only link is to the set0 folder. This is the latest copy of the backup. The remainder of the set1-3 are not visible.

Is this normal? If I needed to restore an earlier version, say set3, how would I do that?

Thoughts appreciated.

Thanks - Rick

oracledba
Offline
Regular Poster
MVP
Joined: 2009-09-16
Posts: 240

I don't use the recovery menu, and I've talked to a few dozen acronis users and none of them seem to use it either particularly those doing GFS backups.

for example, lets say you have a file thats fubar and wish to have it back as it looked 3 days ago ( or for that matter 3 weeks ago) use windows explorer find a .tib file in your set0 thru setN folders of the last known good date, double click it to open with windows explorer then browse/drag/drop your way into happyness. Alternatively you can use acronis to mount the .tib as a drive letter then drag/drop the your way into the restore.

If your HD crashes, go buy a new one take out the old insert the new, boot from your recovery CD browse your set0 thru setN folders for backup from the last known good date and use the recoery CD to restore. GroverH's guides 7A and 7B contain great step by step instructions on how to restore backups onto new drives regardless of those drives being the same size or not.

for both of the examples above the recovery menu/catalog was not used.

Rick W
Offline
Forum Member
Joined: 2010-01-26
Posts: 33

Thanks again oracledba! I really appreciate all the assistance and insight into this versatile software.

Take care,

Rick

JohnK
Offline
Beginner
Joined: 2010-02-03
Posts: 2

There appears to be an issue in version2.5 if you try to use a day of the month (option 2) that is less than 10 . The format of the system day, DateDay, in Acronis_PreProcessing_task.bat has the leading 0 (01 through 09). However TRGR_ON_DDx in !_USER_SPECIFIED_PARAMS_FOR_ACRONIS.bat limits the values to 1 through 9 (01 - 09 will not validate). So in the line starting "%TRGR_ON_DD1%"=="%DateDay%" in Acronis_PreProcessing_task.bat you are for example testing 2 against 02 which does not match so the trigger file will not be written and the set will not be advanced.

Hope
Offline
Forum Member
Joined: 2009-08-30
Posts: 98

I'm using version 2.2 with the 2 updated files with the following settings:
set TRGR_ON_MAX_TIB_CNT=10
set TRGR_ON_DAY1=Sun

...and on Sunday an 8th file was created in set0 instead of it starting over with a fullbackup so...I went back to set TRGR_ON_MAX_TIB_CNT=7 and ran it on Monday and it then published a trigger.txt file and created a full backup in set0.

No biggie...just thought I would report this.

Bret19
Bret19's picture
Offline
Beginner
Joined: 2010-01-15
Posts: 5

I am running version 2.5 and I am having the same problem as post #69. I have option #2 set as:
set TRGR_ON_DD1=1

It ignored the February 1 trigger and it is still creating incrementals. I ran the Force New Chain script last night and it worked perfectly. Moved everything from Set0 to Set1 and created a new full backup during the scheduled task.

My trigger of the 1'st of the month does not work.

oracledba
Offline
Regular Poster
MVP
Joined: 2009-09-16
Posts: 240

JohnK & Bret19 - message received I will release a fix.

JohnK
Offline
Beginner
Joined: 2010-02-03
Posts: 2

oracledba

An easy fix for the date problem is to add the two lines:
set DateDay=0%DateDay%
set DateDay=%DateDay:~2%

before the line:
if "%TRGR_ON_DD1%"=="%DateDay%" echo "Hit TRGR_ON_DD1 = %DateDay%">>%trigger_filename%

in the file:
Acronis_PreProcessing_task.bat

The change adds 0 (zero) to the front of the date and then takes the last two characters for the date thus insuring that all dates are 2 characters long. By the way thank you for all your work on this script. It is just what I was looking for. It is a great enhancement to TrueImage.

oracledba
Offline
Regular Poster
MVP
Joined: 2009-09-16
Posts: 240

JohnK, Bret19, Engeeaitch
Chain2gen v2.6 should resolve the issues you mentioned please PM me if you find otherwise.
V2.6 can be downloaded from the 1st post of this topic.

GroverH
GroverH's picture
Offline
Legend
Joined: 2009-08-15
Posts: 11298

Possible Windows Security File Blocking Issue for some. Similar to post #62.

Just a heads-up to all those downloading the C2G zip file. For whatever reasons, all of a sudden, my computer is suddenly requiring me to unblock these program files after months of this not happening. I have found, however, that after downloading a new zip file, I can unblock the contents of the zip file in one operation rather than on a file by file basis.
Download the zip file. Right click and file and choose Properties and choose Unblock & Click apply.

This unblocking may not be necessary for everyone but this FYI is just to tell you of the time saver one click option should unblocking it be necessary for you. This discussion of unblocking is discussed in more detail in Appendix C of the !Readme.pdf file. C2G is not the cause but is the recipient of some Windows grief.

I am using XP Pro, SP3, TIH2010, Eset32 for AV
-------------------------------------------------------------------

Suggested download procedures:

Download OracleDBA's Chain2Gen zip file from post #1

Important: After downloading the Chain2Gen zip file and before unzipping,
RIGHT click on the zip file and choose properties. Check the properties to see if the zip file needs to be "unblocked".

If no such option exist, then after unzipping the file, again RIGHT Click on the "Acronis PreProcessing_Task.bat" file, choose the properties option and see if the file needs to be "unblocked".If yes, you will need to perform the same unblock procedures on all the ".bat" files and "VBS" files within the unzip folder.>\

  Sample picture showing the need for unblocking.  Click on image for enlarged viewing.
 


AttachmentSize
unblock.png 15.8 KB
__________________

Grovers status = Inactive    1. Grover's New Revised Guides    4.  2014 Cleanup    2015 Cleanup    5. Attachments/How   7. TI 2015 FAQ.
2. Create BKU Tasks >   2011_2012_2013    2A. Using 2014    6.  Help  2016  2015 2014  2013       8.  Stop Scan for Backups   8A.  ATIH Video's
3.  Create new disks-Guides.    9.  Register/Downloads     10.  Mustang's New Guides   11.  Les Seiler's Backup Video

David Town
Offline
Beginner
Joined: 2010-02-13
Posts: 2

Brilliant program. I had date problems (with 1st_Tue etc) but the fixes for these now seem to work. Thanks

Not sure about Grovers latest comments about unblocking the zip file first - tried it but still had to unblock all the files. Anyway no problems, it's only a once off.

I have just been caught with a "hanging" task at 0% and can't seem to stop the task so looks like I'll have to delete it. That was the day I did not have my network running so no backup drive available - don't know why it did not just stop rather than hang.

Anyone know if I can integrate Drive Notify on a network drive to check a network share with UNC - or will I need to map a drive?

JR
Offline
Beginner
Joined: 2010-01-03
Posts: 6

Just want to say THANKS for this great program!

It took a little while to get it right, but that was due to me trying to figure out my backup strategy, folder names, etc.

I did my first scheduled backup this morning using chain2gen and it worked perfectly.

(Good tip to unblock all the batch files while still in the .zip folder.)

Keep up the good work!

Also, thanks to MudCrab for Drive Notify. It looks to be a very handy program!

JR

GroverH
GroverH's picture
Offline
Legend
Joined: 2009-08-15
Posts: 11298

David,
MudCrab, the author of DrvNotify, is investigating the question about network share with UNC. I do not use networking but I do have scheduled tasks set up to have oracleDBA's Chain2Gen (C2G) run the paid version of DrvNotify for me. I prefer the inexpensive paid version which provides automation features not included in the free version of DrvNotify. Preceding posts #7 & 8 also discuss the use of these C2G and DrvNotify working together.

Attached is a zip file which contains a copy of "My_acronis_pretask.bat" which I use.

Also attached is a pdf file showing my settings for C2G and for DrvNotify in order for these two programs to interact.

In summary:
1.TrueImageHome activates the user scheduled task to produce a backup at a time and frequency based on the user task specifications.
2. TrueImageHome backup options activates the Pretask user modified "My_acronis_pretask.bat" program.
3. The "My_acronis_pretask.bat" initiates the DrvNotify program which provides a visible info window advising user to attach the designated external drive.
4. User attaches the external drive, DrvNotify exits so the "My_acronis_pretask.bat" program can do its assigned duties of moving or re-arrangement, etc. Afterward, the TrueImage backup begins.

AttachmentSize
How_I_use_Chain2Gen_to_utilize_DrvNotify.pdf 45.23 KB
my_acronis_pretask.zip 1.48 KB
__________________

Grovers status = Inactive    1. Grover's New Revised Guides    4.  2014 Cleanup    2015 Cleanup    5. Attachments/How   7. TI 2015 FAQ.
2. Create BKU Tasks >   2011_2012_2013    2A. Using 2014    6.  Help  2016  2015 2014  2013       8.  Stop Scan for Backups   8A.  ATIH Video's
3.  Create new disks-Guides.    9.  Register/Downloads     10.  Mustang's New Guides   11.  Les Seiler's Backup Video

David Town
Offline
Beginner
Joined: 2010-02-13
Posts: 2

Grover,

Great. That's a nice clear explanation of how to integrate C2G and DrvNotify. I know I need the full paid version to complete my plan, so hoping that mudcrab will confirm it works at least with a mapped driver (single letter). The UNC would be just a bonus.

Thanks to you, oracle, and mudcrab this is a great posting for automating and controlling backups.

David

ps my still hanging 0% task miraculously ran today with no problem ! (my network was connected). ATI does some very odd things at times.

damni seedemons
Offline
Beginner
Joined: 2010-01-19
Posts: 3

I can't get the sendemail_on_full_backup.bat script to work as a POSTprocess when a new full is created (ie, when there is only one *.tib file in the set0 folder).

Oddly, it works manually --> If I put one *.tib file in my set0 folder and double-click the sendemail_on_full_backup.bat file, it works.

However, when Acronis/Chain2Gen create a new backup generation in Set0 (ie, one *.tib file that is a full backup), and sendemail_on_full_backup.bat is called as a POSTprocess, it does not send email.

I checked the Acronis log file and execution of sendemail_on_full_backup.bat in the POSTprocess is successful.

Any ideas as to what is wrong?

oracledba
Offline
Regular Poster
MVP
Joined: 2009-09-16
Posts: 240

you situation is unusual. This email feature DOES work for me and others. Here are two things you might try to diagnose what is occuring. Go into the chain2gen folder for your existing job and review the contents of error_messages.txt THere might be clue in there as to what is occuring.

If no insight occurs from that, make a new chain2gen folder and define a new target folder. Use notepad create a file a .tib file (or copy some small .tib file) into this new set0 target folder. Now go back to your new chain2gen folder and double click the sendmail_on_full_backup.bat

Assuming that email worked, define a new acronis job. I would make it a job which backups a single small file as we really don't need the backup we just need a job that runs quickly.
This now job of course would use the new copy of chain2gen so define your pretask to call that folders Acronis_PreProcessing_task.bat and your posttask to call that folders sendemail_on_full_backup.bat

when you define the jobs use the "TEST" button
because you already have a .tib file in the set0 folder from notepad the test from within acronis should send you an email. (if it doesn't make sure that .tib file is still present as the pretask task might have rotated it into history)

assuming your sendemail from using the test button worked then go ahead and manually delete your notepad .tib file and run your acronis job for real. It should give you an email, if it doesn't review both the chain2gen error_messages.txt file and the acronis log file.

Hope this helps.
Let us know the results of your testing.

oracledba
Offline
Regular Poster
MVP
Joined: 2009-09-16
Posts: 240

I have just learned that v2.6 is missing the scirpt file named !_FORCE_NEW_CHAIN.bat

v2.6.1 includes this missing file.

To download v2.6.1 please visit the the first post of this topic.

The missing file is only used when the user needs to manually force a new generation to occur versus letting a new generation occur based on a trigger condition such a date or size or number.

Bernard
Offline
Beginner
Joined: 2010-01-28
Posts: 13

As a relatively new user of Chain2 Gen (which I think is fantastic) could I make one suggestion please? I've been trying to get it to run on Win 7 Home Premium 64 bit (I don't think the 64 bit is relevant, or even the Home Premium). I've been very frustrated because I set it all up carefully and followed the instructions religuously (I believe).

I set it up to run daily, with 3 generations and a new generation after 7 incrementals. I could get Acronis to run the first time and take the initial full backup, but thereafter it would start and hang with a status message saying it was processing the "Acronis_PreProcessing_task.bat" command. I tried all sorts of things and then I read the second 'page' of this thread and started to wonder if it could be Windows security that was preventing Acronis from finishing. So I unblocked all the Chain 2 Gen files and it appears to solve the problem.

Could I suggest an update to the installation instructions document for Windows 7 users (at least). It might be worth their while to unblock all Chain 2 Gen files as a matter of course. I imagine this is not something that is peculiar to my system since I think my set up is standard and it would have saved me a lot of time and heartache for what is otherwise an excellant program. Even if it wastes 2 minutes of each Windows 7 users time it would be worth it to avoid potential problems?

oracledba
Offline
Regular Poster
MVP
Joined: 2009-09-16
Posts: 240

Thankyou for finding the solution to your issue.

Yes, I agree the need for the unblock step on each file in the "install" (unzip) is an unusual task.
While there is documentation (.pdf and here) saying to do this task, it is NOT pronounced/easily findable.

The reason for the above facts was the unblock step was discovered after the release of chain2gen and the issue was addressed as a one-off issue it later became clear that a significant number of people need to do this task. At some point a better means of communicating this task will be created and a documentation release of chain2gen made.

Bob Mackenzie
Offline
Beginner
Joined: 2010-03-29
Posts: 6

Hi,
I implemented the scripts as suggested (at least I believe I did), but cannot get the system to work beyond the first backup. I kicked off the first backup manually from Acronis and it worked fine. Then I was gone for a few weeks, so when I got back I kicked off a second the same way, but the system hung up. Here is what I have now:

G:\Fullbakups
Set0
Fullbackups.tib
Trigger.txt
Set1
Set2
Set3

The trigger file contains:
"Hit TRGR_ON_MAX_TIB_CNT = 1"
"Hit TRGR_ON_MAX_TIB_CNT = 1"
"Hit TRGR_ON_DAY1 = Mon"

I have no idea where to go from here. Can you give me some advice? I've tried starting from scratch twice, with the same results.

Thanks for your help.

Regards,
Bob

AttachmentSize
OperationStatus.pdf 14.57 KB
GroverH
GroverH's picture
Offline
Legend
Joined: 2009-08-15
Posts: 11298

Bob,
If you have not seen this, try item 3B inside my signature index. Compare those illustrations with what you have done. Maybe you will find some differences. Cha1n2Gen works great for me and as reported by the other users.

set TRGR_ON_MAX_TIB_CNT=1

I notice the above item is listed twice. Is this a just a posting error and the item below is missing from your post. No spaces between equal sign and number.
set MAX_BACKUP_GENERATIONS=3

[strong>What is you want to achieve? Only full backups and no inc's?
Backups only on Monday's?

One frequent cause of hanging is a security issue. Ti is waiting for C2G to complete, but C2G can't begin because its files are locked--thus a hang. C2G files need to be unlocked in this situation.

Another cause for hanging is that TI is waiting for C2G to complete. Do you have C2G doing anything more such as a defrag or other special job?

__________________

Grovers status = Inactive    1. Grover's New Revised Guides    4.  2014 Cleanup    2015 Cleanup    5. Attachments/How   7. TI 2015 FAQ.
2. Create BKU Tasks >   2011_2012_2013    2A. Using 2014    6.  Help  2016  2015 2014  2013       8.  Stop Scan for Backups   8A.  ATIH Video's
3.  Create new disks-Guides.    9.  Register/Downloads     10.  Mustang's New Guides   11.  Les Seiler's Backup Video

oracledba
Offline
Regular Poster
MVP
Joined: 2009-09-16
Posts: 240

Groverh - I think bob was giving us the contents of his trigger.txt file. If so the format of what he posted is not unusual.

Bob - As for the hanging issue. I am pretty certain that you are tripping up on a windows security thing that grover mentioned. This is a fairly common install issue. the solution is described in post 50 of this thread. Grover's other comment is valid, in that if you requested additional processing to occur before backup (such as a defrag) then during that action chain2gen will wait for the action to finish. Because chain2gen is waiting it will look frozen/hung when in reality the pc is working/busy doing your defrag and when that was done chain2gen would pickup and continue.

Try the solution in post50, let us know if that did not resolve your issue.

Bob Mackenzie
Offline
Beginner
Joined: 2010-03-29
Posts: 6

Thanks for your responses. Oddly, my screen starts with post #51. So, I don't have access to post #50. Is there a way to go backwards and see post 50?

Thanks in advance.

GroverH
GroverH's picture
Offline
Legend
Joined: 2009-08-15
Posts: 11298

http://forum.acronis.com/forum/5940#comment-17719
You are looking at page 2.
At the bottom of pages 1 or 2 is an option to move forward or backward.
The unlocking content of post #50 was also discussed in my 3B link referenced in my prior post #86 above.

__________________

Grovers status = Inactive    1. Grover's New Revised Guides    4.  2014 Cleanup    2015 Cleanup    5. Attachments/How   7. TI 2015 FAQ.
2. Create BKU Tasks >   2011_2012_2013    2A. Using 2014    6.  Help  2016  2015 2014  2013       8.  Stop Scan for Backups   8A.  ATIH Video's
3.  Create new disks-Guides.    9.  Register/Downloads     10.  Mustang's New Guides   11.  Les Seiler's Backup Video

Bob Mackenzie
Offline
Beginner
Joined: 2010-03-29
Posts: 6

GroverH,
Thanks, I'm learning. I did find post #50, and I did read 3B. Also, there was no Unblock selection for the scripts, so that does not seem to be the problem. Also, the scripts ran once, so that seems to show the same conclusion.
Oracledba asked if I requested any additional processing. The answer is no.
I'm simply trying to do a full backup every Monday.
Would it help if I did file attachments of some the scripts that I modified?
Again, thanks in advance; I appreciate the help.
I am having a bit of trouble finding my way around, but, so far, so good.

GroverH
GroverH's picture
Offline
Legend
Joined: 2009-08-15
Posts: 11298

Bob,
Thanks. I do suggest that you recreate a new script and start with an empty set0 folder. We have found that edited TrueImage scripts simply do not work because changes are made in them which you are not easily visible

I would still recheck the files inside your Chain2Gen(C2G) folder as to whether the unlock function is needed. What needs to be checked are those files which were included in the Chain2Gen download zip file. Right click on eachC2G bat file and eachC2G vbs file and check again to see if any need to be unlocked.

If you wish to create a zip file attachment, we would be happy to look at them.
Include your the task script file (the one with all the crazy numbers) and your
parameters file like below:

8E502E55-E5D8-4D3D-8AF9-FF0F722227D7.tib.tis
!_USER_SPECIFIED_PARAMS_FOR_ACRONIS.bat

Or, if you do not have the tools to create a zip file, you can copy the two files into another sample folder. Then right click on each file and rename/change the file extension to ".txt"

After renaming:
8E502E55-E5D8-4D3D-8AF9-FF0F722227D7.txt
!_USER_SPECIFIED_PARAMS_FOR_ACRONIS.txt

Then the two txt files can be attached to your post. Do the zip or the extension rename--which ever is easier.

If I am understanding your issue correctly, you only have one TrueImage/Chain2Gen schedule task and this task is hanging when runs a second time.

__________________

Grovers status = Inactive    1. Grover's New Revised Guides    4.  2014 Cleanup    2015 Cleanup    5. Attachments/How   7. TI 2015 FAQ.
2. Create BKU Tasks >   2011_2012_2013    2A. Using 2014    6.  Help  2016  2015 2014  2013       8.  Stop Scan for Backups   8A.  ATIH Video's
3.  Create new disks-Guides.    9.  Register/Downloads     10.  Mustang's New Guides   11.  Les Seiler's Backup Video

Bob Mackenzie
Offline
Beginner
Joined: 2010-03-29
Posts: 6

GroverH,
Boy do I feel dumb. I cannot find any file with a .tib.tis extension. Either this is a solid clue, or I'm looking in the wrong location. (Windows Explorer Search yields nothing on C:\)
On a lark, I built a new script and am running it now; it will be another 35 min before it's done. Perhaps the missing file will show up on completion of the task.
I rechecked all file in the Chain2Gen folder and none need to be unlocked.
Also, your assumption is correct: one TrueImage/Chain2Gen schedule task and this task is hanging when run a second time.
Thanks for hanging in there with me.

GroverH
GroverH's picture
Offline
Legend
Joined: 2009-08-15
Posts: 11298

The .tib.tis fle is a script file and found in the Acronis Scripts folder. This the real name for what you know as a scheduled task. You know the task by the name you assigned but Acronis assigns a crazy number to this file and stores it in the Scripts folder. Do a file search for the scripts folder. The file you are looking for is the most recently used or modified. Or, you can open each script into notepad and identify by content.

Identification (inside the scripts folder) might be easier if you open TI and delete any scheduled tasks not actually being used.

The path to my scripts folder is:
C:\Documents and Settings\All Users\Application Data\Acronis\TrueImageHome\Scripts\

__________________

Grovers status = Inactive    1. Grover's New Revised Guides    4.  2014 Cleanup    2015 Cleanup    5. Attachments/How   7. TI 2015 FAQ.
2. Create BKU Tasks >   2011_2012_2013    2A. Using 2014    6.  Help  2016  2015 2014  2013       8.  Stop Scan for Backups   8A.  ATIH Video's
3.  Create new disks-Guides.    9.  Register/Downloads     10.  Mustang's New Guides   11.  Les Seiler's Backup Video

Bob Mackenzie
Offline
Beginner
Joined: 2010-03-29
Posts: 6

Here are the two files as attachments. Hope this helps.

AttachmentSize
_USER_SPECIFIED_PARAMS_FOR_ACRONIS.TXT 18.46 KB
FEF0A6F5-A73E-4F6C-B00B-504BC41882E2.tXT 2.76 KB
GroverH
GroverH's picture
Offline
Legend
Joined: 2009-08-15
Posts: 11298

The parameters and paths are all set correctly. I found no user mistakes.
However, the 2 files I download WERE security blocked. I cannot tell whether these were sent blocked or the block was created by my computer.

Please do this for me.
Open Windows explorer and browse to your C:\Chain2Gen\FullBackups\ folder
!_USER_SPECIFIED_PARAMS_FOR_ACRONIS.bat
1. Double check there is the required "!" as the first character this master file name.
Perhaps the missing ! was just lost in shuffle attachment.

2. Right click on the file C:\Chain2Gen\FullBackups\Acronis_PreProcessing_task.bat
a. Click Properties
b. check if you have an unblock option?
If yes, the file is locked and all the files in this folder will need to be unlocked.
3. Browse to your downloaded file of the original Chain2Gen_v2.6.1.zip
a. Right click on the file and click Properties
b. check if you have an unblock option?

Let me know.

Edit:
Is your backup storage drive G: an internal or external drive?

AttachmentSize
lock-unlock.gif 5.91 KB
__________________

Grovers status = Inactive    1. Grover's New Revised Guides    4.  2014 Cleanup    2015 Cleanup    5. Attachments/How   7. TI 2015 FAQ.
2. Create BKU Tasks >   2011_2012_2013    2A. Using 2014    6.  Help  2016  2015 2014  2013       8.  Stop Scan for Backups   8A.  ATIH Video's
3.  Create new disks-Guides.    9.  Register/Downloads     10.  Mustang's New Guides   11.  Les Seiler's Backup Video

Bob Mackenzie
Offline
Beginner
Joined: 2010-03-29
Posts: 6

GroverH,

As you originally expected, the files were all blocked. I unblocked them one at a time and everything is working now. My problem was that I didn't know where to find the unblock button. When you directed me to look under properties, it all became clear.
To reply to your other questions:
the "!" was in place as it should be. Possibly a problem with transmitting a file with a name starting with an exclamation point.
The zip file is no longer on my system. I don't know why (?), so I couldn't determine if it was blocked too.
G:\ is an external USB drive. I have three such drives, one for backup, one for digital pictures, and one for backing up certain backups (redundancy).
I want to thank you for sticking with me through this and I apologise for not knowing where the unblock function was. Actually, I never heard of that before. I have enjoyed working with you.
Regards,
Bob
BTW, just for the record I'm 72 years old today and have been in computers with a major computer company since the early 60s. I find that as time goes by, it's harder to keep up. Good thing there are guys like you. Thanks again.

GroverH
GroverH's picture
Offline
Legend
Joined: 2009-08-15
Posts: 11298

Bob,
Happy Birthday to you and welcome to the forum. Thanks to you for sticking with it and you're right about trying to keep up. I'm 78-1/2 and time is passing much to quickly. I still have much more to learn. I believe you will like the C2G program our thanks to MVP OracleDBA for writing such a helper program.

I will go back and check my item 3-B guide and check on the unblock instructions. The unblocking is also discussed in post #75 but I did not use that reference.

You should consider using MVP MudCrab's drive notify program to help remind you about the need to insert drive G just prior to its backup time. I find this program really helpful and it can be integrated into C2G. Once backup task runs on Monday night and DrvNotify reminds me to insert my drive X. Another task runs on Wednesday night and reminds me to insert drive V. DrivNotify will not allow either to start until the proper drive is inserted. The link is in my signature.

Good luck with your backups and get back to us should you need additional assistance. We 'ol timers must stick together and not let these youngsters get ahead of us. <smile> <just joking> If you're looking for some reading material, check out some the items inside my signature index below.

__________________

Grovers status = Inactive    1. Grover's New Revised Guides    4.  2014 Cleanup    2015 Cleanup    5. Attachments/How   7. TI 2015 FAQ.
2. Create BKU Tasks >   2011_2012_2013    2A. Using 2014    6.  Help  2016  2015 2014  2013       8.  Stop Scan for Backups   8A.  ATIH Video's
3.  Create new disks-Guides.    9.  Register/Downloads     10.  Mustang's New Guides   11.  Les Seiler's Backup Video

Hope
Offline
Forum Member
Joined: 2009-08-30
Posts: 98

I'm the youngster in the group...I'm only 68. :)

thomasjk
Offline
Frequent Poster
Joined: 2009-08-15
Posts: 988

Well I'm only 67. Old F*** rule.

__________________

Tom K.

oracledba
Offline
Regular Poster
MVP
Joined: 2009-09-16
Posts: 240

received an email regarding a typo near line 83 of script Populate_Date_Variables.bat (should read Tue not Tues)
Made this correction as zip file 2.6.2 (see 1st post of this thread).
this is the only change from 2.6.1