Skip to main content

ExtremeZ-IP Zidget - Mac

Beginner
Posts: 2
Comments: 9

What's up group!

We just upgraded to EZ-IP 9.0.4x121 to support our Yosemite upgrades/replacements (10.10.2) and noticed the 2.1.0 version of the Zidget isn't working. Couple of things...

When we double click the app to install, it does nothing. we have to literally double click it multiple times to get it to finally install in Dashboard. Then, when it finally installs, we can't get it to load properly.

it's kind of clunky.

Is there another preferred way to install printers without using this? or are we forced to install our EZ-IP printers this way?

Thanks in advance.

Beginner
Posts: 2
Comments: 9

Top

Earth to Acronis! Earth to Acronis! Do you read me, Acronis? Please respond!

Forum Member
Posts: 0
Comments: 46

Top

Hi Marc! Most likely you need to install the app by control-clicking. Control-clicking on a Mac is equivalent to right-clicking on a Mac or in Windows.

Please check the instructions below and if you have any further questions, please open a new support ticket at http://www.acronis.com/en-us/contactsupportgl.html.

Thanks!

To download the Zidget simply open a browser to http://server:8081 (complete documentation for Zidget can be found at http://www.acronis.com/en-us/support/documentation/ExtremeZ-IP/index.ht… ). To install it you may need to control click on Mavericks/Yosemite.

This first time set up is a multi-step process:
- Create the Print Queue in ExtremeZ-IP Admin;
- Leave the PPD field blank.

Client:
- Add the printer – it will install with the generic driver;
- Confirm the drivers from the manufacturer are installed on the Mac client;
- Open Print Center and toggle the generic driver to use the correct driver;
- Test that jobs print correctly;
- Fish out the PPD: Go -> Go To Folder -> /etc/cups/ppd, and place a copy of it on the Server;
- Edit the print queue and select the tested PPD you fished off the client.

re: Zidget

Once the Zidget is installed/pushed out clients – you can use the following options:

Option 1 (web browser - invokes Zidget):

From the Mac client, open Safari (of FireFox) and enter the following as the url/address: ezip://servername:8081/printqueuename. Zidget will be invoked and ask whether you wish to add the printer

Note: if the Print Queue name has spaces i.e. Art Department, then you would use: ezip://servername:8081/Art%20Department

If Safari/FireFox fails to invoke the Zidget - you may need to copy the ZidgetHelper into the Applications folder. It’s in the Zidget.wdgt widget package file. Right click -> Show Package Contents -> then navigate to the ShellScripts folder. Just copy it to the Applications folder and run it once to make sure it's registered.

Option 2 (terminal/scripting):

cd to the following directory:
~/Library/Widgets/Zidget.wdgt/ShellScripts/ZidgetHelper.app/Contents/MacOS
next run the following
./ZidgetHelper "ezip://servername:8081/Art%20Department"

Zidget will be invoked and will add the printer.

Attachment Size
262850-119209.jpg 6.85 KB
Beginner
Posts: 2
Comments: 9

Top

Hi Mikhail, thanks for the response!

You say, Control + Click on the Zidget, and then what? Open in the menu? Because that's not working either. Just sits there. Still have to do it a couple of times.

Forum Member
Posts: 0
Comments: 46

Top

You should just select "Open". Actually it doesn't seem to be a common problem. I was not able to reproduce it on my Mac: I just click on the Download Zidget link at http://serveraddress:8081 and then select "Install" in a pop-up window to confirm the dialog asking if you want the Zidget installed. So, it looks like something environment specific. Please create a support ticket at http://www.acronis.com/en-us/mobilitysupport, so we could proceed with further investigation. Thanks!

Beginner
Posts: 2
Comments: 9

Top

Thanks but we just tried it the same way and get nothing. Not sure what you mean by environment but we're getting the following error in Console:

CoreServicesUIAgent: Error -60005 creating authorization

and we've tried this under the local admin account as well as our general users. No luck.

Forum Member
Posts: 0
Comments: 46

Top

It sounds rather like a gatekeeper problem. Please disable gatekeeper (System Preferences -> Security & Privacy -> Allow Apps Downloaded From: Anywhere) and let us know the results. Feel free to read the following article to learn more about gatekeeper and its options: https://support.apple.com/en-us/ht202491.

Beginner
Posts: 2
Comments: 9

Top

Okay so this is interesting... We thought it was the same too. But we have Security & Privacy already set to Anywhere. So we tried installing a different Widget from the list already built into Dashboard, just as a test. When we went back to the downloaded Zidget, it install too. Weird. So we have a work around, for now I guess.

Beginner
Posts: 0
Comments: 1

Top

We have a full version of Extremez-ip version 8.1.1x103. When our Mac's look at a folder using AFP, some files are not visible. When they connect with SMB, they are there. The SMB connections are not nearly as fast as the AFP connections.
Rick Gilbreath
Malnove Inc.
402-778-0562

Forum Member
Posts: 0
Comments: 46

Top

Hi Rick!

1st step would be to upgrade the program: You are running an outdated version of ExtremeZ-IP. So, according to our instructions, I have to inform you of the importance of updating your software: https://kb.acronis.com/node/39514. The latest official release versions are available here: http://support.grouplogic.com/?page_id=63.

2nd step would be to localize the problem: What kind of files you are talking about? If you browse the share from a PC on the network, can the files be seen? Do they reside on local or reshare ExtremeZ-IP volumes? Does unmounting and remounting the share on the Mac help to work around it?

If you would like to discuss this problem further on the forum, I would ask you to open a new thread since it is not a Zidget issue. In addition, if you have a valid support contract, you can always open a new support ticket at http://www.acronis.com/en-us/mobilitysupport.