Skip to main content

Acronis Agent Appliance smb v2 settings

Thread needs solution
Beginner
Posts: 3
Comments: 3

Hİ,

We use Acronis Agent Virtual Appliance 11.7 Build: 50088.

I read this version support for smb v2 and  smb v3 .

" Support for SMB2 and SMB3 in Agent for Linux, Linux-based bootable media, and Agent for VMware (Virtual Appliance). In Windows, SMB2 and SMB3 are natively supported."

Currently smb v1 uses.

How to set smb v2 or smb v3 for Acronis agent Appliance 11.7 Build : 50088 ?


 

 

0 Users found this helpful
Forum Moderator
Posts: 113
Comments: 4341

Hi,

The Agent will attempt to mount a share starting from 3.1.1, and in case connection cannot be established (e.g. the server is not configured to work with SMBv2 \ v3), try to connect using the lower protocol versions. Accordingly, the SMBv2 \ v3 protocols must be enabled on the server with the target share. You can try mounting a share manually with the desired protocol version and check if it is possible at all: mount -t cifs // IP_address / share / mnt / tmp -o username = [username], noexec, pass = <pass>, vers = 3.1 .1, sec = ntlmssp, noperm

More information can be found in the asamba log https://kb.acronis.com/content/38017

Beginner
Posts: 3
Comments: 3

Hi,

This command, which you give me, does not work on Agent Appliance.

 

Forum Moderator
Posts: 113
Comments: 4341

And from other servers? The main purpose of this test is to find out, whether the share technically can be mounted using smb2/3 or not. 

Beginner
Posts: 3
Comments: 3

on our netapp storage smbv1 is disable and smbv2,smbv3 are enable.in this situation  we are tried to backup our servers but volume of our servers could  not be mounted.

Support specialist
Posts: 0
Comments: 469

Hi!

Do you receive any error message when trying to mount as Ekaterina advised? Could you please send us a shot of an error message you receive after mounting this way?

mount -t cifs // IP_address / share / mnt / tmp -o username = [username], noexec, pass = <pass>, vers = 3.1 .1, sec = ntlmssp, noperm

Have you tried to mount without desired protocol version by omitting vers = 3.1 .1 parameter?