Skip to main content

Important question about the file unified_data.ds.0

Thread solved
Beginner
Posts: 1
Comments: 1

Hi All,

I am using Acronis backup Advanced 11.7

A file called unified_data.ds.0 in my managed centralized vault keeps growing in size. Please see screentshot.

What are the options I have to reducing the size of this file. Can i just delete it without having any issues? It is already 2.3TB and taking almost half of my storage. Please could someone tell me the right process to deleting or reducing the size of this file.

Cheers

Tony

Attachment Size
capture.jpg 37.19 KB
0 Users found this helpful
Regular Poster
Posts: 30
Comments: 339

#1

Hi Tony,

you should not remove this file, it contains the dedup-data for your backups in the vault.

Try to reduce the filesize by copying to another location as stated in this KB: https://kb.acronis.com/content/36135

When using Acronis Storage Node and deduplication on NTFS filesystem an error occur due filesystem limitation. To fix the issue, reduce the fragmentation by copy forth and back the deduplication storage (datastore) unified_data.ds.0/1.

Beginner
Posts: 1
Comments: 1

#2

Thank you Raphael, I would look at the article and try that.

Beginner
Posts: 1
Comments: 7

#3

as i fixed my problems with the storage node and the problem that the entire disk was full i now run into this problem...

 

my file is 19TB... how do you expect me to just copy forth and back...

 

p.s. sorry for reopening an old thread..

Forum Moderator
Posts: 126
Comments: 4953

#4

Hi,

You can apply the second solution described in the article Acronis Storage Node Operation fails with "The requested operation could not be completed due to a file system limitation

Starting from this builds Acronis has implemented pre allocation ability, so the data store files increased with large portions of data, so it has less fragments. The default pre allocation size is 512 MB. For large data store size (e.g. 11 TB) this is not enough. You need to adjust the pre allocation size manually according to the data size planned to be stored in the vault.

To set up pre allocation size follow these steps:

  • Go to Start -> Run -> services.msc -> and stop Acronis Storage Node service;
  • Go to Start -> Run -> regedit.exe to open Windows registry editor and navigate to this key: HKEY_LOCAL_MACHINE\SOFTWARE\Acronis\ASN\Configuration\StorageNode\PreallocatedDatastoreIncrementSize
  • Change the default value (is 512 in megabytes).

If you plan having more than 10 Tb of unique data size it's recommended to set PreallocatedDatastoreIncrementSize to 1024; Go to Start -> Run -> services.msc -> and start Acronis Storage Node service;

In reply to by Ekaterina

Beginner
Posts: 1
Comments: 7

#5

thank you for your reply..

however the setting is allready at 1024.

i deleted an backup of 1.5TB from the vault and i only got 10GB back after compressing and i dont even think it was from the unified_data.ds.0 file but from the computers folder in the vaults location..

 

what else could i do to shrink this file?

Forum Moderator
Posts: 126
Comments: 4953

#6

Hi,

The only way to reduce the data store file (which contains only unique data after deduplication) I'm aware of is to delete older backups and perform compacting. Note: the data store might have been reduced slightly, because there are still a lot of blocks which have references from other archives. The compacting task deletes only unused blocks.

#7

How do you run a manual compacting in 12.5, my unified_data.ds.0 is taking up almost the entire drive?

Forum Moderator
Posts: 126
Comments: 4953

#8

Hi,

You can start the compacting task via acrocmd 

acrocmd compact vault --name=vault --host=<IP of the host> --credentials=<Username,password> --service=asn 
 

In reply to by Ekaterina

#9

That's exactly what I needed, thank you.

Beginner
Posts: 0
Comments: 3

#10

Works for me too :) After start it consumes 33% CPU an 1Gbit/s Network Bandwith

thx

Forum Moderator
Posts: 126
Comments: 4953

#11
Markus Dommning wrote:

Works for me too :) After start it consumes 33% CPU an 1Gbit/s Network Bandwith

thx

Thank you for posting the confirmation! Yep, the compacting might be very resource-consuming process depending on the hardware and amount of data in the dedup vault. 

Beginner
Posts: 0
Comments: 2

#12

@ Ekaterina, Hi,

https://www.acronis.com/en-us/support/documentation/AcronisBackup_11.7/index.html#3353.html

In 11.7 - By default, the compacting task runs every Sunday night at 03:00. You can re-schedule the task by selecting the corresponding storage node, clicking View details, and then clicking Compacting schedule. You can also manually start or stop the task on that tab.

Is this same apply to 12.5? the compacting task runs ever Sunday night at 3:00.

Is there any place to modify the running time?

Best Regard,

 

 

Support specialist
Posts: 0
Comments: 1054

#13

Hello Packy,

welcome to Acronis forums!

Is this same apply to 12.5?

Yes, the compacting task runs at 3:00 a.m. on Sundays in Acronis Cyber Backup 12.5 also as in the previous version. However, you can't manually start/stop this task or modify the schedule.

The only possible option is to run a compacting task using the command-line utility and compact vault command as discussed here: https://forum.acronis.com/forum/acronis-cyber-backup-125/change-compacting-schedule

Beginner
Posts: 0
Comments: 2

#14
Maria Belinskaya wrote:

Yes, the compacting task runs at 3:00 a.m. on Sundays in Acronis Cyber Backup 12.5 also as in the previous version. However, you can't manually start/stop this task or modify the schedule.

The only possible option is to run a compacting task using the command-line utility and compact vault command as discussed here: https://forum.acronis.com/forum/acronis-cyber-backup-125/change-compacting-schedule

 Hi Maria,

Thanks for your clarification, the issue has been resolved by manually running compacting task by command line utility