Skip to main content

Pre/Post commands execution

Thread needs solution
Beginner
Posts: 3
Comments: 3

Hello!

I am doing MySQL data backup with Acronis 11.7. So I put two commands in the plan:

pre: SC \\SERVER stop MySQL

post : SC \\SERVER start MySQL

While creating the backup plan and editing these commands, I checked if commands working by pushing "Test" button and they worked just fine. But they refused to work from the backup plan execution giving me the error "Access denied" and asking me to put username and password to open smb\\..., as far as I understand to interpret \\SERVER address.

I tried all users and passwords existing in my domain, but no success whatsoever! Why? Why is that Test is working and plan is not?

Thanks.

 

 

0 Users found this helpful
Forum Moderator
Posts: 178
Comments: 5941

Hi! 
I'd recommend starting with the steps from 46690: Acronis Backup: Troubleshooting Pre/Post Commands Issues

Beginner
Posts: 3
Comments: 3

Спасибо, Катя! С Новым вас Годом!

I tried everything - ps scripts, cmd.exe batches, manual execution, playing with credentials, and here is my verdict:

Acronis cannot execute commands at elevated level on domain controllers, not at all, at least I did not find the way to do this. I cannot stop MSSQL service from Acronis (probably any service), and at the same time it works from cmd.exe manualy ran as Administrator, and in test mode (this is mystery for me - while you are in the Backup plan generation process you execute at the elevated level, as soon as you go to Acronis process, it fails.

So if I want to stop the process I have to use Task Scheduler, it is the only solution I see now.

Thanks again!

Forum Support specialist
Posts: 0
Comments: 1668

Hello StringerAlex.

If you run MySQL on a Linux server, please follow recommendations from this respective KB article: https://kb.acronis.com/content/58136