Skip to main content

Cannot Install Acronis Backup 12.5, Registration Failed for Backup Agent

Thread needs solution
Beginner
Posts: 1
Comments: 1

Hello,

I can't seem to install Acronis Backup 12.5 on our HyperV server (Server 2012 R2 Standard). During the install process, a popup appears:

 

When I click "Open Log" to see, this is what I get. 

1: [10:01:46:082]: (mms) RegisterAgentTool::Register: MsiProgressReporter::Update: ticks = 4194304, TicksRemain = 0 
1: [10:01:48:083]: (mms) RegisterAgentTool::Register: attempt = 157 
1: [10:01:48:083]: (mms) RegisterAgentTool::Register: command = C:\Program Files\Acronis\RegisterAgentTool\register_agent.exe -s mms -o register -a localhost:9877 
1: [10:01:49:136]: (mms) RegisterAgentTool::Register: result = 5 
1: [10:01:49:136]: (mms) RegisterAgentTool::Register: The command output:
Failed.
502

{
   "context" : 
   {
      "$module" : "mms_rest_api_vsa64_11010"
   },
   "domain" : "global",
   "origin" : 
   {
      "code" : 502,
      "fields" : 
      {
         "$module" : "mms_rest_api_vsa64_11010"
      },
      "lineTag" : "0x487816542fd3692f, e:\\21\\enterprise\\rest_api\\agent\\registration.cpp:916, AgentRestApi::Register",
      "module" : 0,
      "suberror" : null,
      "text" : "Getting token failed: Bad Gateway"
   },
   "reason" : "internalError",
   "serCode" : "0x000001f6"
}

 

I have attempted to register the agent manually using the command prompt (register_agent.exe) and get the same error. 

I have tried the "retry" option, this does not work, and if i hit "ignore", the installation seems to complete, but then I am unable to open the management console, getting the below error:

 

 

I have also tried installing under different Windows accounts (and verified I am using an administrator account).

This machine previously had Acronis Backup 12.5 installed, but we were uninstalling it to re-install and start fresh. The un-install process had no issues.

I did see another post somewhere, that suggested unplugging the network connection during install, however, this is not an option as this server is at a remote location 200 miles away.

Any help is greatly appreciated.

0 Users found this helpful
Support specialist
Posts: 0
Comments: 346

Hello Lee,

welcome to Acronis forums!

Please make sure that on a remote machine 

  1. User Account Control (UAC) is disabled.
  2. File and Printer Sharing must be enabled on the remote machine

If the above settings are done but the registration of this Agent still fails, please collect Acronis System Information from that remote machine and Acronis Management Server and share them with Acronis Support Team who will investigate this issue.

Beginner
Posts: 1
Comments: 1

Thank you Maria. I did verify that UAC has always been disabled, and that File and Printer sharing has always been enabled. This machine did have Acronis Backup on it before, we were attempting to uninstall and re-install to start fresh. Unfortunately I can't grab the Acronis System Information, because with this issue I cannot access the backup console (see screenshots), and I can't do a bootable media since this server is at a remote location 200 miles away. I have engaged the Acronis Support Team, but they're stumped as well, so far. If anyone has any suggestions, please let me know.

Support specialist
Posts: 0
Comments: 346

Hello Lee,

then please use Acronis Info Utility to collect system information from that remote server and send the result for analysis to Acronis Support Team