Skip to main content

Failed to backup Ubuntu server

Thread needs solution
Forum Member
Posts: 9
Comments: 19

Hello,

This new installation of Acronis Backup 12.5 (currently trial).

I installed Acronis agent on physical Ubuntu Server 14.04.5 LTS and the machine successfully added to devices list.
Server root partition is ext4, no LVM.

I defined backup plan for entire machine; when ran, it failed with message "None of the items selected for backup were found". Details end with message "No volumes have been found while processing the 'Fixed Volumes' template."

I tried then create backup plan for disks and volumes, but during creation no volumes are shown. Message says "Nothing to display".

I tried then create file-level backup plan and it worked.

How can I perform entire machine backup?

Thanks in advance,
Leonid.

 

0 Users found this helpful
Acronis Program Manager
Posts: 22
Comments: 3099

Hi Leonid,

The symptoms indicate that "snapapi" module was not installed properly on the machine, which explains why disk/volume backups are not working, while files/folders backups can be created.

You need to install snapapi as described in https://kb.acronis.com/content/1556 article. Note that for Ubuntu systems the pre-requisites must be met (likely that's the reason why snapapi was not installed properly initially): https://www.acronis.com/en-us/support/documentation/AcronisBackup_12.5/#22619.html . Plus remember to install RPM packet manager before following the instructions: apt-get install rpm

Thank you.

Forum Member
Posts: 9
Comments: 19

Hi Vasily,

Thank you for answer.

I checked the mentioned instructions.

Seems my system met the requirements. Modinfo returns correct information:

image

If I try to run module build manually, I get the message that the module was already built:

Module snapapi26/0.7.104 already built for kernel 4.2.0-42-generic/4 (not sure what /4 at the message end means).

Is there a way to force module rebuild?

Upon start of Linux installation, on the Management server screen, question is asked: "Register anonymously" or "Register under the some account". I didn't find explanation regarding that, so left it on the default "Register anonymously".

Thank you,
Leonid.

Acronis Program Manager
Posts: 22
Comments: 3099

Hi Leonid,

Thank you for additional details. The snapapi module is already built properly (no need to re-build), so the issue could be that it was not loaded correctly. You can check it via the following commands:

cat /proc/modules | grep snapapi

If snapapi is not listed, then try to load it manually:

modprobe snapapi26

If it doesn't load then "dmesg" will show details on the reason for the failure.

Thank you.

Forum Member
Posts: 9
Comments: 19

Hi Vasily,

Thank you for clarifications.

Indeed, module is not loaded, modprobe returns error:

modprobe: ERROR: could not insert 'snapapi26': Unknown symbol in module, or unknown parameter (see dmesg).

No errors mentioned in dmesg, but syslog and kern.log both have the same record:

Nov 29 12:56:44 sw-dev kernel: [18529.275364] snapapi26: Unknown symbol mcount (err 0).

Hope this help to find the root cause.

Thank you,
Leonid.

 

Forum Member
Posts: 9
Comments: 19

Additional kernel complain in syslog and kern.log at boot time:

Nov 29 07:48:37 sw-dev kernel: [   42.333103] snapapi26: module license 'Proprietary' taints kernel.
Nov 29 07:48:37 sw-dev kernel: [   42.333107] Disabling lock debugging due to kernel taint
Nov 29 07:48:37 sw-dev kernel: [   42.333158] snapapi26: module verification failed: signature and/or required key missing - tainting kernel
Nov 29 07:48:37 sw-dev kernel: [   42.333239] snapapi26: Unknown symbol mcount (err 0)

Regards,
Leonid.

Acronis Program Manager
Posts: 22
Comments: 3099

Hi Leonid,

The last errors show that snapapi module was built with wrong Linux kernel sources which is why it cannot start. To fix this problem please try the following (re-build snapapi):

service acronis_mms stop

dkms remove -m snapapi26 -v 0.7.104 --all

dkms {add,build,install} -m snapapi26 -v 0.7.104
service acronis_mms start

If this doesn't help then we'll need to check system report from the machine (you can upload it somewhere and send me a link in a private message).

Thank you.

Acronis Program Manager
Posts: 22
Comments: 3099

Hi Leonid,

(please see additional details in a private message)

The root cause of the problem is that you have the Linux kernel built via gcc version 4.8.4 , while the installed gcc version (used to build snapapi) is 4.4.7 which is causing the module start issues.

Thank you.

Forum Member
Posts: 9
Comments: 19

Hy Vasily,

Thank you so much!

I recompiled it with gcc 4.8 and the module loaded. This is development server with multiply gcc versions installed.

Thanks again.

Kind regards,
Leonid.

Beginner
Posts: 4
Comments: 3

Hello,

I'm facing the same issue with an Ubuntu 14.04 server.

# cat /proc/version Linux version 3.13.0-163-generic (buildd@lgw01-amd64-058) (gcc version 4.8.4 (Ubuntu 4.8.4-2ubuntu1~14.04.4) ) #213-Ubuntu SMP Thu Nov 15 02:19:07 UTC 2018

# gcc -v Using built-in specs. COLLECT_GCC=gcc COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-linux-gnu/4.8/lto-wrapper Target: x86_64-linux-gnu Configured with: ../src/configure -v --with-pkgversion='Ubuntu 4.8.4-2ubuntu1~14.04.4' --with-bugurl=file:///usr/share/doc/gcc-4.8/README.Bugs --enable-languages=c,c++,java,go,d,fortran,objc,obj-c++ --prefix=/usr --program-suffix=-4.8 --enable-shared --enable-linker-build-id --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --with-gxx-include-dir=/usr/include/c++/4.8 --libdir=/usr/lib --enable-nls --with-sysroot=/ --enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time=yes --enable-gnu-unique-object --disable-libmudflap --enable-plugin --with-system-zlib --disable-browser-plugin --enable-java-awt=gtk --enable-gtk-cairo --with-java-home=/usr/lib/jvm/java-1.5.0-gcj-4.8-amd64/jre --enable-java-home --with-jvm-root-dir=/usr/lib/jvm/java-1.5.0-gcj-4.8-amd64 --with-jvm-jar-dir=/usr/lib/jvm-exports/java-1.5.0-gcj-4.8-amd64 --with-arch-directory=amd64 --with-ecj-jar=/usr/share/java/eclipse-ecj.jar --enable-objc-gc --enable-multiarch --disable-werror --with-arch-32=i686 --with-abi=m64 --with-multilib-list=m32,m64,mx32 --with-tune=generic --enable-checking=release --build=x86_64-linux-gnu --host=x86_64-linux-gnu --target=x86_64-linux-gnu Thread model: posix gcc version 4.8.4 (Ubuntu 4.8.4-2ubuntu1~14.04.4)

# dkms status snapapi26, 0.7.116, 3.13.0-163-generic, x86_64: installed

When rebooting the server I see the following in dmesg after boot

[ 11.068570] snapapi26: module license 'Proprietary' taints kernel.
[ 11.068573] Disabling lock debugging due to kernel taint
[ 11.068650] snapapi26: module verification failed: signature and/or required key missing - tainting kernel
[ 11.072344] snapapi_init(modprobe,1194): Snapapi(v.0.7.116) init OK. Session size 13720. Em size 3009. Ctl major 250
[ 11.177867] session_init(mms,1111): OK. kdev=fd:2, bs=4096.

When I attempt to run a backup, I get the following error message:

Operation canceled by user. Error code 0x01350016+0x01350016+0x00A100FC+0x008F0003+0x00010425+0x00010424+0x00070022

At the same time, dmesg on the server shows:

[36705.129411] session_init(service_process,12955): OK. kdev=fd:2, bs=4096.
[36709.932883] session_init(service_process,12980): OK. kdev=fd:1, bs=4096.
[36714.976096] heartbeat_timer_func(swapper/0,0): Deadlock detected.dev=fd00001, cnt=3, state=4. Unfreezing...
[36714.976149] find_deadlocked(snapapid,1223): dev=fd00001 state=1024
[36714.976154] do_resolver(snapapid,1223): Real cleanup started... s=ffff8800b9e74000(fd00001)
[36714.976429] find_deadlocked(snapapid,1223): dev=fd00001 state=256

The complete error details from the Backup Management Console can be found here: https://pastebin.com/480j4qAF

Any ideas?

Thanks in advance,
George

Acronis Program Manager
Posts: 22
Comments: 3099

Hi George,

The issue is a different one and might be related to specifics of what is selected as source for backup (files/folders or disks/volumes) and what is the target (have you tried backing up to some plain network share?). It makes sense to investigate it separately with our support team. Please collect system report from the affected system as described in https://kb.acronis.com/content/58301 and attach it to your support request.

Thank you.