Skip to main content

ProtectCommand: Failed to execute command.

Thread solved
Regular Poster
Posts: 52
Comments: 75

Hello.

This is my customer inquiry.

My customer uses Acronis 11 (for Windows).

They have been using this for a long time, but today suddenly the following error occurred.

ProtectCommand: Failed to execute command.
Additional information:
--------------------
Error code: 41
Module: 307
Line information: e6792a5ee190dd9e
Field: $module: agent_protection_addon_vs
Message: ProtectCommand: Failed to execute command.
--------------------
Error code: 17
Module: 309
Line information: 9a10fc1f8d3b96b4
Field: $module: service_process_vs
Message: Cannot find factory for command with id '8F01AC13-F59E-4851-9204-DE1FD77E36B4'.
--------------------

I searched for the message "ProtectCommand: Failed to execute the command." and delivered the following actions to them.

1. Remove all backup schedules of the device experiencing the problem.
2. Download Acronis Scheduler Manager on the machine experiencing the problem.
3. Run the file with administrator privileges.
4. Enter and run the task zap command.
(If the command does not run, please try after stopping all Acronis services.)
5. In Windows Explorer, delete all files in C:\ProgramData\Acronis\BackupAndRecovery\MMS\TasksStorage.
(If the files are not deleted normally, please try after stopping all Acronis services.)
6. Try the backup again.

However, their server did not have the path "C:\ProgramData\Acronis\BackupAndRecovery\MMS\TasksStorag", I did the rest, but the problem is still happening.

I've also tried restarting the Acronis service, deleting the backup plan and creating a new one, but that doesn't solve the problem.

What action should they take?

Thank you.

0 Users found this helpful
Forum Moderator
Posts: 242
Comments: 7052

Hello Lemoning,

thank you for your posting! I've searched for the error message in our internal sources and found several cases - checking on the documented solutions, I see that most cases have been resolved either with the re-installation\update to the latest build or after specifying the correct credentials under which services and plans are running.