Skip to main content

Recovering data - choosing selection to recover is incredibly slow

Thread needs solution
Posts: 1
Comments: 2

 Hi, I'm using Backup and Recovery 10 (the latest build), and the backup process seems to be working fine.  The challenge I've run into is that whenever I want to select a file/folder to recover in a new recovery task, it takes an exceptionally long time to browse through the "backup contents" - it takes at least 15 minutes every time I click on the + symbol to navigate further down the tree (while the "Loading..." circle continually spins).

The backup files are located locally on a separate hard drive.  Is this a known issue?  



0 Users found this helpful
Forum Star
Posts: 17
Comments: 2991

Hello Rob,

Thank you for using [[ | Acronis Corporate Products]]

We have released a new build of Acronis Backup & Recovery 10.0 (build #11133).  Please download and install the latest build. You can learn more on how to download the latest build here.

See if the issue remains. If the issue still persists, please let us know the following:

What do you mean by a separate hard drive? Is it an internal, external or networked drive? Could you please also clarify the size and the amount of the files/folders located in the folder tree?

Thank you.

Forum Member
Posts: 9
Comments: 48

I've also noticed a long waiting times when browsing through the archive. But 15 minutes is VERY long. I get some 30 sec to browser single folder. It is faster on disk then on files archives. I can also faster browser directly tib file with windows explorer then through Arconis MC. I'm currently testing 11133 version and will let you know if things improve.

I'm impressed, after what I've seen from ealier version (10287, 11105) 11133 is the best :). Updated with no problem - with a reboot request but it started and works for now.
Browsing archives is almost instant - the more folders files are in the folder the longer it takes, but still everything under 5 seconds (competed to 30 sec on folder with two files its a lot better). I'm now testing other things that did not work :)

Posts: 1
Comments: 2

Hi, I upgraded to 11133 on Friday, and still experience the same painful wait times. I'm wondering if it has to do with using Server 2003 x64.

The "separate hard drive" is an internal drive. The folder tree contains 49 000 folders and 500 000 files, for a total of about 689GB.

And to follow up from what Marcin said, it takes quite a long time to browse via the TIB files, and I've experienced Windows Explorer crashes/locks while attempting this - although it definitely seems more usable with the latest build. The Task Manager reports dllhost *32 using up 50% of the server's CPU while attempting to generate the TIB's view in Explorer. The advantage to this method (thanks for making me revisit it, Marcin) is that it will generate the entire tree at once, so after waiting an initial ~5 minutes or so, I can navigate through the file quite quickly.

Forum Member
Posts: 9
Comments: 48

On 10287 I was not able to explore the tib file directly.
On 11105 I had some problems on my servers.
On 11133 everything works fine, but I do browser from an workstation, only management console has to be installed to be able to browser tib files on the computer.
On the server where the archives are stored i get a Visual C++ error when trying to browser directly from explorer even with 11133 :)
So I'm browsing from a network share, archives consist of over 35 000 folders, about 290 000 files and are some 680GB in total. Browsing speed is now pretty reasonable.

It would be even better if exploring the archive would allow to search it with explorers search box (Vista, W7)

Posts: 1
Comments: 2

That's actually a pretty good call - I didn't realize you could install just the management console and get this functionality. I'm doing the exact same thing now - similar speed as I found on the server (~5 minutes to generate the folder listing), but at least usable. Thanks for the tip.

Posts: 0
Comments: 1

I also encounter the same problem, it takes more than 20 minutes and still can't browse the "Backup contents". I am currently, using the Advanced Workstation with build 11133.

Any idea???

Posts: 0
Comments: 1

I've got a similar problem. Browsing each level in the folder hierarchy takes several minutes. I just upgraded from version 9 which was very fast. Now I'm using version and it's close to unusable for restoring individual files.

Forum Member
Posts: 3
Comments: 39

I am using 11345 and the waiting to select items is a REAL pain. This was never an issue in TI9.

Posts: 0
Comments: 3

Similar problem. I'll lay out the situation fairly verbosely.... PATA hard drive with four partitions.
1: C drive ~10GB
2: unformatted ~10GB
3: D: drive ~ 50GB
4: I: drive ~ 10GB
Two SATA drives 350GB (G: drive) and 1TB(J: drive).

For historical reasons, the system drive (Windows XP SP3) I've been operating off is I: drive, but even without data and only programs, it became full, reporting only 20MB free. Yesterday converted the PATA drive from Basic to Dynamic to try to extend I: drive to the unformatted partition2. However it was unable due to it being either the boot/system disk or previously being a basic disk. Installed Windows XP SP2 on C: drive to boot this and try to Extend I: drive, but still failed, so I guess its due to previously being a basic disk.

Had heard some good things about Acronis for a while but hadn't had a chance to trial it, so decided this would be a good chance to try using it to resize I: drive.  Downloaded and installed the trial version "Acronis Backup and Recovery 10 (Agent build 10.0.11345)" on C: drive. Then...
1. Copied D: drive data to J: drive
2. Ran Acronis Backup of I: drive to archive file on J: drive - with validate
3. Deleted I: drive and D: drive partitions to consolidate all non-C-drive space (btw have not created the new partition yet)
4. Ran Acronis Recover
5. Selected Archive, with then has a problem, it shows....
+ Archive: Path: Personal Vault, J:\Backup2\
++ Archive: Archive-I-drive
++ Type:Disk
++ Number of backups: 1
+ Data type: Volumes
+ Content: Backup:
++ Created: 1/3/2010 9:33:09 AM
++ Size: 5.810 GB
++ Type: Full
++ Items to recover: Not defined

++ twirling wait timer - been running 45 minutes now

Now, I thought I was in BIG trouble. After running for 45 minutes I'm close to assuming it is permanently stalled. Stupidly having assumed there wouldn't be a problem restoring the files (only with redirecting the boot.ini file), and not testing further, I had a deleted partition and an inaccessible backup.  However I see in another post that I can browse and copy the files in Windows Explorer, so maybe I'm not in so much trouble - thought I'm not sure if all the permissions will be set up properly just doing a a Windows file copy to a newly created I: partition. (Expert advice appreciated)

I'll take a look for some command line stuff that will just run the restore without having to create some selection list, which is probably preferable to just a Windows copy. (Expert advice appreciated)

It would be good if the GUI Recover "just worked"(TM).

Additional Info
In the Navigation Window > (machine name) > Vaults > Personal > J:\Backup2\
it shows under the [Disk Archives] tab, Archive-I-drive > Backup #0
from which I choose View Content > As Files and I can browse then files okay.

Final Edit
Managed to get of jail with the command:
trueimagecmd /deploy /filename:Archive-I-Drive.tib /partition:DYN2
which allowed me to boot into the restored I drive.

So if the gui was working, the product would be worth looking into further.

Posts: 0
Comments: 3

Following on from above, I created a new 15 GB partition X: drive on the PATA drive containing a single empty text file in the root. Ran the Backup and then Recover and then problem appears to be the same (although I only let the timer idle for a couple of minutes - its only a small archive)

The archive is attached for your investigation.

(btw, I haven't activated the newly installed Windows XP yet on C: drive, under which I am running Acronis, since I'm not going to be using after I have restored I: drive - but I doubt that will affect anything - but mention it for completeness)

Attachment Size
15531-86860.txt 251.5 KB
Posts: 0
Comments: 3

For comparison, I created a new 15GB partition Y: drive on the 1TB SATA drive (which are Basic Disks rather than Dynamic Disks) containing a single empty text file in the root. Ran the Backup and then Recover, resulting in the same problem.

In addition, trying to go back to the start page, top of tree in the Navigation Window does nothing, and shows a notification windows "Operation in Progress. Processing, plese wait..." Pressing the button on this stops the scrolling striped progress indicator (which is a 0%) but does not close the "Operation Progress" window, nor actually cancel the operation.

So you should be able to reproduce this easily. The entire history of the system is...
1. Installed Windows XP SP2 yesterday - added required device drivers - not activated
2. Installed Acronis Backup and Recovery 10 (Agent build 10.0.11345)
3. Create a second partition with a single file
4. Backup then Restore that partition

Attachment Size
15535-86863.txt 407 KB
Posts: 0
Comments: 1

I'm in the same situation. Using version

I'm attempting to recover from a backup on a locally connected USB harddrive and when I select the Archive it just hangs with "Items to recover: Not defined".

I've been using Acronis for quite a while and love the product. I am able to restore this backup off of this drive without issue using an older version of Acronis, so it's a little disappointing that the new version won't work.

I selected the archive and let it run overnight last night. Over twelve hours. When I came back the progress icon was still spinning in the Content section.

The image I'm working with is about 12GB, so I tried switching to a smaller (base OS install) image of about 4.5GB, but no luck so far.

Any assistance would be greatly appreciated!

Edit -- 01/13/10 --
Still working this issue. I haven't resorted to the command line tactics that Ben outlined above, but I'm about to. I'm frustrated because (as others have mentioned), I spent good coin on a solution that should work and has in the past performed well for me.

I wanted to eliminate the possibility that the problem was related to restoring a backup created with an older version of the software. I created a backup using the current build and attempted to restore from the boot disk (bare metal rebuild) with the same result. I select the tib file and the software sits and spins with "Items to recover: Not defined".

Forum Star
Posts: 17
Comments: 2991

Hello all,

Thank you for posting your question, I will be happy to help. Please accept our apologies for the delay with the response.
About the "Items to recover: Not defined" message.
The exact reason of the issue is unknown. However from what you have told me this may be the possible solution:
1) Please check if the Distributed Link Tracking Client service is running. If it is, please stop this service (Start -> Control Panel -> Administrative Tools ->Services). See if the issue persists.
2) Increase the overall system performance by setting data transfer mode for the hard disk controller to DMA. Please see this article on how to do it.
If nothing helps, please obtain the below information and send a Private Message to me, I will create a FTP account to let you to upload the files:
1) Download AcronisInfo file ;
Run the downloaded file. The gathered information will be put in in the same folder, where the AcronisInfo was saved.
Running AcronisInfo may take up to 5 minutes.
2) Please obtain the screen shot of the "Items to recover: Not defined" message;
If you are not familiar with making screen shots, please read the below step-by-step instructions.
- Get to the window which you want to make a screen shot of;
- Hit the (Alt+)PrintScreen button on your keyboard;
- Run Paint usually available in Start\Programs\Accessories or another graphics application;
- Choose Paste command in Edit menu;
- Save the result picture in JPEG format being preferable.
3) Please provide us with the copy of the following folder: C:\ProgramData\Acronis or C:\Documents and Settings\All Users\Application Data\Acronis
About the low performance of the Explore operation.
There is no solution at the moment, the only thing I can suggest is to use the mount operation instead of exploring. You can also place the archive to a hard drive of a higher performance or to use internal hard drive instead of external or networked drive.
We are looking forward to hearing back from you at your earliest convenience. If the provided information is not clear or if you have any other question do not hesitate to post them and we will be glad to answer.
Thank you.


Posts: 0
Comments: 1

We are running the ABM on Server 2012 R2, intel raid volume SATA drive. I too have really slow update in populating volumes. Somtimes not at all. I have tried from the USB boot stick, A remote manager and the manager on the ABMS Server. All act the same. Once I get all set the recovery takes very little time.

I am running AcronisBackupAdvanced_11.7_50058_en-US.

Processor Intel(R) Xeon(R) CPU E31225 @ 3.10GHz, 3101 Mhz, 4 Core(s), 4 Logical Processor(s), Installed Physical Memory (RAM) 16.0 GB.

Distributed Link Tracking Client service is running.

 I am recoverying from BSP://ABMS/acronis_vault1/ which is a managed vault. and physically on a NAS.

Posts: 0
Comments: 1

thanks for this information Ben. It is really helpful for me. appreciate it. I'm always having a hard time with it... gives me waay to many headaches... no seriously, i even used a conzip.