Skip to main content

Cannot Migrate VMs - Locked by Acronis

Thread needs solution
Beginner
Posts: 3
Comments: 9

Sometimes, when I try to migrate a VM to a different host, vCenter reports that the VM is locked by Acronis and prevents me from migrating the VM. The error message I receive is:

The method is disabled by 'Acronis Agent for VMware vSphere ESX(i)'
Call "VirtualMachine.Relocate" for object "[The VM I Need to Migrate]" on vCenter Server "[F.Q.D.N]" failed.

This happens when there are no ongoing backup tasks. The last backup for the VM completed successfully.

Is it related to https://forum.acronis.com/forum/56385 ? (Specifically, Vasily's post here: https://forum.acronis.com/forum/56385 .)

Edit: I found this: https://forum.acronis.com/forum/52620
I'm running another backup of the affected VM in an attempt to reenable migration, but the backup portion of the task is already complete and I still can't migrate the VM. (The backup is complete, but it's still validating, so I'll try again after that finishes.)

Edit 2: Even after the backup completed, I still cannot migrate the VM. I still get the same error. I'll try scheduling another backup.

Edit 3: Still unable to migrate the VM. I had to do a clone instead.

0 Users found this helpful
Beginner
Posts: 3
Comments: 1

Here is a workaround that I have successfully used. It involves getting into the Vcenter SQL server, but it works.

http://kb.vmware.com/kb/2008957