Skip to main content

Unable to open ANY previous backup locations or create any new ones to restore Entire VM

Beginner
Posts: 5
Comments: 10

Hi,

I'm trying to open an existing backup location so I can restore an Entire VM from backup. The backup drive is a QNAP NAS device - never had any problem opening the volumes on the NAS before - and I can access them through SMB using the same credentials as I'm trying to use through Acronis.

I have three Appliances and none of them will open up an existing location or let me add a new one. Nothing has changed on the NAS - no user rights changed or anything at all. I also tried to open up a new location (not on the NAS) but received the same error.

Any help most welcomed - as I need to restore an Entire VM from disk really quickly!

Thanks in advance,

Paul D

The error I'm getting is this:

Code: 27066484 (0x019D0074)
Line: 785B8E25EFF8E862
Message: An error has occurred while executing command 'add_location'.

============

Code: 27066387 (0x019D0013)
Line: DCF235234C25DEC2
Message: A key holder error occurred.

============

Code: 16285701 (0x00F88005)
Line: C25B1498C08C3531
Message: Failed to store object access information.

============

Code: 7667714 (0x00750002)
Line: 23C7366F69C73E79
target: /tmp/root/.Acronis/CredStorage/acronis_wcs_wcs_locations_7ba70607-49c1-493c-98f0-004e83fbb9d9/
cred: 0
Message: Failed to write credential '{0}' to the set of user credentials.

============

Code: 262161 (0x00040011)
Line: 3D9EA26F1BFDF083
Message: The specified file does not exist.

============

Code: 65521 (0x0000FFF1)
Line: BD28FDBD64EDB8D0
code: 2
Message: No such file or directory

 

 

Beginner
Posts: 5
Comments: 10

I opened a support ticket with Acronis for this but the engineer couldn't fix it. I was told to complete the steps in this link: https://kb.acronis.com/content/50090 but the "rm -rf /tmp/root/.Acronis/CredStorage/*" command just gives me an error saying the argument is too long. The Acronis engineer received the same error when he tried it remotely via Teamviewer. 

I was then told to continue past that and then edit the VMMS.config file - so I did that, removed the lines required, resaved it up to the VA again but it still wouldn't work - even after a VA reboot.

Since then, I can now no longer log into any of my Virtual Appliances on any of the hosts - I just receive the same error as I did when I tried to open a previous backup location. I can no longer see what's backing up, if anything has failed/has problems etc.

Also, I can now no longer log into the Virtual Appliances using WINscp. I just get a "Connection Refused" error now when I try - on any of the hosts.

How can all three of my VA's on 3 separate hosts start with the same problem all at the same time? I don't get that. I don't think any of them reference each other in any way. I thought they were all completely separate entities.

I'll await a call back from the 2nd line support team!

Thanks,

Paul D

Acronis Program Manager
Posts: 22
Comments: 3084

Hi Paul,

The problem is related to appliance local disks overfill according to your first post - it's unlikely that the same issue could happen with all your 3 appliances, but still possible. With help from our tier 2 support you should be able to get back these appliances to normal. In the meantime the quickest possible workaround is to simply deploy a new appliance and use it for VM recovery (you won't need any licenses for this operation): deploy appliance using the usual Acronis Backup for VMware installer ->go to Recovery->Entire VM->Add location->browse to your QNAP NAS and restore a VM.

Thank you.

--

Best regards,

Vasily

Acronis Virtualization Program Manager

Beginner
Posts: 5
Comments: 10

Hi Vasily,

Thanks for your post.

The fault has now been fixed. It was because I was using Acronis Dashboard Appliance - and had that connected to all three of my VAs. The Acronis Dashboard Appliance writes an entry to the host VA /tmp/root/.Acronis/CredStorage folder every five minutes - so over the years it had filled all the folders on all three hosts. The VAs on the hosts will only allow a maximum of 31,998 writes to the folder before completely stopping working. I had to use WinSCP to access the folder and delete them - as the command line 'rm' couldn't delete that many entries. It took a few hours to delete all the files in each folder but now it works fine. I still had to modify the VMMS.config file (instructions in the link on my first post on here) but then after that (after a VA reboot) they all now work fine. I had to reassociate them to the vCenter Server but that's all.

I've now STOPPED the Acronis Dashboard VA from running! :-)

Cheers,

Paul D