Skip to main content

ACB 12.5.16327 Agent updates won't push...

Thread needs solution
Forum Member
Posts: 15
Comments: 37

Hi,

 

Having problems updating the agents since upgrading from Build 16318 to 16327.

If I try to upgrade the agent from Settings > Agents > [device] > Update Agent, ACB begins the process but never completes - the device displays Updating...

If I try to upgrade the agent by adding a new device (Devices > Add > Windows > [existing workstation] within a few seconds I see this error:

Cannot add this machine

Windows error: (0x80070648) Unknown property

Error code 4

 

The workstation firewall is correctly configured (even tried it with the firewall off). Tried adding the PC by name and by IP address with the same result.

 

Full error details:

Additional info:

------------------------
Error code: 22
Module: 309
LineInfo: 0x8D165E86FB819597
Fields: {"CommandID":"F67F2F21-8511-438B-A4F4-80C250FAC590","$module":"management_server_vsa64_16327"}
Message: TOL: Failed to execute the command. Adding agents to the management server
------------------------
Error code: 22
Module: 309
LineInfo: 0x8D165E86FB819597
Fields: {"CommandID":"F67F2F21-8511-438B-A4F4-80C250FAC590","$module":"remote_installation_addon_vsa64_16327"}
Message: TOL: Failed to execute the command. Adding agents to the management server
------------------------
Error code: 22
Module: 309
LineInfo: 0x8D165E86FB819597
Fields: {"CommandID":"97362C4F-AF94-43BF-9EA7-4F8E01D90248","$module":"management_server_vsa64_16327"}
Message: TOL: Failed to execute the command. Remote installation of agents
------------------------
Error code: 22
Module: 309
LineInfo: 0x8D165E86FB819597
Fields: {"CommandID":"97362C4F-AF94-43BF-9EA7-4F8E01D90248","$module":"remote_installation_addon_vsa64_16327"}
Message: TOL: Failed to execute the command. Remote installation of agents
------------------------
Error code: 147
Module: 69
LineInfo: 0x448BB490B35D3539
Fields: {"$module":"remote_installation_addon_vsa64_16327"}
Message: Request to the remote installation service has failed. This may indicate a connection failure.
------------------------
Error code: 1
Module: 598
LineInfo: 0xA0F38699A82E6C83
Fields: {"$module":"acroinst_vs_s_16327"}
Message: Failed to get property 'VersionString' of the installed product with code '{64D625A5-603E-40BF-A710-83B90B905F52}' from Windows Installer.
------------------------
Error code: 65520
Module: 0
LineInfo: 0xBD28FDBD64EDB8F8
Fields: {"$module":"acroinst_vs_s_16327","code":"2147944008"}
Message: Unknown property

 

Quite happy to leave the agent version at 16318 if it's not going to be a problem but hate seeing the count of out-of-date agents every time I log into the management console.

 

Please advise.

 

Cheers

 

 

Neil

 

0 Users found this helpful
Support specialist
Posts: 0
Comments: 1400

#1

Hello Neil!

The root cause of the issue in Windows Installer DB  which is damaged. Possibly someone deleted some keys or values in the registry manually, also it can be the result of failure from previous installations.

Please open a case with Acronis Support Team and request a remote session where our support engineer could correct the mst file configuration over the registry.