Skip to main content

Agent for XP SP2 Installation failure and question regarding Storage Node

Thread solved
Beginner
Posts: 3
Comments: 6

Hi@all.

I have to questions regarding Acronis 12.5:

1. What are the prerequisites to install the AcronisBackup_12.5_Agent_for_WindowsXP_SP2_32-bit?

Before trying to install the agent on one of our productive machine PCs, I have installed Windows XP SP2 on a test machine and tried to install the agent on it, but the installer doesn´t open/run. The local User has administrator privileges. When you try to open it, it simply does nothing. For a few seconds the hourglass cursor appears, but nothing happens. I can´t even find an entry in the Eventlog. It generates no error message at all. I´ve installed vcredist 2005 SP1,vcredist 2008 SP1, vcredist 2010, Windows Installer 3.1 (WindowsInstaller-KB893803-v2-x86), .NET Framwork 2 and 3 but nothing has changed.

2. On our Management server I haven´t installed the Storage Node component, as I thought it is unnecessary for our needs and we use one network share for all images created. In that share, we create a subfolder for each machine we are backing up. However, that has the disadvantage, that the list of the storage locations gets rather cluttered, as every subfolder has to be added as a location. E.g. \\server\share\machineA, \\server\share\machineB, \\server\share\machineC, and so on.

Is this different when using the Storage Node component? Great would be, if it would only list all added network shares and not each subfolder containing the individual images.

Thanks in advance and greetings

Andreas

0 Users found this helpful
Support specialist
Posts: 0
Comments: 1269

#1

Hello Andreas,

thank you for posting on Acronis forums!

What concerns the first problem you described, I suggest that either right-click on the installation file and Run as administrator, re-download Agent for Windows XP or wait a bit longer and check in the Task Manager what process is stalled.

As for your second question, you could have created only one folder as a backup location for your machines. They will have different backup names. Moreover, you can specify your own backup names in backup options in order to differentiate multiple backups in the same backup location. If you decide to use Storage Node, then all backup names will contain this storage node ID and it will be difficult to differentiate backup files outside of Acronis Management Console. In Acronis Management Console both variants will look almost the same way: a backup location with a list of backups stored there and a Storage Node with this list.

A backup location on a network share:

A Storage Node:

Beginner
Posts: 3
Comments: 6

#2

Hello Maria,

thanks for clarifying how the Storage Node works. I think we will stick with the current solution.

Regarding my first question. I already tried running the Installer as Administrator. I have also re-downloaded the Agent and retried the installation and waited about an hour after starting the installation. In the Task Manager no additional entry (like mxsiexec.exe,..) is shown and the installation window never pops up. I also installed the test client with Win XP SP2 twice. It´s always the same. Can you tell me if there are other prerequirements necessary to install the agent?

Greetings

Andreas

Beginner
Posts: 3
Comments: 6

#3

Is it possible, that the installer package is broken? When i try to extract it with command line arguments, it only says "Failed to parse command line". The same happens on my Business Laptop with Windows 10. On it, when i try to launch the installer, it shows a window for a millisecond and closes without an error message.

The Agent for Windows XP SP2, that is linked on the Management Server Page has the Build number 12.0.1.3750.

Support specialist
Posts: 0
Comments: 1269

#4

Hello Andreas,

I have sent you a Private Message with a download link for Acronis Agent for XP SP2 and it's checksum. I have checked it and it is ready for installation.

Beginner
Posts: 3
Comments: 6

#5

Hello Maria,

with your Installer, which is the same as the one I downloaded via our server, I had the same problem. However I tried starting the installation via command line and this way the Installer opens and I could install the agent. Strange that it is the only way, but at last it works.

Thanks and greetings

Andreas

Support specialist
Posts: 0
Comments: 1269

#6

Hello Andreas.

Thanks for sharing the outcome. At least now we know that the problem was not with the installer itself.

I am glad to know that you found a way to workaround this issue and published it here.