Skip to main content

Issue manually re-adding Storage Node (Acronis Backup 12.5.14330)

Thread needs solution
Beginner
Posts: 1
Comments: 0

Dear reader,

I'm having issues re-adding our Storage Node.
I followed the below KB:
https://kb.acronis.com/content/59863

It's stated that I have to cd in s commandprompt to "C:\Program Files\Acronis\RegisterAgentTool".
After this, I can register it via: register_agent.exe -o register -s asn -a
When doing this I receive the following result:

-----------------------------------------------------------
Failed.
500

{
"context" :
{
"$module" : "asn_rest_api_vsa64_14330"
},
"domain" : "global",
"origin" :
{
"code" : 10,
"fields" :
{
"$module" : "asn_rest_api_vsa64_14330"
},
"linetag" : "0x9bf77d935f2c69d8, e:\\497\\enterprise\\service\\impl\\crede
ntial_store_factory.cpp:133, Core::CredentialStore::`anonymous-namespace'::Secur
ePersistentCredentialStore::LoadBlob",
"module" : 630,
"suberror" :
{
"code" : 13,
"fields" :
{
"$module" : "access_manager_vsa64_14330"
},
"linetag" : "0xe839411589f18c06, e:\\528\\enterprise\\managers\\access\
\impl\\profile_vault_component.cpp:1741, AccessManagement::ProfileVaultComponent
::LookupLocalGenericAccount",
"module" : 627,
"suberror" :
{
"code" : 11,
"fields" :
{
"$module" : "access_manager_vsa64_14330",
"path" : "C:\\ProgramData\\Acronis\\BackupAndRecovery\\ASN\\Acces
sVault\\config\\preferred"
},
"linetag" : "0x2a0cf3e48ece3369, e:\\528\\enterprise\\common\\file_u
tils\\source\\file_io.cpp:46, FileUtils::OpenFileI",
"module" : 606,
"suberror" :
{
"code" : 20,
"fields" :
{
"$module" : "access_manager_vsa64_14330",
"function" : "OpenFileW",
"path" : "\\\\?\\C:\\ProgramData\\Acronis\\BackupAndRecovery\\
ASN\\AccessVault\\config\\preferred"
},
"linetag" : "0xf35f747b3b21f916, e:\\528\\core\\file\\windows\\wi
nnt_dir.cpp:525, winnt_dir::OpenFile",
"module" : 4,
"suberror" :
{
"code" : 65520,
"fields" :
{
"$module" : "access_manager_vsa64_14330",
"code" : ""
},
"linetag" : "0xbd28fdbd64edb8f8, e:\\528\\core\\common\\error.
cpp:314, Common::Error::AddWindowsError",
"module" : 0,
"suberror" : null,
"text" : "Access is denied"
},
"text" : "Access to the file is denied."
},
"text" : "Cannot open file."
},
"text" : "Access violation in module 'asn_rest_api.dll' at line '0x9bf7
7d935f2c69d8', executable: 'StorageServer.exe'."
},
"text" : "Cannot get access to protected storage."
},
"reason" : "internalError",
"serCode" : "0x0276000a+0x0273000d+0x025e000b+0x00040014+0x0000fff0"
}

-----------------------------------------------------------

Any idea's?

Much appreciated,
David Dahles

0 Users found this helpful
Support specialist
Posts: 0
Comments: 1054

#1

Hello David,

welcome to Acronis forums!

According to the error log that you've shared, the issue is in access to the protected storage (the Storage Node that you are trying to re-add). Since this issue is quite specific, it should be investigated by analyzing System Information collected from the machine with this Storage Node. 

Since you have already uploaded these logs on Acronis FTP, I have viewed them and see that you are trying to access it while being logged under asn user 2 account which does not have read/write rights on  C:\ProgramData\Acronis\BackupAndRecovery\ASN\ . Please grant full read/write rights for asn user 2 to this ASN folder and all its subfolders.