Skip to main content

HTTPS redirect problem

Thread solved
Forum Member
Posts: 12
Comments: 35

Hello,

I used Acronis Cyber Backup advanced 12.5 and recently I installed (new installation not upgrade) v15 27009. In file c:\ProgramData\Acronis\ApiGateway\api_gateway.json I chenge the value auto_redirect to true.

The first problem that I had was that I could not add the storage nodes getting the error SSL certificate problem: self signed certificate. I changed the value to false again and I could add the storage nodes. Then I changed the value to true again.

The redirection works, the backup plans work but indexing is not working properly. It finishes with the warning: SSL certificate problem: self signed certificate and it does not update the correct location usage to management server.

I changed the value to false again in order to continue working.

I use the internal FQDN of my domain (.local). Is there any option to ignore the default certificate? Should I add it to Windows trusted certificates? What do you suggest? I had no this issue with v12.5

0 Users found this helpful
Regular Poster
Posts: 12
Comments: 473

Hello Athanasios Pantziarelas!

I might be wrong, but maybe it doesn't work with self signed certificate? I seem to remember I also tried to configure https with self-signed and didn't work.

Can you request a cert from your domain CA?

-- Peter

Forum Member
Posts: 12
Comments: 35

The solution is the following :

Domain CA should be added to all storage nodes at C:\ProgramData\Acronis\CurlCaCertificates\cert_bundle.pem

and

Server certificate and key should be changed to C:\ProgramData\Acronis\ApiGateway\api_gateway.json

 

Forum Moderator
Posts: 209
Comments: 6679

Athanasios thank you for sharing your solution with the community!