Skip to main content

VmWare virtual appliance: Backup Plan Failed

Thread solved
Beginner
Posts: 1
Comments: 3

Hello,

I explain the stage:
It's an Acronis Cyber Protect 15 Backup Advanced Virtual Host installation.
Acronis console is installed in a virtual machine Windows server 2016 standard, in a workgroup.
Acronis Cyber Protect has been installed with default services accounts.
It has been deployed VMWare Appliance in one host ESXi.
Appliance Configuration has the credentials for the vcenter administrator account, the credentials for the Acronis Management Server and TCPIP Configuration.
Apparently Communication between the AMS & the Appliance seems to work fine as all the ESXi hosts and VMs appear in Acronis console.
Ports 443 and 902 has been opened between VMware Appliance and VMware VCenter.
iSCSI NAS Storage has been configured in VCenter as datastore, and set in Acronis Virtual Machine as another hard disk (secondary local drive in ms explorer).
I have created two protection copy plans (destiny \\acronis_vm\secondary_drive with Acronis VM credentials) and when running the plan, the backup failed.

I do not see any blocked traffic in the firewall.

Can you give any idea?

Thank you and regards

I attach also the error messages for the backup plans.

MESSAGE

The server refused connection

Additional info:

------------------------
Error code: 20250646
Fields: {"$module":"mms_bundle_glxa64_28035","CommandID":"D332948D-A7A9-4E07-B76C-253DCF6E17FB"}
Message: TOL: Failed to execute the command. Backup plan 'Plan de prueba'
------------------------
Error code: 20250646
Fields: {"$module":"mms_bundle_glxa64_28035","CommandID":"D332948D-A7A9-4E07-B76C-253DCF6E17FB"}
Message: TOL: Failed to execute the command. Backup plan 'Plan de prueba'
------------------------
Error code: 20119593
Fields: {"$module":"mms_bundle_glxa64_28035"}
Message: Failed to execute the command.
------------------------
Error code: 20250677
Fields: {"$module":"mms_bundle_glxa64_28035","FailCount":2}
Message: 2 activities have not succeeded. One of them is displayed.
------------------------
Error code: 20250646
Fields: {"$module":"service_process_glxa64_28035","CommandID":"8F01AC13-F59E-4851-9204-DE1FD77E36B4"}
Message: TOL: Failed to execute the command. Backing up
------------------------
Error code: 20250646
Fields: {"$module":"gtob_backup_command_addon_glxa64_28035","CommandID":"8F01AC13-F59E-4851-9204-DE1FD77E36B4"}
Message: TOL: Failed to execute the command. Backing up
------------------------
Error code: 7503931
Fields: {"$module":"disk_bundle_tape_off_glxa64_28035"}
Message: Backup of virtual machines has failed.
------------------------
Error code: 7503950
Fields: {"$module":"disk_bundle_tape_off_glxa64_28035"}
Message: Not all virtual machines have been backed up.
------------------------
Error code: 7503949
Fields: {"$module":"disk_bundle_tape_off_glxa64_28035"}
Message: Failed to back up virtual machine 'nmaad01-PRUEBASPARCHEO'.
------------------------
Error code: 7503890
Fields: {"$module":"disk_bundle_tape_off_glxa64_28035"}
Message: Failed to prepare for backup.
------------------------
Error code: 21561347
Fields: {"$module":"disk_bundle_tape_off_glxa64_28035"}
Message: Backup has failed.
------------------------
Error code: 66596
Fields: {"$module":"disk_bundle_tape_off_glxa64_28035"}
------------------------
Error code: 9764877
Fields: {"$module":"disk_bundle_tape_off_glxa64_28035"}
Message: Failed to perform the requested operation.
------------------------
Error code: 7503875
Fields: {"$module":"disk_bundle_tape_off_glxa64_28035"}
Message: Failed to prepare for backup.
------------------------
Error code: 5439582
Fields: {"$module":"esx_srv_glxa64_28035"}
Message: Failed to open virtual disk file '[genvm01-Vol] nmaad01/nmaad01-000002.vmdk'.
------------------------
Error code: 14009
Fields: {"$module":"esx_srv_glxa64_28035"}
Message: The server refused connection

MESSAGE

You do not have access rights to this file

Additional info:

------------------------
Error code: 20250646
Fields: {"$module":"mms_bundle_glxa64_28035","CommandID":"D332948D-A7A9-4E07-B76C-253DCF6E17FB"}
Message: TOL: Failed to execute the command. Backup plan 'Prueba 2'
------------------------
Error code: 20250646
Fields: {"$module":"mms_bundle_glxa64_28035","CommandID":"D332948D-A7A9-4E07-B76C-253DCF6E17FB"}
Message: TOL: Failed to execute the command. Backup plan 'Prueba 2'
------------------------
Error code: 20119593
Fields: {"$module":"mms_bundle_glxa64_28035"}
Message: Failed to execute the command.
------------------------
Error code: 20250677
Fields: {"$module":"mms_bundle_glxa64_28035","FailCount":2}
Message: 2 activities have not succeeded. One of them is displayed.
------------------------
Error code: 20250646
Fields: {"$module":"service_process_glxa64_28035","CommandID":"8F01AC13-F59E-4851-9204-DE1FD77E36B4"}
Message: TOL: Failed to execute the command. Backing up
------------------------
Error code: 20250646
Fields: {"$module":"gtob_backup_command_addon_glxa64_28035","CommandID":"8F01AC13-F59E-4851-9204-DE1FD77E36B4"}
Message: TOL: Failed to execute the command. Backing up
------------------------
Error code: 7503931
Fields: {"$module":"disk_bundle_tape_off_glxa64_28035"}
Message: Backup of virtual machines has failed.
------------------------
Error code: 7503950
Fields: {"$module":"disk_bundle_tape_off_glxa64_28035"}
Message: Not all virtual machines have been backed up.
------------------------
Error code: 7503949
Fields: {"$module":"disk_bundle_tape_off_glxa64_28035"}
Message: Failed to back up virtual machine 'TEST_ALMACENAMIENTO2'.
------------------------
Error code: 7503890
Fields: {"$module":"disk_bundle_tape_off_glxa64_28035"}
Message: Failed to prepare for backup.
------------------------
Error code: 21561347
Fields: {"$module":"disk_bundle_tape_off_glxa64_28035"}
Message: Backup has failed.
------------------------
Error code: 66596
Fields: {"$module":"disk_bundle_tape_off_glxa64_28035"}
------------------------
Error code: 9764877
Fields: {"$module":"disk_bundle_tape_off_glxa64_28035"}
Message: Failed to perform the requested operation.
------------------------
Error code: 7503875
Fields: {"$module":"disk_bundle_tape_off_glxa64_28035"}
Message: Failed to prepare for backup.
------------------------
Error code: 5439582
Fields: {"$module":"esx_srv_glxa64_28035"}
Message: Failed to open virtual disk file '[datastore1] TEST_ALMACENAMIENTO2/TEST_ALMACENAMIENTO2.vmdk'.
------------------------
Error code: 13
Fields: {"$module":"esx_srv_glxa64_28035"}
Message: You do not have access rights to this file

0 Users found this helpful
Forum Support specialist
Posts: 0
Comments: 2016

Hello Jose Carballido,

Welcome to Acronis forums!

Please check whether \\acronis_vm is accessible from the AMS machine at the moment of protection plan creation.

If everything is ok with the accessibility, please then collect Acronis System Information from the VMware Appliance machine after the issue is reproduced, open a case with Acronis Support Team and provide the engineers with these logs.

Beginner
Posts: 1
Comments: 3

Hello María,

It was a communication issue. We just reviewed the ports again, and started working.

Thanks for help

I have another problem right now:

The actual stage:

2 sites:
Production vcenter1: 2 hosts ESXi, where AMS virtual and  ESXiAppliance are in host1 + storage1

storage 2: replicated NAS from storage1(storage1 synchronize to storage2 storage1-->storage2)

There is another vcenter2 with 3 hosts ESXi and ESXiAppliance in vcenter2-host1. All the virtual machines of vcenter2 are in storage2 and are clons of the VMs in storage1.

The proble has arised because in vcenter2 we have created 2 virtual machines cloned from vcenter1 (vms has been created from replicated files in storage2). AMS console has detected virtual machines in vcenter2 but not in vcenter1.

We have followed next steps, trying to resolve:

- Deleting virtual machines invcenter2
- Unmouning the datastore where virtual machines lived in vcenter2
- Restarting the ESXiAppliance in both vcenters
- Restarting Acronis Management Server
- UNinstalling and reinstaling ESXiAppliance in vcenter2
- Restarting vcenter2.

AMS continues showing the deleted virtual machines in vcenter2, orphans, they are not in the infrastructure.
Existing virtual machines invcenter1, continue without being detected in AMS console.

Any idea? I am in troubles.

Thank you again

Forum Support specialist
Posts: 0
Comments: 2016

Hello Jose Carballido,

thank you for posting on Acronis forums!

The VMs should be assigned by AMS to a respective vCenter in several hours. VMWare appliance connects to vCenter and asks where VMs reside. Please check how your hosts see these VMs.

Thus, we recommend that you open a case with Acronis Support Team for this issue investigation.

 

Beginner
Posts: 1
Comments: 3

Hello María,

Problems are fixed.

Old orphan vms where assigned to another appliance in site1.

Unistalling and installing the appliance solved It; old orphan vms disappeared from AMS console and then the original VMs were visible.

Thanks and regards.

Forum Support specialist
Posts: 0
Comments: 2016

Hello Jose Carballido.

Thank you for sharing your solution and outcome here with other forum users!