Skip to main content

Acronis not backing up all sourced file/folders

Thread needs solution
Forum Member
Posts: 16
Comments: 75

I stumbled onto a problem where ACPHO does not backup C:\Users\xxxx\AppData\Roaming\Microsoft folder.  

I discovered that you could back the folder up if you only source the C:\Users\xxxx\AppData\Roaming\Microsoft folder.

I discovered that this fails on three different PCs, TI 2019, ACPHO 2022, Beta, and 2023.  

I discovered that C:\Users\xxxx\AppData\Roaming\Microsoft folder is backed up with an Entire PC backup.

I discovered that it only fails with a File Backup.

The problem is easy enough to reproduced.  Just create a File backup and select your user.  

Any thoughts. 

I stumbled onto this problem; I wonder what other Sourced Files/Folders it is not backing up.

I would think it would be a great selling point to have backup software that cannot backup all Sourced Files/Folders and not produce an error.

0 Users found this helpful
Legend
Posts: 110
Comments: 28569

William, in all honesty I have never even tried to make a Files & Folders backup of any of the system AppData folder contents & structure.  This is captured with any Disk backup of the OS drive where the Microsoft VSS snapshot service is able to capture any locked / system data.

If you truly feel this is a coding issue with ACPHO then I can only suggest that you raise this via a Support Case directly with Acronis Support.

Forum Member
Posts: 16
Comments: 75

I opened a case with Acronis, and it has been escalated.

My goal was not to back up the AppData folder, it was to back up my user which includes the AppData folder.  I had a problem where a folder was deleted when I uninstalled Acronis Beta Version.  The folder I needed was in the C:\Users\billc\AppData\Roaming\Microsoft folder.  It appears that the only folder not backed up was the Microsoft folder.  As you stated fortunately the folder was captured in the Entire PC backup.  

My concern is why was it not backed up and unless there was an exclusion why was there no error?  I discovered that if I backed up the AppData folder it included the Microsoft folder.  My concern is that ACPHO should backup all Sourced folders, unless there is an exclusion, and if it does not there should be an error generated.  What other sourced folders is ACPHO not backing up, hopefully none.  I have discovered that this problem has occurred on three different PCs along with TI 2019 and three versions of ACPHO, two released and one Beta.

For your information my email program creates folders in AppData.  The folder it creates is all of the emails on my PC.  Years ago, I had a Microsoft problem with a Microsoft update.  Microsoft determined that I had a corrupt user.  The solution was to create a new user and copy the files to it.  Fortunately, Acronis TI had backed up the folder I needed, and I was able to restore my emails.  I did not know that TI backed up the AppData folder until I needed it.

Forum Star
Posts: 187
Comments: 1748

I just double checked my daily data backup and there is no such problem. I backup C:\Users in the task and the Microsoft folder is there. This is part of a File and Folders backup running under ATI 2019.

I recommend you go back to the backup source definition and make sure you've done nothing to deselect that folder.

Forum Member
Posts: 16
Comments: 75

Here is what I know:

  1. I do not have TI 2019 on my PC.  A friend of mine uses TI 2019 and I had him check.  The Microsoft folder was missing.  I am not sure, but I thought I asked him to make sure the Microsoft folder is sourced.  I will verify.
  2. I bought a new PC and installed APCHO 2022.  I had a problem with the new PC, and it was replaced.  I saved the backup files, and that backup is missing the Microsoft folder.
  3. I installed APCHO 2022 on the new PC.  I created a new backup job, and that backup is missing the Microsoft folder.
  4. I installed APCHO Beta, and that backup job is missing the Microsoft folder.
  5. I uninstalled APCHO Beta and installed APCHO 2023 Release.  I used the same backups, and the new backup is missing the Microsoft folder.
  6. I created a new backup job, with APCHO 2023 current build and that backup is missing the Microsoft folder.
  7. I have checked multiple times and submitted screenshots showing that the Microsoft folder is source.

Testing Results:

  1. You said you checked, and the Microsoft folder is there.  I created a Test backup, and the source was the Microsoft folder.  I wanted to make sure ACPHO would create a backup of the folder and it did.
  2. I then created a Test backup of the APPDATA folder, and the Microsoft folder was missing.
  3. I then checked the source to make sure the Microsoft folder was selected, and it was.
  4. I then unchecked the Microsoft folder, rechecked the Microsoft folder, and ran the test.  The Microsoft folder was backed up.  I thought I had found the solution.
  5. I went to my user backup, unchecked the Microsoft folder, rechecked the Microsoft folder, and ran the user backup.  The Microsoft folder was missing.

Data submitted:

  1. I have submitted a screenshot showing that the Microsoft folder is selected.
  2. Acronis asked for a System Report, which I submitted.
  3. Acronis asked me to run Process Monitor while the backup job was running and submit the results, which I did.
  4. The next corresponded I received from Acronis said the problem has been escalated.
  5. Acronis stated, "That this may involve several subject matter experts, resulting in additional investigation time".  

Questions:

  • I wonder why your backup was successful? 
  • I wonder why my test that successfully backed up Microsoft folder worked?
  • Any thoughts.
Forum Star
Posts: 187
Comments: 1748

Bill, the question should not be why backup was successful, but rather why yours was not.

In Windows Explorer, check your view options for Folders. Do you have it set to Show or Hide hidden files and folders. When selecting Files and Folders, Acronis will not show the hidden ones if you have set Windows to hide then. On my system, AppData is a hidden folder so if you can see AppData you should be able to see the Microsoft folder.

Check your Exclusions to make sure there is nothing set that would exclude the folder.

Also note that when selecting Files and Folders as Source in ATI, be sure to consider the checkbox next to the Name column header. That should be checked if you want everything in the folder.

Beyond that I have nothing without physically seeing the machine.

Forum Member
Posts: 16
Comments: 75

I agree that the question should be why does my backup not include the Microsoft folder.  To that end what am I doing wrong?  Did you modify the exclusions?

That is why I think there is a bug.  No one has been able to tell me what I am doing wrong.  I also feel that ACPHO should be displaying an error if it does not backup a Source folder, unless there is an exclusion.  The user needs to have confidence that all Source folder/files are backed up.

As an example:

  • My user includes the iPhone picture folder.  I was getting all kind of errors because ACPHO could not backup all files under the iPhone folder because they did not exist on my PC.  The only solution I found was to uncheck the iPhone folder in the Source.  I could not add an exclusion.

You are correct the AppData folder is a hidden folder.  I have the option set to show hidden folders.

You are correct that if I reset the hidden folders option it will not show in the Source or in Recover.

I can see the AppData and Microsoft folder in Source.

I added a screenshot of the Recovery tab.  If there was a problem seeing the hidden folder AppData then I should not be able to see anything under the AppData folder including the AppData folder itself.

I cannot add an exclusion for the Microsoft folder in a File Backup.  If you know of a way let me know, but the exclusions are as they were when I installed ACPHO.  I wondered about an exclusion but do not see one.

If the problem was an exclusion, then why would my test have backed up the Microsoft folder?  It only seems to fail when I backup my user that includes the AppData folder which is backed up minus the Microsoft folder.

One thought:

  • When I created the User backup, I checked my user and nothing else.  ACPHO checked all of the files/folders under my user. 
  • I have user files on C: and D:.  ACPHO selected all files and folders for both drives. 
  • I then unchecked D:\Users\billc\Pictures\iPhone and D:\Users\billc\Pictures\iCloud Photos folders.
  • Should I have manually selected the folders I wanted under my user instead of relying on the Acronis software?
  • Even though C:\Users\billc\AppData\Roaming\Microsoft has a check by it, remember that when I ran a test and selected the C:\Users\billc\AppData folder it did not backup the Microsoft folder until I unchecked the Microsoft folder and then reselected it.  I tried the same procedure with my user backup, but it did not work.

 

Attachment Size
610617-352364.jpg 130.24 KB
Forum Member
Posts: 16
Comments: 75

I got it to work.  Notice the Recovery Screenshot - Worked.jpg.  Now I need for someone to explain what is going on.  Hopefully you can.

As a test I tried recovering the missing folder that started all this and I was successful.

If you had not responded I would not have thought about this again.  I am glad you responded.

As I stated earlier in my test, I had to deselect the Microsoft folder and reselect it.  I got to thinking.  I don't know about any other PC but on the three PCs I have used when I select my User as the source Acronis takes a long time calculating the size of the backup.  I never let it finish until today.  The reason is because on my first PC it took too long.  My new PC is a lot more powerful, and I let it complete.

Here is what I did:

  1. I deselected the Microsoft folder and let ACPHO calculate the Estimated Backup Size.  It calculated a size of 77.4 GB.
  2. I selected the Microsoft folder and let ACPHO calculate the Estimated Backup Size.  It calculated a size of 77.6 GB.
  3. Notice the image file User Bill Backup.jpg.  It now shows billc, Users, Microsoft.  Before it showed billc, Users.

In my opinion Acronis has a bug.  If you select something as a Source than all files and floders under that selection should be selected and backed up.  If a folder is selected, regardless of how it was selected, it should be backed up.

I wonder what other folders are not being backed up.  Hopefully none, but it makes you wonder.

If you disagree, then explain why.

Attachment Size
610620-352368.jpg 137.64 KB
610620-352370.jpg 38.58 KB
Forum Star
Posts: 187
Comments: 1748

Bill, I am not able to make any assessments looking at the Recovery screen shots. Can you provide shots of the specific source selections and exclusions?

Forum Member
Posts: 16
Comments: 75

I am not sure what you are looking for.  The files I upload contained a description of the file.  The file name you see is the .img file name so I can see how you would be confused.

If you want me to send a screenshot of the exclusions I will, but I did not add or subtract from what Acronis installed.  Also, if there was a problem with an exclusion, then I would think it would not backup the Microsoft folder no matter what I did.

I added two log files.

  • The first log file is the results of the backup on Friday, September 30.  Notice that it includes C:\Users\billc\AppData\Roaming\Microsoft\.  Why was that required since it already had C:\Users\billc\?
  • I was curious why Acronis showed "billc, Users".  I now know it is because I have files on two different drives.
  • The second log file is the results of the backup on Thrusday, September 29.  Notice that there is no C:\Users\billc\AppData\Roaming\Microsoft\.  In my opinion it should not be required.

The file 610620-352368.jpg shows the Microsoft folder was backed up.  This never occurred until I performed the procedure where I deselected and then reselected the Microsoft folder.

The file 610620-352370.jpg shows that Microsoft was added to the Source.  Prior to me performing the procedure it only showed "billc, Users".

I can tell you that I spoke with my friend that has TI 2019 yesterday.  He had the Microsoft folder selected in the Source.  I had him preform the deselect reselect procedure and Microsoft was added to his Source.  I am waiting on him to tell me the results of his backup, but I suspect it will back up the Microsoft folder.

The question is:

  • When you select a parent folder and Acronis selects all sub-folders and files then why does it not backup the Microsoft folder, which Acronis selected, unless you manually select it?
Attachment Size
610663-352585.log 3.84 KB
610663-352586.log 3.82 KB
Forum Star
Posts: 187
Comments: 1748

Bill, what you are showing us are the results of the backups, but not of the configurations which lead to those results. I suspect, based on your posts, that there have been edits of the task configuration that make it impossible to determine what may have led to the results you are seeing.

My suggestion is to create a completely new backup task in which you select C:\Users\billc folder in its entirety. Please tell us exactly the sequence of steps you use to do that.

Then, using the MVP Assistant please select the Acronis Configuration page and select the new task. Capture the screen shot of the Summary tab. Also capture the script file (right click, Select All, Copy, paste in Notepad).

Run a backup and see if it works.

Forum Member
Posts: 16
Comments: 75

Just to clarify.

You want me to create a new backup task and select only C:\Users\billc.  You understand that I have user files on D:\Users\billc.  I moved everything I could from C:\Users\billc to D:\Users\billc.  All of the folders are in D:\Users\billc.  I have attached a screenshot of the Documents folder.  I moved them using the Location option in the folder properties.

Just to make sure you understand when I was communicating with Acronis Support, I created the backup task I am using.  I only added the additional D:\Users\billc folder and the Microsoft folder was not backed up and it was selected.  All of the other folders in the C:\Users\billc\AppData\Roaming folder were backed up.

Attachment Size
610686-352711.jpg 140.36 KB
Forum Star
Posts: 187
Comments: 1748

Bill, now I am even more confused as to the state of your file system.

First, realize that Documents is not equivalent to C:\Users\billc.The default location for the Documents folder is C:\Users\billc\Documents. By changing the location for Documents as you did, you have now set the Documents location to D:\Users\billc. The folder C:\Users\billc\Documents should still exist but be empty.

Moving other folders under C:\Users\billc to D:\Users\billc sounds very dangerous to me. Did you actually move them or did you copy them?

I think what you want is change the location of Documents to D:\Users\billc\Documents. Downloads could be similarly relocated to D:\Users\billc\Downloads. You can do this for Documents, Downloads, Music, Videos, Pictures, etc... but not AppData! That stays on C:. Trying to change that to D: is not wise. You can simply look at the properties of each folder under C:\Users\billc and if there is a Location tab, you can relocate it.

My system is set up in the same way as you want, although on the D: driver I would just base the folders on D:\billc rather than D:\Users\billc... to avoid confusion.

First, get your file system right and then I'll bet it will work.

 

Forum Member
Posts: 16
Comments: 75

Fist let me address your concerns:

  1. You are correct there is a C:\Users\billc\Documents folder which is empty and a D:\Users\billc\Documents folder that contains all of my files.
  2. If I gave you the impression that I physically moved the folders to D: I misspoke.  When I stated that I moved the folders I should have said that I used the Microsoft location option to move the folders to D:\Users\billc.
  3. I used the Microsoft option to change the locations of the folders Desktop, Documents, Downloads, Music, Pictures, and Videos D:\Users\billc.
  4. I never moved or copied any files or folders; the Microsoft command performed that function.  
  5. I have various programs that use folders in the Documents folder and all work correctly.  Never had a problem.
  6. My goal was to preserve the space on C: (512 MB SDS) drive and use the internal D: (1TB hard drive) and I was successful.
  7. I created the folder D:\Users\billc so I would not get confused.
  8. AppData is still on C:\Users\billc.

I hope I was able to get what you asked for.  If you need something else let me know.

  1. I created a new task and named it Test User.
  2. I selected only C:\Users\billc
  3. I then ran the new task.
  4. The first img file shows the Recovery screen.  Notice there is no Microsoft folder.
  5. The second img file shows the Source screen.  Notice that the Microsoft folder is selected.
  6. The third img file shows the first screenshot of the Summary screen.
  7. The fourth img file shows the second screenshot of the Summary screen.

 

Attachment Size
610695-352729.jpg 125.06 KB
610695-352731.jpg 155.77 KB
610695-352733.jpg 163.06 KB
610695-352735.jpg 179.4 KB
Forum Member
Posts: 16
Comments: 75

I just got off the phone with my friend that is running TI 2019.  We used the procedure to deselect and reselect the Microsoft folder prior to him backing up his user.  His backup included the Microsoft folder.  If you changed the date to the previous backup the Microsoft folder is missing.  For your information all of my friend's files are on the C: drive.

I am firmly convinced that Acronis has bug.  In my opinion any Sourced folder should be backed up unless an error occurs and that does not happen with the Microsoft folder on two of my PCs and my friend's PC unless you follow the procedure of deselecting and reselecting the folder.

Since no one can tell me what we are doing wrong, if anything, I wonder what other folders/files Acronis is not backing up.

Forum Star
Posts: 187
Comments: 1748

Good news, Bill. I think I have solved the mystery.

Go to the exclusions tab in the file backup options. There are three checkboxes...
Exclude hidden files
Exclude system files
Exclude files matching the following criteria:

I can see by your pictures from the MVP Assistant Acronis Configuration that in you backup task, you have the second and third boxes checked.

On my ATI 2019 version, when I created a new backup task none of these boxes were checked. But on the latest ACPHO, the second box (Exclude system files) is checked when I created a new task.

I ran a test on ACPHO by running one backup to exclude system files and one not. Lo and behold, only when excluding system files is the Microsoft folder excluded.

Further checking says that the Exclude system files is checked by default. Once you set up the exclusion page as you like it, select "Save as default" for all further backups. Apparently I'd done that years ago for ATI 2019. Please read the document about these choices so you understand how they work.

I believe this should be the solution to your mystery.

EDIT: Comparing the Microsoft folder to others makes me wonder why Acronis feels this folder is a System folder. I don't think it should be considered as such.

Forum Member
Posts: 16
Comments: 75

I will check this tomorrow but let me ask a question. 

Can you explain why it includes the Microsoft folder if I deselect and then select it manually. Would that overwrite the exclusion? 

 

Forum Star
Posts: 187
Comments: 1748

My guess is yes.

Forum Member
Posts: 16
Comments: 75

You were correct.  By unchecking "Exclude System Files" the Microsoft folder is backed up.

You have the same question I have.  

  • The folder C:\Users\billc\AppData\Local\Microsoft was backed up prior to me changing the option.
  • The folder C:\Users\billc\AppData\LocalLow\Microsoft was not backed up prior to me changing the option.  It was backed up after changing the option.
  • The folder C:\Users\billc\AppData\Roaming\Microsoft was not backed up prior to me changing the option.  It was backed up after changing the option.

Thanks for your help.

Forum Star
Posts: 187
Comments: 1748

Glad to know that's resolved for you.

Forum Member
Posts: 16
Comments: 75

Bruno,

You know more about this than I do so maybe you will have an answer.

I have attached two screenshots and two Acronis log files.  The first log file has an error.  The second log file does not have an error.  The same backup job was used for both log files.

I followed your recommendation and unchecked "Exclude System Files", and I thought everything was good.  It did backup the Microsoft folder.

There are three Microsoft folders:

  • C:\Users\billc\AppData\Local\Microsoft
  • C:\Users\billc\AppData\LocalLow\Microsoft
  • C:\Users\billc\AppData\Roaming\Microsoft

The C:\Users\billc\AppData\Local\Microsoft was always backed up regardless of the exclusion setting.  The last two Microsoft folders were not backed up unless I unchecked the exclusion setting.

The setting name is "Exclude System Files" it does not say "Exclude System Folders and Files".

There is a folder named C:\Users\billc\AppData\Local\Microsoft\Windows\INetCache.  I cannot see this in File Explorer or via the Command Prompt.  The first screenshot shows it missing in File Explorer.  What I can do is use File Explorer with the entire path name and it displays.  The second screenshot shows C:\Users\billc\AppData\Local\Microsoft\Windows\INetCache in File Explorer. There are four empty folders.

The log file shows an error.  It is complaining about C:\Users\billc\AppData\Local\Microsoft\Windows\INetCache.

I checked the exclusion "Exclude System Files", reran the backup, and the error disappeared.  The second log file shows that there is no error.

I think "Exclude System Files" is performing what the name indicates.  It is not backing up System Files.  I cannot see the INetCache folder even though I am not hiding hidden items.

With the exclusion "Exclude System Files" selected Acronis does not backup the LocalLow or Roaming Microsoft folder.  It does backup the Local Microsoft folder minus the INetCache folder.

I think either I am missing something, or Acronis has a bug.  I think Acronis should backup all Sourced items with the exception of System Files if the option is selected.  

I think it was on the Microsoft web page where I read that System Files are the hidden files.  Clearly everything under the INetCache folder is hidden including the INetCache folder itself and that is what is not being backed up with the option selected.

In my case I think the solution is to uncheck and recheck the LocalLow and Roaming Microsoft folders.  What do you think?

Attachment Size
610872-353143.jpg 76.16 KB
Forum Member
Posts: 16
Comments: 75

Not all of the attachments went.  I do not know why.  I have added the missing attachments.

Attachment Size
610874-353152.log 3.86 KB
610874-353154.log 4.87 KB
610874-353155.jpg 23.59 KB
Forum Star
Posts: 187
Comments: 1748

Bill,

To quote from the ACPHO User Guide...
Exclude system files—Select this check box to exclude system files and folders from a file-level backup.

As for the INetCache folder, that one is specifically excluded when you check the box that says "Exclude files matching the following criteria:".

System files and Hidden files are not the same thing.

I suggest you do not check any of the three boxes on the exclusions options page and just select in the Source which folders you want or don't want.

 

Forum Member
Posts: 16
Comments: 75

I did not realize that the INetCache folder was specifically excluded.  If you look at the log that has the error, you see C:\Users\billc\AppData\Local\Microsoft\Windows\INetCache\*.  Any thoughts as to why it tried to back it up?

The INetCache folder is not visible in ACPHO Source.  When I saw the error, I was going to uncheck it, but it was not available.

In my case I think I need to leave "Exclude System Files" and "Exclude files matching the following criteria" checked and use the procedure I discovered in Source to back up the two Microsoft folders.  

The strange thing is that ACPHO will back up the Microsoft folder that contains INetCache and will not back up the other two Microsoft folders unless you uncheck "Exclude System Files".  All of the Exclusions that are listed are in the C:\Users\billc\AppData\Local folder.