Skip to main content

Unable to access support for my active subscription

Thread needs solution
Beginner
Posts: 3
Comments: 5

I was expecting a support call at 1pm today and I didn't get one. I tried the usual route to contact support by phone to check whether the the support level had been delayed or forgotten. I was signed into my account. The product list shows my active subscription has been updated to Acronis Cyber Protect Home Office. I clicked on support|Technical Support. It advised me that I needed to Register a product to access support!

I went back to the main support page and clicked on Trial / Activation / Pre-sales / Privacy / Licensing question. I chose "Start Instant Chat". I input my problem about "subscription not registered for support" - It offered to switch me to a support engineer. I clicked yes. I was taken to a screen that told me to click on a "Chat Now" button that doesn't exist.

Normally I would be able to simply request assistance and get access to a UK phone number. This was stored on my phone so I rang it and was not given the opportunity to talk to a human but told that I needed to put in a paid support id number which I didn't have so I couldn't progress. What is going on?

0 Users found this helpful
Legend
Posts: 106
Comments: 26369

Nigel, when you are signed in to your Acronis Account, click on the Support option, then on Technical support, which will then show you a list of registered products.

When I do this for my own account, it starts off by showing me ATI 2021 then earlier versions of ATI but if I scroll down further, it then shows me ACPHO products!

Most users would expect the most recent product to be shown at the top of the listing but this is not the case here!!!


Forum Moderator
Posts: 207
Comments: 6627

Hello Everyone, 

I've reported this issue to the responsible team, sorry for the inconvenience!