Skip to main content

Acronis Drive Monitor interferes with flash drive operation

Beginner
Posts: 1
Comments: 1

I had Acronis Drive Monitor installed on my system (the installer file version was 1.0.0.566) and had it configured (I thought) to only monitor my C drive and also another external (USB) hard disk drive. In spite of this configuration I saw periodic unexplained activity on USB flash drives that were connected to the system.  Those same flash drives (a Patriot 8Gb and an Imation 16Gb; both relatively new) started generating errors when transferring large files. I ran a flash drive test utility and it showed very regularly-spaced corrupted "sectors" on the flash drive. Subsequent runs of the test utility showed the same corrupt sector spacing but in different locations on the flash drive. Since it was periodic in nature but randomly located I suspected that it might be related to the periodic activity that caused the flash drive activity light to blink every now and then when the system was expected to be idle.  I fired up Sysinternals' Process Explorer and watched for new process activity that coincided with the blinking of the flash drive and it turned out to be Acronis. I quit DriveMonitor and the blinking continued. I shut down the Acronis Scheduler and the blinking stopped. I have uninstalled the Acronis software and I can now move large amounts of data to and from the flash drives without any errors or data corruption. This is on Windows XP with SP3.

Flash Drive I/O errors cause by Acronis DriveMonitor & Scheduler Service

Attachment Size
flash_drive_test.jpg 130.83 KB
Beginner
Posts: 0
Comments: 1

I had a similar problem using a Medion 64 Gbyte USB-stick (MD86694) when drive monitor was installed on a win XP SP3 computer. Size of all subdirectories is reported 0 kbyte and empty subdirectories are displayed. The size of the files in the root of the stick is reported correctly but none of the files is accessible. After deinstallation of drive monitor everything works fine and all subdirectories still contain the data that have been stored.

A 32 Gbyte Medion Stick (MD86602) worked fine when drive monitor was running.

Forum Member
Posts: 1
Comments: 70

I don't have such an issue, but i'm interested under what circumstances this happens.
It may be relevant, what filter drivers are installed in your systems.

Can you *both* please run the following commands and then paste the output from notepad to this thread?
If you e.g. have an AntiVirus software installed, it's driver names will be also shown in addition to Acronis and Microsoft drivers.

fltmc >> filters.txt
reg query HKLM\SYSTEM\CurrentControlSet\Control\Class\{4D36E967-E325-11CE-BFC1-08002BE10318} /v UpperFilters >> filters.txt
reg query HKLM\SYSTEM\CurrentControlSet\Control\Class\{4D36E967-E325-11CE-BFC1-08002BE10318} /v LowerFilters >> filters.txt
reg query HKLM\SYSTEM\CurrentControlSet\Control\Class\{71A27CDD-812A-11D0-BEC7-08002BE2092F} /v UpperFilters >> filters.txt
reg query HKLM\SYSTEM\CurrentControlSet\Control\Class\{71A27CDD-812A-11D0-BEC7-08002BE2092F} /v LowerFilters >> filters.txt
notepad filters.txt

In addition to the build number of used Acronis products (if you have more than ADM 566):
please also check if stopping all Acronis services helps.
If yes retry with only "Acronis Scheduler2 Service" started, which is needed by Acronis Drive Monitor.