Skip to main content

Acronis Recovery for SQL Backup Fails

Thread needs solution
Beginner
Posts: 1
Comments: 2

Windows Server 2003 Ent. SP2. SQL 2005. Acronis Recovery for SQL build 212
When I start a backup job it starts then gets a status of Failed. I then get the email with the failure report.
I have done the following troubleshooting:
1. deleted and created a new backup Job. still fails
2. uninstalled the Agent from the SQL server and reinstalled. one successful backup then all other backups fail.
3. stopped and started the Acronis services on the SQL server. Still fails
4. Tried to backup individual DBs. still fail
5. Changed recovery mode from FULL to SIMPLE on all DBs. still fails
6. Tried backing up to a different location. still fails

I get the following failure when executing a backup:

Location: \\x.x.x.x\XXXX/. Start time: 12:54:03 PM. Error: Member invoke failed (0xE000B) token = ".Apply", $module = "C:\Program Files\Common Files\Acronis\DatabaseBackup\Fomatik\DataWalker.dll" Tag = 0x298D61E7C0088CAD Failed to create backup of database 'XXXXX' from Microsoft SQL Server '(local)'. (0x571026) $module = "C:\Program Files\Common Files\Acronis\DatabaseBackup\Fomatik\MsSqlBackup.dll" Tag = 0x120B5C319F646E8F MSSQL_ClientVirtualDeviceSet::GetConfig fails. (0x572000) Tag = 0x38930F7709E7627C Unknown Win32 error (0xFFF0) code = 80770004) Tag = 0xBD28FDBD64EDB8BBFailed to create backup of database 'XXXXX' from Microsoft SQL Server '(local)'. (0x571026) $module = "C:\Program Files\Common Files\Acronis\DatabaseBackup\Fomatik\MsSqlBackup.dll" Tag = 0x120B5C319F646E8F MSSQL_ClientVirtualDeviceSet::GetConfig fails. (0x572000) Tag = 0x38930F7709E7627C Unknown Win32 error (0xFFF0) code = 80770004) Tag = 0xBD28FDBD64EDB8BBMSSQL_ClientVirtualDeviceSet::GetConfig fails. (0x572000) $module = "C:\Program Files\Common Files\Acronis\DatabaseBackup\Fomatik\DataWalker.dll" Tag = 0x38930F7709E7627C Unknown Win32 error (0xFFF0) code = 80770004) Tag = 0xBD28FDBD64EDB8BBUnknown Win32 error (0xFFF0) code = 80770004), $module = "C:\Program Files\Common Files\Acronis\DatabaseBackup\Fomatik\DataWalker.dll" Tag = 0xBD28FDBD64EDB8BB.

0 Users found this helpful
Forum Star
Posts: 24
Comments: 3268

Hello SteveW,

Thank you for finding time to join us on Forum, we're glad to greet you here. I understand your concern, and will do my best to help you.

"Member invoke failed" is a very common issue, which may point onto the different issues, so this situation requires investigation. Please gather the following information: 

  1. AcronisInfo from the Agent machine
  2. Exact sequence of steps performed
  3. Screenshot of the issue
  4. Please check whether a database can be backed up successfully by means of MS SQL native utilities.

    In most cases, you can create a backup by native MS SQL utilities in the following way:

  5. Open SQL Management Studio;
  6. Right-click on the database that you want to back up and select Tasks -> Backup

See also the following MSDN articles:

After that please submit a case with the information attached, and let us know it's number.

Should you need anything else or have any further questions - feel free to contact us at your earliest convenience, we will be happy to help you!

Thank you!

Beginner
Posts: 1
Comments: 2

Can you please give me some troubleshooting steps to try that may fix this issue? or if you have some kind of patch or hotfix that may fix the issue can you tell me how to download it. I know you said this is a common issue so there must be something to try to resolve it.

Sequence of steps and log results:
1. logon to our Acronis management server
2. Start Acronis SQL
3. Connect to our SQL server and use the domain admin un/pw to connect to the SQL server
4. run the scheduled task manually (or as scheduled)
5. interface Says task started then says Status FAILED within 30 seconds
6. Log says "backup operation started" then the next line says Module 87 "Failed to create backup of databse XXX" The previous entries (module 82 entries) say successful.
7. Log then says Module 87 "MSSQL_ClientVirtualDeviceSet::Get Config Fails
8. Log then says Module 0 "Unknown Win32 error"
9. Log then says Module 82 "Backup Task failed. Reason: Member Invoke failed"
10. Log says Module 65 "Execution of task failed"
11. Log says Module 14 "Error on Executing bytecode"
12. then the log repeats the same errors again

Forum Star
Posts: 24
Comments: 3268

Dear Steve,

I entirely understand your concern, and I wish I could offer you something as a solution, but unfortunately there's nothing I can advise that would be safe for the system, as it may appear so that we're trying to cure a cold by amputating a leg. If I could provide you with something in addition to the information request, I would definitely do it.

Unfortunately we need to review all the logs fully to have a clear picture of the issue in order to provide you with the best solution possible. The errors are too common, they cannot even tell us where the issue occurred: during the access to the database, in the Agent processes, when running the backup processes, when writing the data to the backup... That's why we need the diagnostic data.

I'm extremely sorry for the inconvenience faced, and will be glad to help you with the issue. Please let me know if you have any case opened regarding this problem - I will make sure it's handled in a proper way.

Thank you once again for cooperation and patience.

Beginner
Posts: 0
Comments: 3

I have this same issue. I have to go in and stop and restart the SQL Server for it to work for a while. Now that doesn't even work. I have given the tech team there all the information and the file they have you run isn't capturing all the information so they have no way to help me. I notice the last pose on this was Feb. of this year but I would like to know if there has been a fix? I have 5 servers with 400 customer's databases on each that I can't back up and having to "babysit" this program is starting to become a horrible nightmare.

Beginner
Posts: 0
Comments: 1

I get the same error message once I backup ms sql server. can some help