Skip to main content

Snap Deploy 5 - *SOLVED* Machines on new server always report as not ready

Thread solved
Beginner
Posts: 2
Comments: 8

Hi,

I'm in the process of testing a new server.

Current setup:

  • Server 2012 R2 as the licence and deploy server
  • 20 client machines
  • Local workgroup network

I have never had an issue and everything has worked from day 1.

However, when I try the exact same setup with the new server (Server 2019), all machines that work fine with the current server, now report as not ready.

I can connect to the machines fine, install tools to them and take an image from them, but the machine status never changes.

I have tried with build 1749 & 1924.

Is there something that needs to be done on the original server that might be blocking something?

*Update* I've tried Server 2012, 2016 & 2019 on the new box and all have the same issue.

Regards

0 Users found this helpful
Beginner
Posts: 2
Comments: 8

Finally solved it!

If I created a bootable agent USB drive, the machines will show as ready.

However, I noticed you can choose whether or not to specify a deploy server when creating the bootable media.

I chose not to.

This made me realise that all of the existing agent windows client installations must be tied to the original deploy server.

Low and behold there's a reg key for the server IP address.

So if you're going to replace your server, make sure it keeps the same IP that the original had.

However, my original server needs to keep that IP for other functions.

So if like me, your server IP is going to change, you have to change the following reg key on every client:

HKEY_LOCAL_MACHINE\SOFTWARE\Acronis\SnapDeploy\ManagementAgent

Update the value for Server to the new IP address

Happy days!

Forum Moderator
Posts: 113
Comments: 4338

Iain, thank you for sharing the results of your investigation, good to know and may be able to help others