Skip to main content

Snap Deploy and WinPE (win 10 1809)

Thread needs solution
Beginner
Posts: 1
Comments: 0

Dear all,

I'm trying to use Snap Deploy to deploy master images of the last Win10 1809 version from PC i've just received.

Actually, my first issue was that I could not use the standard Linux based media. I got a video error (code 0x1480006 : Invalid video framebuffer parameters).

After checking the topics, I found out that I could use the Windows PE to avoid this error.

I donwloaded the last ADK / AIK from microsoft's website (here https://docs.microsoft.com/en-us/windows-hardware/get-started/adk-install) and install everything, both ADK and PE add-on. Restart my computer.
But I still can't create my PE image through PE builder. The first option (auto create) is greyed out, and when I use the second one to find a winPE.wim presents in ADK files, I still got an catalog error.

I really don't know where I'm wrong. Is my snap deploy version not compatible with Win10 1809 ? (I have Snap Deploy 5.0.1 780)

Thank you very much to who could be able to help me, if someone have already done it.

Regards,

/Baptiste

0 Users found this helpful
Support specialist
Posts: 0
Comments: 335

Hello Baptiste,

welcome to Acronis forums!

What concerns the video error you receive when booting a target PC from standard Linux-based media, please press E during the boot when you see a message "press <e> to edit kernel command line". Then please type: vga=0x314 and press Enter.

As for Win PE media creation issue, please check the troubleshooting steps described in this KB article: https://kb.acronis.com/content/46220

If it still does not help, please collect the diagnostic logs listed at the bottom of KB article and contact Acronis Support Team

Forum Member
Posts: 4
Comments: 25

Baptiste,

Acronis Snap Deploy 5 U3 doesn't support using the latest Win ADK. You must use version 1607 if you want Acronis to create the WinPE WIM for you. Not sure why Acronis specifically requires this version, but its extremely outdated and they need to add support for later versions.

If you need absolutely need a newer WinPE (like we do, as there are quite a few new features since 1607), you can create the WinPE WIM using the newest ADK on a separate machine (or preferably in a VM) via copype (use the boot.wim inside the sources folder). Then on your machine with Acronis and Win10 ADK 1607 installed, you can select the boot.wim you generated earlier and it will slipstream all the Acornis binaries and configs into it.  

Then you can upload that WIM into your Acornis PXE Server or to your custom PXE server (we use WDS).

Forum Moderator
Posts: 109
Comments: 4054

Hello Everyone,

support for versions 1703, 1803, 1809 is expected to be added in the upcoming update 4 for Acronis Snap Deploy. Preliminary ETA is February, but no fixed date yet. I'll post an announcement on forum once the update is available. 

Thank you, 

Forum Hero
Posts: 46
Comments: 7175

FYI, you can use the latest Win 10 ADK in the Acronis MVP rescue media builder.  It works fine with True Image and Snap Deploy as long as you have the latest ADK installed.  You can get it from the link to the right >>>>>>

Or from the KB article

https://kb.acronis.com/content/59335

Driver injection is really easy with this and you end up with a really nice user interface on the client side when booting this instead of the default environment.  

Beginner
Posts: 0
Comments: 1

Has this been release yet for Snap deploy 5?  I am still not able to  'upload PE image to PXE'  with 1809 ADK installed, as it does not recognize the ADK

Ekaterina wrote:

Hello Everyone,

support for versions 1703, 1803, 1809 is expected to be added in the upcoming update 4 for Acronis Snap Deploy. Preliminary ETA is February, but no fixed date yet. I'll post an announcement on forum once the update is available. 

Thank you, 

 

 

Forum Hero
Posts: 46
Comments: 7175