Skip to main content

Need NVMe SSDs Imaging help - How to?

Thread needs solution
Jam
Beginner
Posts: 1
Comments: 1

Greetings everybody,

 

I've done quite a bit of looking around for a concise method to Image M.2  NVMe drives but have only found bits and pieces of information.  Does anybody have a proven method that works?  If so, can you provide explicit steps start to finish?

 

My environment:

Snap Deploy 5  v1755

Lenovo M710q machines.  They have Intel M.2 NVMe SSD's in them but I can't seem to image them with Snap Deploy.

Lenovo M700 /Dell Optiplex .  These have standard SATA drives and SD5 will take an image / push an image to these devices without issue.

 

What I've done:

In the BIOS I've disabled Secure Boot, and left the system in AHCI mode for drives.

Hand built a Windows 10 machine on a M710q and created an image with the SD5 management console (states successful) but whenever I try to remotely image a machine it completes and boots up to a No Operating system message. 

 

Thanks in advance,

 

James

0 Users found this helpful
Forum Moderator
Posts: 207
Comments: 6603

Hello James,

Welcome to Acronis forums! Read my response here. So, in short, NVMe drives are fully supported and don't require any particular steps to be completed before the imaging. What could be an issue here is the lack of necessary drivers. For example, some NVMe drives have the SATA mode set to RAID by default. The default LInux rescue media doesn't have current drivers for modern RAID controllers, so you will have to build WinPE rescue media to support the RAID setup and NVME drives in this setup or disable RAID mode as described in the following article https://kb.acronis.com/content/58006

Thank you, 

Beginner
Posts: 0
Comments: 1

Hi All,

We had a similar issue where Snap Deploy 5 & 6 wouldn't recognise the built in NVMe when trying to take an image of the machine or deploy an image to the machine (both Linux based and Windows PE versions of the software). Snap deploy simply wouldn't show the NVMe drive as a disk. To resolve this we had to go into the bios of the machine and change the following:

"SATA/NVMe Operation"

By default the option "Raid On" will be turned on, change it to "AHCI/NVMe"

It maybe named differently from different manufacturers but this is for a Dell.

PS - You need need to turn off secure boot as well if the above doesn't work.

Forum Moderator
Posts: 207
Comments: 6603

Sean, thank you fo sharing your experience with the community!