Skip to main content

Realtek Driver Isssue

Thread needs solution
Posts: 3
Comments: 5

Hello everybody,

yesterday after the deployment of Windows 10 Professional (x64) on a new laptot, i found a problem with Realtek HD Audio Controller drivers.

The laptot is an Asus X550LD, and even installing the downloaded drivers from the asus official site the problem persisted (only for the audio while the other drivers have been installed correctly).

In a second moment, trying to figure out the problem, i've distributed with clonezilla a master image created on the same virtual environment of the first Acronis image distributed but the problem did not occur.  The only differences between the two images is that are the second image was created with Micrsoft sysprep and acquired with clonezilla, while the first image was create and acquired directly with Acronis Master Image Creator and deployed with Universal restore.

Have you received similar feddback in the past? Have you any suggestions to solve this problem?

0 Users found this helpful
Forum Hero
Posts: 70
Comments: 8346

I've seen it before too, and would go into the registry and make the change.  I don't know why it happens on some deployments and not others, but what seems to happen on some systems is not a driver issue, but it actually shows up in device manager as "failed to start" which prevents the driver from loading.  Just curious, but see if 1 of these gets the audio to work (as a work-a-round).

01) HKEY_LOCAL_MACHINE\SYSTEM\controlSet001\Services\HDAudBus

Modify REG_DWORD "Start" and set it to 3

Go back into computer management >>> device manager and uninstall the "high defintion audio controller"

Scan for hardware changes and it should pick up the generic driver and audio should work again.  

----------- OR -------------

02)…   (Once removed, then delete the driver and reinstall and see if that helps.)


in the right pane, righ-click UpperFilters
If you do not see UpperFilters there, find and right-click LowerFilters. (Note: If you do not see the UpperFilters or LowerFilters registry entry, this method is not for you.)
Click Delete on the context menu.

When you are prompted to confirm the deletion, click Yes.  Restart the PC


Of course, that doesnt' solve the issue as to why it happens, but if you can repeat it on the same image deployment, I would open a support case with Acronis and provide this information - especially if one of them fixes the issue after deployment.  

Also, for my own testing, this is what I'd do...

Take the same sysprepped system that works with Clonezilla and take an image of it with Snap Deploy Image Creator.  Then push it to the same trouble hardware with Snap Deploy WITHOUT the universal deployment and see if the same audo behavior occurs or not.  

If not, take the same sysprepped image and then deploy with Snap Deploy and run univesal deploy and see if the audio works with the sysprepped image.  If it works with sysprep first, but not without using sysprep, you have a work-a-round.  If neither works, this is definitely something Acronis should look into more closely.

Posts: 1
Comments: 1

Thanks for the soulotion N01, it worked for me and saved the day!

In reply to by Bobbo_3C0X1

Posts: 1
Comments: 9

This helped me as well. Thanks.

Posts: 0
Comments: 1

Thanks very much.  Solution #1 worked for me, as well.  The only additional wrinkle was that after the hardware scan found the "new" device, no drivers were available.  I then downloaded the audio driver from the manufacturer (Lenovo in my case), installed it, and all is now working fine.

Posts: 0
Comments: 1

Solution #1 worked!

I have a Toshiba Satellite S55-A5295. Just installed Acronis cloned WD BLUE 3D NAND SSD 1TB and lost audio. Tried several fixes that didn’t work.

Changed Start from 4 to 3 then reinstalled High Definition Audio Controller.

Red X over Sound icon went away - Sound is working now!

Thank you!

Forum Star
Posts: 60
Comments: 2006

There is an easier fix from Device Manager. Open the properties of the Realtek controller. Click Update Driver. Click Browse my Computer. Click Let me choose from available drivers. Highlight the Realtek controller. Click Next. The driver gets corrected.

Posts: 0
Comments: 1

You can download Realtek audio drivers from Realtek. To get them, you need to go to the website, find the drivers corresponding with the sound card model and your specific flavor of Windows 10 (32 or 64 bit), and download the driver manually. Once you’ve downloaded the correct drivers for your system, double-click on the downloaded file and follow the on-screen instructions to install the driver. If you don’t have the time, patience, or computer skills to update the Realtek driver manually, you can do it automatically with Driver Easy.

Posts: 1
Comments: 2


@Bobbo_3C0X1, you, Sir, are a genius.  I have been trying to fix my audio for days now.  I tried downloading and reinstalling the realtek audio drivers, uninstalling the High Definition Audio drivers from the device manager, everything.  I finally stumbled across your post above, and the first fix you suggested fixed everything.  I can't thank you enough!


Posts: 0
Comments: 1

@Bobbo_3C0X1. Thank you so much. Tried a heap of things first. The Regedit worked! Oh Blessed relief.