Skip to main content

Unable to restore backup due to drive ID

Beginner
Posts: 1
Comments: 0

I have made all my backups routinely like a good little computer owner. The backups started to take up way too much space, so I copied them out to another drive. Now when I have gone to restore the backups I have found that WHAM! Acronis for no apparent reason requires you to use the same drive you first copied it onto, not just whatever drive has the backup on it. I have tried for almost the entire day to copy the tib file back to the original disk, but it will not go, it works for about half an hour then tells me "Cannot read from media". I've tried 3 computers and a direct connection to a network drive, the file will not budge. So now I have backup software and a completely fine and intact, otherwise usable backup, but it won't restore because  it's in a new place. I understand why you might wish to warn someone about the fact it's not the "correct" drive, but why in the world would you insist like this? The option comes up to "ignore" the warning, but pressing "ignore" just cancels the task, it doesn't let me ignore the problem and proceed anyway. If you make a second backup of a backup in case of drive failure, only one of them will ever be any use, so still you have only one backup. This is the craziest thing I ever heard! 

How do I now use my perfectly good backup to restore the files from the perfectly good drive with my perfectly good sofware? (The drive is now full, so I can't create another backup with the same name then delete the wrong one and use the old file, it won't fit). 

Forum Hero
Posts: 28
Comments: 9277
mvp

Top

Clare, welcome to these User Forums.

Please can you clarify exactly what you are trying to do here?

The only time that Acronis will have a problem with backup files being moved is if you are attempting to do a Restore or Recovery based on an Acronis Task in the main application GUI that originally created those files, which in turn would suggest that you are also attempting to do the Restore or Recovery from within an active Windows OS system.

The reason why the above is a problem is because when you run an Acronis backup task, information about the files created by that task is stored in an internal database but this references the original backup location, not where you have moved the files to.

To resolve this issue, you can do a Validation of the Backup Task and then direct the process to where the files are now stored.

The alternative method, and recommended for when Restoring / Recovering a backup that includes the Windows OS partition, is to boot the computer from the Acronis Rescue Media and do the restore in that way, completely separately from Windows and without any need to use the database information.

I have no idea why you are having the other problems in trying to move the backup files to other locations but that is a different issue.  If your backup files are all complete on your current storage drive then provided you can connect that drive to your computer and boot from the Rescue Media and see those files, then recovery should be possible, assuming that all the files are good.