Skip to main content

Notebooks won't wake up for scheduled backups

Thread needs solution
Beginner
Posts: 1
Comments: 8

Hi everyone,

First post here. I have two notebooks that I have set to sleep after 45 min of inactivity. I have True Image 2016 configured to do scheduled incremental backups to my WD EX2100 NAS. I can't get them to wake up and run the backups reliably. More often than not they don't backup. One is running windows 8.1, the other windows 10. They do run the incremental backups when I click the backup now button. Thanks for any advice in advance.

Terry

0 Users found this helpful
Forum Hero
Posts: 67
Comments: 7990

Terry,  Are the backups set to run around the same time each day/night?   If so, you can try creating a separte Windows Scheduld Task to wake the computer a few minutes before then.  

http://www.howtogeek.com/119028/how-to-make-your-pc-wake-from-sleep-automatically/

Is your NAS connected via USB or across the network?

Even when not "sleeping" your system may be in a lower power state which turns of network adapters, usb ports, and/or hard disks.  You want to go into your computers advanced power settings and make sure that the disk is not set to stop after a period of idle time, and do the same for the NIC and/or USB ports if available there as well. 

After that, you want to go into computer management / device manager and then do the same for your network card and USB hub as well (see screenshot).

If you have drives like WD green they will also power off and may not wake properly.  Your NAS may have power saving features as well.

 

 

Attachment Size
341875-126910.png 126.15 KB
341875-126913.jpg 48 KB
341875-126916.jpg 50.32 KB
341875-126919.jpg 48.06 KB
341875-126922.png 70.29 KB
Beginner
Posts: 1
Comments: 8

Bobbo_3C0X1 wrote:

Terry,  Are the backups set to run around the same time each day/night?   If so, you can try creating a separte Windows Scheduld Task to wake the computer a few minutes before then.  

http://www.howtogeek.com/119028/how-to-make-your-pc-wake-from-sleep-automatically/

Is your NAS connected via USB or across the network?

Even when not "sleeping" your system may be in a lower power state which turns of network adapters, usb ports, and/or hard disks.  You want to go into your computers advanced power settings and make sure that the disk is not set to stop after a period of idle time, and do the same for the NIC and/or USB ports if available there as well. 

After that, you want to go into computer management / device manager and then do the same for your network card and USB hub as well (see screenshot).

If you have drives like WD green they will also power off and may not wake properly.  Your NAS may have power saving features as well.

Hi Bobbo,

Thanks for the comments. Somehow the power settings changed in the W10 notebook. I reset it to never sleep. I'll leave it on tonight and see what it does. As for the NAS, it is over Ethernet. It does take a moment to come only when not accessed for sometime. I think I have it set to spin down after 20 minutes.

I have been using a scheduled tasks to launch a RoboCopy batch files to copy updated files from the 3 PCs during the night. These have generally been running OK.

I was surprised that there doesn't seem to be a task scheduled to launch the Acronis backup. Maybe that's the problem. I'll look into my W7-64 machine. It has been running the backups on time.

Anyway, thanks again. I'll post what happens tomorrow.

Terry

 

Beginner
Posts: 1
Comments: 8

Well I have had some success. It appears Acronis won't wake up a sleeping PC. I think I have everything set up correctly. My desktop runs pretty much 24-7 so it's not a problem. I am leaving the new Lenovo W10 notebook on at night. I'll run in this mode for a few days. Then I'll set up a Windows Scheduled Task to wake it up. This could be a problem because the timing of these events doesn't seem to be very well controlled. I downloaded the user guide and that clarified some things. For example, entire PC is NOT what I want for my desktop. It has several mutil terrabyte drives since it also serves as a backup media center DVR. I only want the C drive. The Disks and Partitions source was the way to go.

Forum Hero
Posts: 67
Comments: 7990

I agree - I never use "entire PC" - only "disks and partitions" as it allows for control of exactly what disks/partiions should be backed up.  Entire PC could potentially backup other large drives.

As for the timiing issue and not coming out of sleep for scheduled backups, if you're backups are set to run at the same time, I  believe a scheduled task to wake the computer a few minutes before hand should work in your situation.   I would think Acronis would wake the system if the task is scheduled, but I have not tried before - someting i'll have to test  later.  You may want to check your computer services and verify that the "Acronis Scheduler2 Service" is set as STARTED / AUTOMATIC, along wiht the Acronis Remote Agent Service, and Acronis Managed Machine Service Mini.  I don't use nonstop backup so I've disabled that service permanently on my systems.

Beginner
Posts: 1
Comments: 8

Thanks again Bobbo. I'm still learning what makes this program tick. The one thing I noticed is none of the PCs have a windows task scheduled to do a backup. I would like to get it to work with the notebooks sleeping. That way I can just leave them on 24/7. First I'll test it for a few days with the PCs on at night. Take care.

Forum Hero
Posts: 67
Comments: 7990

Correct.  There are no Windows tasks created with the sheduled backup tasks when you create them.  The Acronis Scheduler service is supposed to take care of that without needing to create Windows schedueld tasks. 

Did you select the "wake up the sleeping/hibernating computer" check box in your backup task?

http://www.acronis.com/en-us/support/documentation/ATI2016/#7941.html

  • If you want to wake up the sleeping/hibernating computer to perform the scheduled operation, select the Wake up the sleeping/hibernating computer check box.

 

Attachment Size
343892-127168.jpg 51.13 KB
Beginner
Posts: 1
Comments: 8

Yes sir. It is checked.

Forum Hero
Posts: 67
Comments: 7990

Ok, just wanted to be sure.  

Check "computer management / services and applications / services"

make sure that the following (if you have them all - I have snap deploy installed on this machine too, so think i have an extra one) are all set to:

status = started / startup type = automatic

Acronis Managed Machine Service Mini, Acronis Remote Agent Service, Acronis Scheduler 2 Service, Acronis Sync Agent Service

Then, also check to make sure that your startup service are running (start / search / msconfig    and press enter).  Go ot Startup tab (in Windows 10, just open task manager and go to the startup tab).

Acronis scheduler helper , Acronis Tib mounter, TrueImageMonitor.exe

Beginner
Posts: 1
Comments: 8

Hi Bobbo,

I show four services for Acronis. Their status shows as running. Startup type was automatic except for Acronis Sync Agent which was set for automatic/delayed start. I changed it to automatic. This is on the W10 Lenovo notebook. It IS backing up now on schedule but I still have sleep disabled. I swear i had the desktop set for 11:30 pm. It missed the backup. When I checked the settings. It was set for 11:30 AM. But getting close. I'll try setting up the NB to sleep this weekend and setting up the scheduled wake up task if necessary.

Thanks again,

Terry

Beginner
Posts: 1
Comments: 8

All,

Well as near as I can tell, ATI16 just won't reliably wake up a sleeping PC to run the backups. They run properly if I leave them on.

So I'm going to try a scheduled task (in the task scheduler) to wake up the notebook(s) say 5 min before their Acronis time.

Any suggestions for what the task should do to wake up a notebook and keep it awake for a while?

Thanks, Terry

 

 

Forum Hero
Posts: 67
Comments: 7990

Thanks for the update Terry.  On my system, I have the opposite problem at times.  I put my computer to sleep and it wakes up shortly afterwards even though nothing is scheduled to wake up the system and nothing has physcially been touched (mouse/keyboard).  I run the following command to determine what woke up the system:

powercfg -lastwake

and it shows that Acronis scheduler service woke up the system even though no backups are scheduled for a few hours.  This does not always occur though, and usually, after rebooting, it behaves normally again.  

In your case, you can try this:

https://support.microsoft.com/en-us/kb/929463

make the task reference a batch file that kicks off your backup task: 

for example: http://www.wilderssecurity.com/threads/trigger-acronis-backup-task-by-command-line.152309/

Alternatively, perhaps just try removing and re-installing ATIH using the ATIH 2015/2016 cleanup tool (running by right clicking and "run as administrator".  After cleanup, try a fresh install by downloading the most recent version from your account and installing by right clicking and "run as administrator".  You will need to create new backup tasks if you go this route, but hopefully it will clear up the issues. 

Beginner
Posts: 1
Comments: 8

Hi Bobbo

I set up a task to wake up the notebook 5 min before the Acronis scheduled time. I'll report what happens tomorrow.

Thanks again.

Beginner
Posts: 1
Comments: 8

Well it worked. I set up a scheduled task to run a batch file. The batch file appends a time stamp to a log file then has the timeout /t 360 to stay awake for at least 6 minutes. The backup to place rignt on schedule. There are a lot of check boxes in the task schedular that must be set correctly but the settings are pretty obvious.

Bobbo, thanks for all your suggestions. I have some other questions but I'll start a new thread on them.

Forum Hero
Posts: 67
Comments: 7990

Awesome.  Glad you got it to work.  Defintely a work-a-round, but at least it helps in your situation.