Skip to main content

'backup terminated by user' (not)

Thread needs solution
Forum Member
Posts: 9
Comments: 20

I just had two incremental backups that were 'terminated by user' but were not. Here is the log of the session of the second attempt. The backup jobs included automatic validation. It looks like the incremental backup succeeded, but the validate failed due to not being possible in 'quiet mode' . What is quiet mode and how does it come about.

This run created X - 09.25.2019_inc_b1_s3_v1.tib, the previous logged looked the same but created _s2_

10/5/2019 10:38:48 AM: Backup reserve copy attributes: format tib; need_reserve_backup_copy false;
10/5/2019 10:38:48 AM: Operation X - 09.25.2019 started manually.
10/5/2019 10:38:51 AM: Backup reserve copy attributes: format tib; need_reserve_backup_copy false;
10/5/2019 10:38:51 AM: Operation: Backup
10/5/2019 10:38:51 AM: Priority changed to Low.
10/5/2019 10:38:51 AM: Create Backup Archive From: Disk 1, Disk 3 To file: X:\X - 09.25.2019.tib Compression: Normal Exclude: Files matching mask Match criterion: hiberfil.sys, pagefile.sys, $Recycle.Bin, swapfile.sys, System Volume Information, *.tib, *.tib.metadata, *.~, *.tmp, C:\Users\JoeAdmin8700\AppData\Local\Temp, C:\Users\Joeuser8700\AppData\Local\Temp, C:\Users\JoeAdmin8700\AppData\Local\Microsoft\Windows\INetCache, C:\Users\Joeuser8700\AppData\Local\Microsoft\Windows\INetCache, C:\Users\JoeAdmin8700\AppData\Local\Google\Chrome\User Data\Default\Cache, C:\Users\JoeAdmin8700\AppData\Local\Opera Software, C:\Users\JoeAdmin8700\AppData\Local\Mozilla\Firefox\Profiles, C:\Users\JoeAdmin8700\AppData\Local\Google\Chrome\User Data\Default\Cache, C:\Users\JoeAdmin8700\AppData\Local\Opera Software, C:\Users\JoeAdmin8700\AppData\Local\Mozilla\Firefox\Profiles, C:\WINDOWS\CSC
10/5/2019 10:38:53 AM: Pending operation 172 started: 'Creating partition image'.
10/5/2019 10:39:19 AM: Pending operation 172 started: 'Creating partition image'.
10/5/2019 10:40:15 AM: Writing incremental version to file: X - 09.25.2019_inc_b1_s3_v1.tib
10/5/2019 10:40:37 AM: Pending operation 172 started: 'Creating partition image'.
10/5/2019 10:41:04 AM: Pending operation 172 started: 'Creating partition image'.
10/5/2019 10:41:46 AM: Pending operation 172 started: 'Creating partition image'.
10/5/2019 10:41:46 AM: Pending operation 172 started: 'Creating partition image'.
10/5/2019 10:41:46 AM: The following backups have been successfully created: X:\X - 09.25.2019_inc_b1_s3_v1.tib
10/5/2019 10:41:46 AM: Validate Backup Archive Location: X:\X - 09.25.2019_inc_b1_s3_v1.tib
10/5/2019 10:41:47 AM: Pending operation 4 started: 'Validate Backup Archive'.
10/5/2019 11:02:51 AM: Error 0x4000b: The drive is not ready.
10/5/2019 11:02:51 AM: Cannot perform this operation in quiet mode. (0x103F1)
$module = "ti_demon_vs_8058"
TrueImage::Archive::ArchiveMsgReadCallbackProcessor::ProcessReadCallback:
k:\8058\products\imager\archive\impl\operations\archive_message_callback.cpp(987)
The drive is not ready. (0x4000B)
$module = "ti_demon_vs_8058"
TrueImage::Archive::ArchiveMsgReadCallbackProcessor::ProcessReadCallback:
k:\8058\products\imager\archive\impl\operations\archive_message_callback.cpp(988)
10/5/2019 11:02:51 AM: Terminated by user.

Start: 10/5/2019 10:38:48 AM
Stop: 10/5/2019 11:02:51 AM
Total Time: 00:24:03

0 Users found this helpful
Legend
Posts: 106
Comments: 26782

Joe, your log shows that the backup operation was successful, but that a problem occurred when the task was trying to do a validation of the new backup .tib file.

10/5/2019 10:41:46 AM: Validate Backup Archive Location: X:\X - 09.25.2019_inc_b1_s3_v1.tib
10/5/2019 10:41:47 AM: Pending operation 4 started: 'Validate Backup Archive'.
10/5/2019 11:02:51 AM: Error 0x4000b: The drive is not ready.
10/5/2019 11:02:51 AM: Cannot perform this operation in quiet mode. (0x103F1)

What is your backup drive X: and how is it connected to your computer?

Forum Member
Posts: 9
Comments: 20

The X: drive is a WD 2gb blue 3.5" HD connected via an external SATA to usb3 device.   I have been using this seup for about a year now and this is the first time I have experienced this. 

I did a reboot of the computer and am now doing a validation of the backup on the disk.  So far it seems to be working.

When ATI does a validation of a backup with a full , and multiple incremental versions, does it validate all the way back through the original full version file?

Legend
Posts: 106
Comments: 26782

When ATI does a validation of a backup with a full , and multiple incremental versions, does it validate all the way back through the original full version file?

Yes!  Validation of a single file would be pretty meaningless if other files in the same chain were broken for any reason.

Forum Member
Posts: 9
Comments: 20

This is still happening.   What is quiet mode?

 

10/21/2019 8:43:17 PM: Backup reserve copy attributes: format tib; need_reserve_backup_copy false;
10/21/2019 8:43:17 PM: Operation X - 09.25.2019 started manually.
10/21/2019 8:43:19 PM: Backup reserve copy attributes: format tib; need_reserve_backup_copy false;
10/21/2019 8:43:19 PM: Operation: Backup
10/21/2019 8:43:19 PM: Priority changed to Low.
10/21/2019 8:43:19 PM: Create Backup Archive From: Disk 1, Disk 3 To file: X:\X - 09.25.2019.tib Compression: Normal Exclude: Files matching mask Match criterion: hiberfil.sys, pagefile.sys, $Recycle.Bin, swapfile.sys, System Volume Information, *.tib, *.tib.metadata, *.~, *.tmp, C:\Users\JoeAdmin8700\AppData\Local\Temp, C:\Users\Joeuser8700\AppData\Local\Temp, C:\Users\JoeAdmin8700\AppData\Local\Microsoft\Windows\INetCache, C:\Users\Joeuser8700\AppData\Local\Microsoft\Windows\INetCache, C:\Users\JoeAdmin8700\AppData\Local\Google\Chrome\User Data\Default\Cache, C:\Users\JoeAdmin8700\AppData\Local\Opera Software, C:\Users\JoeAdmin8700\AppData\Local\Mozilla\Firefox\Profiles, C:\Users\JoeAdmin8700\AppData\Local\Google\Chrome\User Data\Default\Cache, C:\Users\JoeAdmin8700\AppData\Local\Opera Software, C:\Users\JoeAdmin8700\AppData\Local\Mozilla\Firefox\Profiles, C:\WINDOWS\CSC
10/21/2019 8:43:21 PM: Pending operation 172 started: 'Creating partition image'.
10/21/2019 8:43:50 PM: Pending operation 172 started: 'Creating partition image'.
10/21/2019 8:44:50 PM: Writing incremental version to file: X - 09.25.2019_inc_b1_s4_v1.tib
10/21/2019 8:47:21 PM: Pending operation 172 started: 'Creating partition image'.
10/21/2019 8:47:47 PM: Pending operation 172 started: 'Creating partition image'.
10/21/2019 8:56:02 PM: Pending operation 172 started: 'Creating partition image'.
10/21/2019 8:56:02 PM: Pending operation 172 started: 'Creating partition image'.
10/21/2019 8:56:02 PM: The following backups have been successfully created: X:\X - 09.25.2019_inc_b1_s4_v1.tib
10/21/2019 8:56:03 PM: Validate Backup Archive Location: X:\X - 09.25.2019_inc_b1_s4_v1.tib
10/21/2019 8:56:03 PM: Pending operation 4 started: 'Validate Backup Archive'.
10/21/2019 8:58:54 PM: Error 0x40001: Error occurred while reading the file.
10/21/2019 8:58:54 PM: Cannot perform this operation in quiet mode. (0x103F1)
$module = "ti_demon_vs_8058"
TrueImage::Archive::ArchiveMsgReadCallbackProcessor::ProcessReadCallback:
k:\8058\products\imager\archive\impl\operations\archive_message_callback.cpp(987)
Error occurred while reading the file. (0x40001)
$module = "ti_demon_vs_8058"
TrueImage::Archive::ArchiveMsgReadCallbackProcessor::ProcessReadCallback:
k:\8058\products\imager\archive\impl\operations\archive_message_callback.cpp(988)
10/21/2019 8:58:56 PM: Terminated by user.

Start: 10/21/2019 8:43:17 PM
Stop: 10/21/2019 8:58:56 PM
Total Time: 00:15:39

Legend
Posts: 106
Comments: 26782

Joe, quiet / silent mode is normally as per the image below (from Options > Advanced > Error handling settings:

Forum Member
Posts: 9
Comments: 20

So if my error handling options look like that I'm in 'quiet mode' ?    Doesn't seem to make sense.   My backups all use that same option and they don't always fail,  but they are failing frequently and always when validating.

Legend
Posts: 106
Comments: 26782

Joe, no - if the top option is not selected then you should not be in quiet mode.  Quiet mode / silent mode would be if that top error handling option is ticked.

There have been various problems with validating when doing this immediately after a backup using the Advanced option for the backup task.  I do not use that option myself and just perform a validation as / when I deem one to be needed.

Just to clarify here, quiet / silent mode means that the user doen't get interrupted when an error occurs and ATI continues / takes an appropriate action automatically rather than waiting for the user to choose what to do. In your case, ATI is terminating the backup task.

Forum Member
Posts: 9
Comments: 20

Still getting "Terminated by user" when trying to do validations.  Last two attempts were made as a separate process, not during the backup task.  I'm doing these backups and validations on a drive placed in an external usb3 drive bay.  Does ATI not work with this kind of hardware?

 

11/13/2019 1:24:27 PM: Operation Backup validation started manually.
11/13/2019 1:24:29 PM: Priority changed to Low.
11/13/2019 1:24:29 PM: Validate Backup Archive Location: X:\X - 09.25.2019_inc_b1_s5_v1.tib
11/13/2019 1:24:29 PM: Pending operation 4 started: 'Validate Backup Archive'.
11/13/2019 1:45:33 PM: Error 0x4000b: The drive is not ready.
11/13/2019 1:45:33 PM: Cannot perform this operation in quiet mode. (0x103F1)
$module = "ti_demon_vs_8058"
TrueImage::Archive::ArchiveMsgReadCallbackProcessor::ProcessReadCallback:
k:\8058\products\imager\archive\impl\operations\archive_message_callback.cpp(987)
The drive is not ready. (0x4000B)
$module = "ti_demon_vs_8058"
TrueImage::Archive::ArchiveMsgReadCallbackProcessor::ProcessReadCallback:
k:\8058\products\imager\archive\impl\operations\archive_message_callback.cpp(988)
11/13/2019 1:45:33 PM: Terminated by user.

Start: 11/13/2019 1:24:27 PM
Stop: 11/13/2019 1:45:33 PM
Total Time: 00:21:06

Legend
Posts: 106
Comments: 26782

Joe, it is possible that your external USB 3 drive bay is playing a role here but the only real way of testing this is to be able to connect the same drive using a different method.

You could try the type of adapter shown below from Amazon.

StarTech.com USB312SAT3 USB to SATA Adapter Cable, 2.5 Inch and 3.5 Inch Drives, USB 3.1, 10 Gbps, External Hard Drive Cable, Hard Drive Adapter Cable

I have used the 2.5" version of this type of adapter; StarTech.com USB312SAT3CB USB 3.1 to 2.5 Inch SATA Hard Drive Adapter, USB 3.1 Gen 2 10 Gbps with UASP External HDD/SSD Storage Converter - but this cannot be used for 3.5" SATA drives.

Forum Member
Posts: 9
Comments: 20

Sata to usb3 adapters are what I have been using,  the method I used to use (and had no trouble with)  was swappable sata bays.  I'm going to have to try that again.