Skip to main content

Install process has permissions issues

Thread solved
Posts: 1
Comments: 1

I have a 3-machine license for True Image 2017 and am trying to install it on a new laptop but the installer program aborts with this message: "Windows cannot access the specified device, path or file. You may not have the appropriate permissions to access the item."  There is a reference to a file within the C:\Users\*******\App Data\Local\Temp folder, and so I've used Windows Explorer to find that Temp subdirectory, right-clicked and granted access permissions to "Everyone", then closed, rebooted and tried the installation again -- no joy.

If anyone has insight or thoughts on how to resolve this particular issue so I can get the installation completed successfully and start backing up this laptop, I'll very much appreciate it.

0 Users found this helpful
Posts: 103
Comments: 24107

James, welcome to these public User Forums.

Please see KB 46710: Acronis True Image: Installation Fails in Windows - which should cover most of the common issues encountered in this area.

Note: ensure you are installing from an Administrator user account.

Forum Hero
Posts: 70
Comments: 8343


Others in the forum have had issues with improperly extracted software packages prevented the install.  %temp% is where these are extracted...

Go in to that folder and delete everything from temp and reboot.

Then, when you log in, make sure it's with an admin account and the one you want to use - I believe the installer works better if you are actually logged in with the account being used.  Even so, still run the installer with right click and "run as administrator" even if logged in with the admin account to ensure it has the highest admin privileges for that admin account.

Posts: 1
Comments: 1

Many thanks for the suggestions, which might have proven helpful in tracking down the culprit of the misbehavior if I had remembered to toggle the box for notifications of new replies to my original message.  Unfortunately I didn't, and haven't seen them until just now when I came back to report success in overcoming the issue and describe the source of the problem that was simple to resolve.

I had become frustrated with the various "help" offerings through MS or most of the other sites which were identified in searches on the original error message, and life intervened in the form of chores and weather to distract me until this morning.  A new update for Skype wouldn't install in a similar manner, but presented a different style and form of error message ("Access is denied" and referencing "error 5")  -- searching on that brought up many of the same threads and posts as earlier, but there was one reference to the MS KB article linked below, and that revealed the problem lay somewhere in the permissions for vital folders being "read-only" and the installation process requires writing to such a folder.  The solution is to select the critical TEMP folders and toggle the top folder's properties "read-only" feature on and off, choosing the option to apply the action to all files and folders below; one may be under the root drive C:\ and the other under the relevant Windows\USERS\***\AppData\Local\Temp path.…

After I took that action for both folder lines and rebooted, I re-attempted the Skype update; it ran through fine, so I launched the TrueImage installation again and it ran through to completion.  Once I got the product activated and an initial backup performed, I came here to report on the resolution.