Skip to main content

Acronis True Image will not backup incrementally anymore

Thread needs solution
Beginner
Posts: 1
Comments: 0

I bought a new Windows 10 computer 2 months ago. Since then I've not been able to do a single incremental backup. After first ensuring I've selected the folder that contains the last full backup, I have repeatedly gone to options where I select incremental backup scheme and incremental backup method (as I've always done in the past). Acronis still tries to do a full backup, estimating it will take 14 hours (or longer) to complete!! When I tried to do an incremental b/u last wk, I finally gave up ("Fine, force a full back up on me then) and let it run all night long. It should have finished around 7am; instead it failed at some point during the night, so it went all that time with no backup at all. What is suddenly going on with full backups taking ridiculously long and then not allowing incremental backups?! My previous Windows 10 computer NEVER took this long to do a full back up - maybe an hour or two max. And the incremental backups worked like a quick charm in between. At this rate Acronis TrueImage (which I've been using for over 15 years) is time-consumingly useless to me. On top of that "my account" does not show my most current version of Acronis TrueImage 2018. When I seleted "Add key" and then tried to copy the product key from this latest product, it returned an error message of "serial number already registered" - but then it's not appearing!

0 Users found this helpful
Legend
Posts: 81
Comments: 17993

#1

Leslie, welcome to these public User Forums.

Please download the MVP Log Viewer tool (link in my signature below) and use this to review the log file for your backup operation. This should provide more information on why you are seeing problems with your backup tasks.

With regards to your registered license keys, you will need to contact Acronis directly to resolve any issues there as we are users the same as yourself.

Forum Moderator
Posts: 123
Comments: 4704

#2

On top of that "my account" does not show my most current version of Acronis TrueImage 2018. When I seleted "Add key" and then tried to copy the product key from this latest product, it returned an error message of "serial number already registered" - but then it's not appearing!

Leslie, if the issue still persists, send my the key in a private message (first two blocks -16 digits - are enough) and I'll check, where the key is registered