Skip to main content

Restore not booting, tried bootrec /FixBoot got "access is denied"

Thread needs solution
Beginner
Posts: 10
Comments: 9

Seems every new release of Acronis (or more likely win10 update) there is a problem restoring.

I have old Dell 435mt with legacy bios and I put its hard drive in a USB adapter and made a backup few weeks ago.  Backup shows 3 items:  Windows "g", and two recovery partitions as shown in ac1

Original disk was 256gb, new one was 1TB.   I used acronis to load the TIB archive and restore to new 1TB drive but I see there is a 4th item as shown in ac2.  My guess is that is not supposed to be there.

I take the drive over to that dell system and try to boot.  Does not boot.  I boot win10 recovery tools "bootrec /fixmbr" runs ok.  bootrec /FixBoot fails "access is denied".  Googleing I read this https://answers.microsoft.com/en-us/windows/forum/windows_10-performanc… and try it but does not work either.

I have supposidly valid TIB file on my file server.  How do I get its image onto the new drive so that it boots on that old computer?

 

BTW, i have misspelled words.  When I highlight them (to correct) all I see is cut , paste, etc.  Your speller has a problem, it even thinks that Acronis is misspelled.

Attachment Size
ac2.png 11.3 KB
ac1.png 27.24 KB
0 Users found this helpful
Legend
Posts: 109
Comments: 28196

Joseph, your screen images show the issue with booting!  Your source disk drive is Legacy / MBR but your new disk drive shows that you have a EFI System 100MB partition and thus has been converted from MBR to GPT because the restore was done on a UEFI boot system.

Beginner
Posts: 10
Comments: 9

Yes, restore was done on a UEFI system.  I keep Acronis on my best system (I do have a site license though) and back up my kids computers and other systems to a sysology server.  I cannot imagine changing a disk to something different than what it was for a restore.  I can imagine putting a GPT on an MBR as a feature but in this case it is clearly a bug.  Seems like changing MBR to GPT is something the Disk Director would be used to for, not True Image.

 I ended up doing a clean install of win10 and activating using the digital license on file at my microsoft account.  The backup was made a the time win10 was installed so nothing would have been gained over the clean install.

1.  In the future, from my file server, how do I make a disk restore and get a true image of the original disk to be restored?

2.  Seems to me this should have worked since win10 can boot from a GPT even if the bios is not UEFI.  Why didnt this work?

Legend
Posts: 109
Comments: 28196

Joseph, sorry but this is not a bug but is the defined behaviour for ATI in observing the BIOS boot mode of the system when any restore/recovery or clone is done, as documented in the ATI User Guide under the section for Migration Method.

There should be an option during the restore or recovery where you are advised that the recovered / restored drive will be in GPT format and giving an option to change this, but this may only be shown when doing a manual restore, not with automatic settings.

Windows cannot boot a GPT drive when the BIOS is set to Legacy only, GPT requires UEFI.

The other option here is to boot the original source system using the Acronis Rescue Media to perform any recovery, where the boot mode of that system would determine whether MBR or GPT is used.

 

Forum Hero
Posts: 70
Comments: 8346

Joseph this is an issue from Microsoft and bios booting.  As an example...

If you have an existing Legacy MBR disk that the OS is installed on, but you want to upgrade the OS using (let's say from Win 7 to Win10 as an example) and migrate to GPT, you would need to boot the installer in UEFI Mode.  Likewise, if you have an MBR formatted disk (let's say a new one) and plan to install Windows in UEFI mode or want to migrate to GPT, the Windows installer (when booted in UEFI mode) will tell you that there is no disk to install on! If the disk is different than the way the installer was booted, you either have to go back and reboot the Windows installer the other way to match the existing drive layout, or you have to format the disk to match the way the installer is currently booted.

Basically, modern bios and Windows installers, require that you boot your rescue media (Acronis Rescue media or Windows installer) to match the OS install.  

In the case of a Windows installer, it will just say that there is no compatible disc when it asks you to select an install location if you have booted the installer differently than the disk is formatted.

In the case of Acronis rescue media, it doesn't choke there, but will continue the restore in the mode the rescue media was booted.  Rule of thumb... if your OS is legacy/MBR, boot the rescue media as legacy/MBR.  Or if the OS is UEFI/GPT, then boot the rescue media as UEFI/GPT.  This will ensure an exact recovery without any conversion.

In some cases, users can (and/or want) to convert from Legacy MBR to UEFI / GPT.  Acronis can do this and the system will remain bootable... if 1) the bios is configured correctly to use UEFI/GPT as the primary boot function, 2) the bios default boot option still points to the new drive as the primary boot and hasn't changed to something else like the CD/DVD rom by default.

In your case, you should still be able to go back and restore the image, but make sure you are booting the rescue media in legacy mode.  The best way to be sure is to use your bios one time boot menu and specifically pick legacy or UEFI mode.  It is different on every bios, but you can see an example of what a Dell might look like for reference.  

I've noted several pictures of one system bios in this thread

https://forum.acronis.com/forum/acronis-true-image-2016-forum/rescue-media-fails-boot#comment-378318

and this is a specific one time boot menu on a Dell where you can clearly see that it offers a legacy and a UEFI boot option for the same USB drive.

https://forum.acronis.com/sites/default/files/comment_attachments/2016/07/378318-132040.jpg

Legend
Posts: 109
Comments: 28196

Last update only 3 years out of date!