Skip to main content

USB Boot Media WIll Not Boot

Beginner
Posts: 3
Comments: 11

Is there a problem with USB boot media?

Tried Linux and WinPE and both fail to boot in two different laptops.

Tried two different USB sticks.

 

WinPE  - Just hangs at a flashing cursor in top left of screen

Linux - complains of unrecognised boot device.

 

Thanks :)

Forum Hero
Posts: 29
Comments: 5668
mvp

Top

This can be caused by Secure Boot enabling in UEFI booted systems.  Are your laptops UEFI ?  Are you running Windows 8 or 10 ? 

If your laptops are UEFI booted and you are running Win 8 or above you can attempt boot from within the Windows environment by doing the following:

With USB stick attached, click the Start button, then click the Power button, then hold down the Shift key and click on Restart.  Wait while Windows loads Advanced UEFI startup options and displays your choices on screen.

When those options appear choose Boot from USB device which will show other options then select the entry that contains UEFI in the device name for your USB stick.

Beginner
Posts: 3
Comments: 11

Top

Scrap this. It seems there was a problem with both the USB sticks I tried (both 2GB which shows their age).

Bought a new 16GB drive and it booted just fine :)

Forum Star
Posts: 82
Comments: 1520
mvp

Top

Excellent news. Getting a USB stick to boot can be problematic, particularly if they are older ones that have been used for other purposes. In some case reformatting them solves the problem, but in other you need to resort to utilities that format USB sticks.

Ian