Skip to main content

Acronis Cloud backup long cleanup times

Thread solved
Legend
Posts: 98
Comments: 21080

Is anyone else seeing long cleanup times for backups going to the Acronis Cloud?

As shown by the screen image below (for a disk & partitions backup) my cleanup times are taking around an hour after the backup is completed successfully, which seem excessive and also stops any further backups from being processed while this cloud cleanup activity is being actioned!

2018-12-08 Cloud Cleanup delay.png

Note: the cleanup times for my files & folders backups to the Acronis Cloud are almost instantaneous in terms of the time taken!

2018-12-08 Cloud Cleanup delay 2.png

2 Users found this helpful
Legend
Posts: 98
Comments: 21080

#1

Cross reference to topic: cleaning up ... less than 1 minute

Legend
Posts: 98
Comments: 21080

#2

Support ticket submitted by email for this issue - ticket number not yet advised / to be added later.

Forum Star
Posts: 164
Comments: 3544

#3

Backups to Au1 are taking about 20-30 minutes to do clean-up. Looked at 3 different backup tasks. Could be server configuration issue or related to demand on server resources being greater for the server you are using Steve.

Ian

Legend
Posts: 98
Comments: 21080

#4

Thanks for your update Ian, my thinking here is that this Cloud based cleanup shouldn't need to hold up other Acronis tasks that might be queued given it is happening at the remote server end.

Forum Star
Posts: 164
Comments: 3544

#5

Valid point Steve. It may require an update to the way global email settings are configured by adding a category for cleanup of Cloud backups. A failure could indicate a more serious problem.

Legend
Posts: 98
Comments: 21080

#6

Ian, given that ATI is signed in to my Acronis account for the Cloud backup, then it could still release the local task to run other backups and return later to update the status of the Cloud cleanup process.  ATI already queries the Cloud for all such tasks on startup before giving a tick mark to show all was successful last time!

Beginner
Posts: 0
Comments: 2

#7

FYI...Seeing this issue with my Cloud backups cleanup dragging on also... starting with the Nov 27/28 late night backup. 'Data Centre' of backups is 'United States'.

Legend
Posts: 98
Comments: 21080

#8

Cliff, my Support Ticket 03544640 with Acronis is still open for this issue, where the last update I received was back on 17th December as below:

I have analyzed your logs and see that the issue needs deeper investigation from our development. I have escalated your case to our development. Normal processing time of cases in development department is three - four weeks. I have notified the developers that the issue is urgent and hope that I will get any information during next week but unfortunately I cannot promise you for sure that it will take place. I will surely come back to you with update to this case during next four weeks.

If this issue is a concern for you, then I would encourage you to open your own Support Ticket and quote my ticket 03544640 plus reference this forum topic:

Forum Member
Posts: 3
Comments: 23

#9
I have this same issue ever since (it seems) the last ATI19 update, starting in December, 2018.
I have a support ticket and have provided reports, etc.  Also have numerous emails with support.
System reports were created by ATI tech support via remote access to my PC.
ATI support is very responsive, but thus far, support has been unable to determine the problem.
I have also tried "Repair," uninstall and reinstall, to no avail.
I have the same problem on two identical Dell PC's (Win10).  One might think that part
of the problem may be our slow internet upload speed (1.8Mbps) but this has never been a problem in the past.
One PC is 550gb and cloud backup time is about 5-6 hours.  No problem, but cleaning up time is about 4 hours
after upload is completed.

Also, I have asked why does not the server disconnect from and release my PC and the server
can do its "cleaning up" without needing my PC.  Today, the reply was:

"It is the design behavior. Acronis has to update the information under Database/ Scripts.
If the server disconnects from the application then Acronis will not be able to run the next backup."
Legend
Posts: 98
Comments: 21080

#10

usgroupie, thanks for sharing your update on this issue.

My last update on my Support Case was as below (and totally unacceptable to me!).

I have checked the status of your case today and see that with the help of provided logs the developers were able to find out that we may have issues with file level backup performance. The developers are still investigating the logs and are still searching for the root cause and plan to fix the issue in the version 2020. We want to thank you for your great help and your cooperation. As for now we suggest you creating only disk level backups as the file level backups may be a bit slower than expected. As the fix will be available starting from the next version we offer archiving the support case till that moment.

Please let me know whether the situation is clear for you now and whether we can put the case into archive.

My response to the above feedback was:

This support case was raised for the long cleanup times for my Disk & Partitions backup to the Acronis Cloud - I have not seen this problem with my File level backup to the Cloud.

The most recent Disk level Cloud backup took 1 hour and 10 minutes to perform a cleanup on 2nd February as shown in the screen image.

Sorry but I do not agree to this case being archived given the above.

I have this issue on at least 2 different computers running ATI 2019 and making Disk backups to the Acronis Cloud, where the delay time for cleanup seems to get longer as the task has run for an extended period.

Forum Member
Posts: 3
Comments: 23

#11

Thank you Steve!  I too have advised support to not mark the case as resolved and to keep it open.  It is interesting that your support person indicated that the developers are still searching for the cause in your logs (and mine?) and it will be fixed with the next 2020 version LOL.  Out of their 1000's of customers, it appears that only you and I (and perhaps a few others?) have this problem.  I remain optomistic that they will find the problem prior to 2020 and there will be an update.  I still suspect the problem was created by some rogue program line inserted in their last update LOL.  I will continue to use the Cloud backup daily, as it is needed for offsite storage, even though it is redundant to my two external hard drives for local backups every 6 hours and once at night.  We live out in the sticks and have CenturyLink with upload speed of 1.8Mbps which is the fastest we can get.  A couple of miles from here CL speed is 1Gbps.

Forum Member
Posts: 3
Comments: 23

#12

Just received the following:

Hello Scott, 

Thank you for your email.

I certainly understand the issue is not resolved and its a known issue.

The issue is been reported to the team concern by the Expert Advisor who was working on the prior case 03554191 and for now we do not have an ETA  for the fix.We suggest to put the current ticket into archive and notify you once we have a fix available.

Looking forward for your response.
Legend
Posts: 98
Comments: 21080

#13

Interesting that they reference working on a prior case # 03554191 for this issue, so there are at least 3 different cases open for this problem.  Mine is # 03544640 opened back on 13/12/2018.

Forum Member
Posts: 3
Comments: 23

#14
This will explain it ...

My first case was made on Dec. 12 ... 03554191

Then on Feb. 6 they gave me another one ... 03671400
Legend
Posts: 98
Comments: 21080

#15

Good to know! Thanks.

Beginner
Posts: 0
Comments: 1

#16

I have had this same issue for a while. Pleas epost if you get a resolution.

Legend
Posts: 98
Comments: 21080

#17

James, welcome to these public User Forums.

All has been quiet on my own Support Case for this issue since my update on 02/18/2019 but I will post if I get any updates on this.  My Cloud backups (Disk & Partitions) are typically taking around 1.5 hours to do the cleanup after the backup has finished!

Forum Member
Posts: 3
Comments: 23

#18

Steve & James:

Update ...

Today, Wednesday, 02/27/2019
I am attaching a screenshot of Backup & Activity from this morning showing successful Cloud backup completed at 08:12 a.m. (started at 1:00 a.m.).  The Cleaning Up completed at 11:09.  Again, I have 500+GB and 2-4MBps upload (slow), but it does the job.

Prior to this, on Monday & Tuesday, the following are my most recent emails to Acronis as followup:

Monday 02/25/2019 01:47 p.m. (response from Acronis request to update):
Okay, I'll try to make this short.  Last Thursday & Friday, during backups to two external hard drives, Acronis stopped (was interrupted) with a popup message that there was a failure to read from a sector on the internal hard drive (backup source).  I clicked ignore and the backups continued.  I then validated the external HD backups and no issues.

I then noted on Friday that Cloud had not backed up since Tuesday, Feb. 19.  On Friday afternoon, I ran Acronis Cloud and it "Failed to enumerate directory C:/Windows/InfusedApps/Packages."

Over the weekend I spent hours troubleshooting the sector errors and the directory error, suspecting that my hard drive was beginning to fail.  I ran numerous tests (sfc /scannow, dism /online /cleanup-image /restorehealth, chkdsk /f) to detect, repair, etc. including Western Digital scanning.  Nothing seemed to be working to fix those issues.  Also did another Acronis repair.

So, I ran a major chkdsk /f /r /x which took several hours, and it appeared to have fixed the hard drive sector problem.  Acronis desktop backups to external HD's is no longer producing any sector errors.

I ran Acronis Cloud yesterday mid-morning and it completed at 2:19 p.m. and Clean Up completed at 6:10 p.m. (almost 4 hours), and it did not have a directory failure error.

However, Acronis Cloud ran a scheduled backup at 1:00 a.m. this morning and completed at 5:24 a.m.  The Activity Report does not show that there was a Clean Up!!!  So, I will let it run again tomorrow at 1:00 a.m. and catch it prior to 6:00 a.m. to check activity and confirm that it is not cleaning up after the cloud backup.  I will let you know tomorrow morning (Tuesday).

Scott

Tuesday 02/26/2019 08:56 a.m. (Update to my Monday response)
Update - this morning's Cloud Backup completed successfully but there was a 3 hr. Cleaning Up period that I witnessed.  The Cleaning Up did not register / log on the Activity.  Attached is a screenshot of the Activity tab.  Nothing more I or we can do, so you can close the case I guess.

My note this morning 02/27/2019 07:35 a.m.:  Cloud backup are still experiencing a Cleaning Up

 

Tuesday 02/26/2019 05:17 p.m. - latest response from Acronis ... issue is not closed and they are still working on it.
Hello Scott,

Thank you for your email.

I certainly understand your concern, as mentioned in my previous email the Expert team have forwarded the request to Development team and yet have not received any update. We do not consider this issue to be Resolved but as we do not have any ETA we are  archive the case and we will get back to you with an update on the same once a fix is created for this issue.

 

Attachment Size
490769-164750.jpg 161.57 KB
490769-164753.jpg 209.48 KB
490769-164755.pdf 828.56 KB
Forum Star
Posts: 164
Comments: 3544

#19

I had not been keeping an eye on this so checked just now and clean-up seems to be going well. The time taken could be server specific, I am using the server in Australia. Seems to be taking about 10 minutes. Checked on two different PCs. Example below.

Legend
Posts: 98
Comments: 21080

#20

Ian, are you doing a disk backup to the cloud or files & folders?

I don't have a problem with cleanup for files & folders, only for Disks & Partitions.

Forum Star
Posts: 164
Comments: 3544

#21

Hi Steve, in both cases it was a backup of my system disk; in one case a Samsung 970 EVO NVMe (500gig) and the other a Samsung 850 EVO SATA (260gig). In each case there are multiple partitions (UEFI, OS and Recovery).

So my speculation about it being sever specific may have some substance. Could be demand related or something to do with configuration of individual servers. I will check another PC and see how it is going.

Update: Checked on a third machine, in one task (data partition) under 10 minutes, in the other (system disk 850 EVO SATA) took up to 30 minutes. This system is not booted often, not sure that is relevant.

Ian

Forum Member
Posts: 3
Comments: 23

#22

Thank you for posting Ian.

I note your incremental backup is only 4GB of 113GB total, and at a speed 3x mine.  My incremental cloud backups are 100GB of 550GB+ total HD size, and at a slow upload speed due to constraints of my internet provider (C-Link).  We have copper wire phone lines, not fiber optic.

My observation is that why doesn't the Acronis server release 'control' of my PC while the server completes "its" cleanup in the background?

Been using ATI since 2014, and Cloud since 2016, and never had this issue with the cloud until the last update.

Forum Hero
Posts: 69
Comments: 8317

#23

Good point. My guess would be that it's going back and verifying the checksum of the data against the information on the machine. Purely a wild guess though and would love if it gave back access to the Acronis local console when the backup was done and doing any other under the hood stuff.

Forum Star
Posts: 164
Comments: 3544

#24

@usgroupie

Yes not much happening in the backups being made. I am on HFC (aka cable) with limited upload (100/5 Mbps - but better than the 100/2 I had for many years). Earlier in this thread I reported much longer cleanup times than I am now seeing, so not solely limited to size of backup and size of change made over time.

Steve, is there much being cleaned up on you cloud backup and how large are they - may help in working out the difference (other than the server being use, in my case Au1).

Edit: Something weird going on - the backup speed is given as being between 109 and 133 Mbps. On the third machine I looked at the top was of the same order. On the second one rages between 50 Mbps an Mbps.

Ian

Legend
Posts: 98
Comments: 21080

#25

Ian, my cloud backup is only around 80GB total size but includes my second copy of Windows 10 running an Insiders build where there are regular new builds, as well as my main Windows 10 OS.

This cloud backup has been running at least twice a week since last October and the last 3 cleanup actions have freed just 2.5GB each.

I am using the cloud cleanup settings as below:

Forum Star
Posts: 164
Comments: 3544

#26

Hi Steve, I am using the same settings as you are. No insider builds or dual booting here.

Ian

Beginner
Posts: 0
Comments: 2

#27

Hi, I'm also having this issue with very long waits (hours) for the 'clean up' process to finish...I never encountered this issue before. Would be grateful if anyone finds a fix. I opened a case and they suggested "Go to /Library/Application Support/Acronis/TrueImageHome/OnlineBackup and rename the OnlineBackup folder" This didn't make any difference, nor did reinstalling the whole program...I'm pretty sure the issue started with an update around December, too...Any tips, welcome! thanks

Legend
Posts: 98
Comments: 21080

#28

Peter, welcome to these public User Forums.

There are no actions you can take on your local computer to resolve this cleanup delay issue as far as I am aware (short of deleting the whole cloud backup and starting over again! <not acceptable!>)

Please ask the person looking at your Support Case to look at cases # 03554191 # 03544640 & # 03671400 which has all been opened for this same issue by myself & others posting in this topic, plus refer them to review this forum topic!

Beginner
Posts: 0
Comments: 2

#29

thanks Steve, I'll do that

Forum Member
Posts: 3
Comments: 23

#30

I did provide Acronis with the link to this forum discussion.  BTW, Steve, we have two identical Dell XPS's and the other one has the same issue, except it's HD is 350GB, so upload and clean up time is a little less than mine (mine is 550GB).

Legend
Posts: 98
Comments: 21080

#31

I am seeing this on 2 Dell laptops (different models but similar disk sizes) and the cleanup time is directly related to the size of data in the backup.

Forum Star
Posts: 164
Comments: 3544

#32

My suspicion is that the problem is cause by misconfigured server(s) or the servers do not have sufficient resources to carry out the process. I cannot think of any other reason why Au1 is not exhibiting this problem.

Ian

Legend
Posts: 98
Comments: 21080

#33

Received an update for my support case 03544640 this morning as below:

I have checked the status of the internal ticket and see that the issue should be resolved. Please check out on your system and let me know the results.

I have replied with screen images from 2 different laptops.

Sorry but I am not seeing any change or improvement in cloud cleanup times so far.
See attached image from one laptop which did the most recent backup overnight & yesterday.
My second (main) laptop is due to do the next cloud backup overnight tonight so will check if I see any change there (see second image for current status of cleanup times).

Where has this issue meant to have been resolved?  Is this on the Acronis Cloud servers or is it via a new update to the ATI application?  If the latter, then my laptops are both still on build #14690 per the normal update process.


 

Legend
Posts: 98
Comments: 21080

#34

Still an issue with long cleanup times for Cloud backups of Disks & Partitions.

Legend
Posts: 98
Comments: 21080

#35

Further exchange of emails on my support case for this issue, with Acronis Support trying to say that this issue has been resolved, as per the message received shown below:

The issue was resolved on the server side. Now the cleanup shows correct time.
Previously the cleanup task was sent to the server and the information did not sync up with the client side that is why the activity tab displayed that the cleanup was done in 1-5 sec/minutes because all the activity was done on the server side.
Now the cleanup operation is synced up with the client side and shows the whole progress which is still be done on server side by is synced up with the installed Acronis True Image that is why this is regarded as technically resolved.
The cleanup operation does not give any impact on software productivity and does not affect the PC or backup itself. Please let me know whether the situation is clarified now.

The above still does not reflect my own experience here for my Disk backup to the Cloud and my reply is as below:

Sorry but I do not see any difference here at all and the core issue that I (and other users) was reporting remains exactly the same.
The issue here is that all the time that the cleanup action is running on the server side, no other backup actions can be performed on the client computer.
The ATI backup task still says 'less than 1 minute remaining' but the cleanup action takes much more than 1 hour as shown by the screen images.

I would have no issue with how long Acronis take to run cleanup on the server side if this released the client from waiting so that other actions can be performed instead of being queued up.  This becomes a greater issue as the size of backup data increases.

If all that is required here is to sync the status of the backup task with the client, then there should be no need to lock the client out and prevent other actions - that status should sync whenever the client is active.

What I am seeing is that the Activity page is now showing how long the actual Backup took but is not including the time taken for the Cleanup!

This doesn't match the data I collect myself for this task by using a Pre & Post command to write an entry in a backup log text file for when the backup starts (Pre) and ends (Post) which shows:

05/03/2019  0:29:35.76 Backup started Dell Studio   
05/03/2019  2:46:22.21 Backup finished Dell Studio  

Legend
Posts: 98
Comments: 21080

#36

Ran a further Cloud backup this afternoon with a second local backup task queued behind it to confirm that the second task was still queued while the first Cloud task showed 'Cleaning up .... less than 1 minute' as status.  This was confirmed as the second task sat in queued status for nearly 2 hours while Cloud server cleanup ran!

The entries in my backup log file confirm this:

05/03/2019 13:48:49.97 Backup started Dell Studio   
05/03/2019 16:39:07.11 Backup finished Dell Studio   
05/03/2019 16:39:37.96 Backup started Local  
05/03/2019 17:17:18.21 Backup finished Local

Beginner
Posts: 0
Comments: 1

#37

Running into this exact same problem with both my drive backups. I'll submit a support ticket referring to the #s posted here and see what they say.

Legend
Posts: 98
Comments: 21080

#38

Chris, welcome to these public User Forums.

There has been no update on my own support case since March 6th when the last update received said:

I have forwarded your feedback to the developers and will update you on the case status as soon as I get any news. According to the development team there is no technical issue but may be they can change the design.

The core issue / complaint that I have is not that cleanup is needed, but that it prevents any other local task from running while it happens in the Cloud servers, especially as the backup has been completed nearly 2 hours earlier, where other tasks could have been running.

Thanks for submitting your own support ticket on this issue & referencing the others from this topic.

Forum Member
Posts: 3
Comments: 23

#39

Hi Steve,

As an update from my side, I needed to replace one of my internal HD's.  I no longer have the cleaning up activity.  Go figure.  The other identical PC still does a cleaning up.  Go figure twice.  I am happy to report though, I used the Acronis Recovery to my new HD from an external HD backup, and it worked flawlessly.  Maybe I should replace the other PC internal HD.(?)  The other PC is not as critical as the one I use (it's the wife's LOL).  Just kidding, we both use for our business.

Scott

Legend
Posts: 98
Comments: 21080

#40

Scott, thanks for your update - I have this issue on multiple different computers doing Cloud backups, so am doubtful that it is a local HDD issue, especially as the actual backup portion of the task finishes just fine, then the cleanup of data in the Cloud takes almost as much time again..!

Forum Star
Posts: 164
Comments: 3544

#41

I agree with Steve that it is not likely to be associated with the particular HDD from which the backup is being taken.

Ian

Legend
Posts: 98
Comments: 21080

#42

Latest update received today from Acronis Support:

I have checked the status of your case and see that the developers plan to fix the issue with the next version of Acronis True Image. The next version is expected to be released in the third quarter of this year.

 

Forum Member
Posts: 3
Comments: 23

#43

An admission of guilt?  LOL

Forum Star
Posts: 164
Comments: 3544

#44

Just checked an the last clean-up of one of my cloud backups took about 30 minutes. On another system it is averaging 20 minutes.

Ian

Forum Member
Posts: 13
Comments: 15

#45

Same issue on my side. Happening with a disk image backup to Acronis Cloud (~100GB). Even if only a small amount of data needs to be backed up incrementally (upload is finished within a few minutes), it takes like ~45 minutes more for the cleanup.

For another file and folder cloud backup of ~60GB, the cleanup is finished within seconds.

Good to hear that they will fix this problem!

Legend
Posts: 98
Comments: 21080

#46

Final update on my support case for this issue:

According to the development they plan to fix it with 2020 version directly with the release so I tend to trust and will archive the case. You will surely get an announcement about beta version and will be able to test this whether the issue is resolved or not otherwise you can raise a ticket and we will continue the investigation.

Forum Star
Posts: 164
Comments: 3544

#47

Steve, thanks for posting the update. Not clear to me if the problem is with the ATI code itself or something at the server side. Suspect we will never know where the problem resides.

Ian

Legend
Posts: 98
Comments: 21080

#48

Ian, I suspect that changes may be needed on both sides here, to the ATI app to hand off cleanup to the Cloud, and for the Cloud to manage the same and update the GUI when all is done.  Have to look forward to the next Beta tests to find out more!

CC
Forum Member
Posts: 5
Comments: 28

#49

Steve,

Thanks for dogging this issue, fortunately I won't have to waste even more time trying to figure it out thanks to your excellent detective work.

I have a system of only 24GB and the file backup runs in a few minutes every 2 hours, but the cleanup always hangs with "less than 1 minute" to go and hasn't finished in 2 weeks or more. I guess it is aborted when the next backup starts because there is no indication in the activity log (GUI) of any completions and only an occasional error in consolidation.

The only way I would know is that I have email error reporting set up and get an email every 2 hours. Even the app log shows no errors, just the consolidation starting and then no end timestamp.

I verified that the backups were indeed good and I could recover the oldest of 20 versions of a file.

Thanks again.

Chris

 

Beginner
Posts: 0
Comments: 1

#50

I have the same problem. Any Acronis solution yet?