Skip to main content

Backup file damaged

Thread solved
Posts: 4
Comments: 15

I am writing the backup file on the external USB HDD and after finishing writing, when the program is starting verification of the backup correctness I get the message "The backup copy is damaged. The probable cause is the low quality of media" (see Image1.jpg, unfortunately in Polish).

Still, after pressing "cancel" I see the message "the backup is correct" (see Image2.jpg), but when I try to verify the correctness - I receive again the message "The backup is damaged". I repeated this 3 times with the same result. This concerns 2 partitions, with another one I don't see any problems.

I downloaded and installed the update of the ATI to compilation 17750, but it did not help.

I checked the HDD surface carefully (using the ARDC Hard Disk Checker) and it did not find ANY error.

I used another USB HDD disk, but it did not help either.

Using the ATI for 12 years I never had such a problem.

Can anybody help?

Attachment Size
Image2.jpg 107.21 KB
Image1.jpg 131.06 KB
0 Users found this helpful
Posts: 105
Comments: 25395

Eryk, there are various reasons why this error might be given but first some information.

When ATI creates a backup image file, it also creates within the blocks of that file a series of checksum values calculated from the file data - these are called 'Points in time' checksums.

When the backup task has completed it only knows that the write has been finished and all the checksums have been written to the file during that process, so without performing a validation, it will believe that the backup has finished successfully!

When a validation is performed, ATI reads back the file data and recalculates all the Points in time checksums then compares these with the stored values from the file.  If these all match, then validation is successful.  If any checksum fails to match then the file is considered to be either corrupt or damaged.

It is this latter scenario that looks to be happening for your backup file in your images, that validation is failing because checksums do not match between the stored values and the recalculated value taken from the file data.

This can be caused by a bad USB cable, by a failing memory module, a bad disk or by the use of overclocking of the host computer.

I would recommend trying a different USB backup drive and cable to see if the problem still occurs or not?  If there is no problem, then try changing the USB cable for the original drive if possible, else try a different USB port if available, or even just unplugging / replugging the cable a couple of times.

If you see the same problem with multiple backup drives, then the issue may be with the host computer, i.e. memory etc.