Skip to main content

Failed to read data from disk

Thread needs solution
Regular Poster
Posts: 30
Comments: 177

Get the "failed to read data from disk" on the primary drive. However we've tried the chkdsk /x /f /r  but no issues found so nothing fixed. Removed ATIH v2018, cleaned up and then installed v2019 but got the same error.  Happened to have license for both so gave it a shot. 

The only way I could resolve the issue when I had it was I wiped the drive and started over. My issue was on the backup drive back then however. Any ideas?  Haven't seen this error in years. Helping my sister (who's in another state). 

0 Users found this helpful
Legend
Posts: 73
Comments: 16442

CHKDSK will only work for partitions on your drive which have been allocated a drive letter, i.e. C: but this type of issue can often occur on other hidden / system partitions such as a Recovery partition.

Dedicated diagnostic utilities from the disk manufacturers take the longest time to complete the checks, but provide the most accurate methods of checking whether the disk is good or needs replacement:

 - Western Digital drives: Data Lifeguard Diagnostic for Windows

 - Seagate disks: SeaTools for Windows

 - HGST disks: HGST Windows Drive Fitness Test (WinDFT)

 - Intel SSDs: Intel Solid State Drive Toolbox

 - Samsung drives: Samsung Magician

 - ADATA drives: ADATA SSD ToolBox

 - Kingston SSDs: Kingston SSD Toolbox, Kingston SSD Manager

 - Transcend SSDs: Transcend SSD Scope

 - Silicon Power disks: SP ToolBox

 - Toshiba disks: Toshiba PC Diagnostic Tool Utility

Use one of the above according to the make of your drive giving this issue.

Forum Hero
Posts: 36
Comments: 7024

SBMongoos,

Check out the "Fix Disk Corruption" link in my signature below for an in depth on using the chkdsk utility.  Hope it helps!