Skip to main content

Restore View does hide hidden folders

Thread solved
Forum Star
Posts: 443
Comments: 1832

Dear Acronis Team,

I wish you a happy new year!

is it true that the restore view under Windows will hide hidden folders, perhaps concludent with your view settings in Explorer?

I cannot find c:\users\username\appdata

If I search for the folder that I want to restore it will be shown, however. That is at least a workaround.

Is this limitation a known design decision?

 

Thank you very much! 

0 Users found this helpful
Legend
Posts: 105
Comments: 24801

Karl, as far as I can see this is working as designed in keeping with the Explorer View options.

I have just checked one of my own OS backups and can see all of my C:\Users\[my_name]\AppData folders along with other hidden / system folders, where this is in line with my Explorer view options settings.

There may also be a correlation here with the type of user account being used - I was also using an Administrator group user account for my check.

Forum Hero
Posts: 70
Comments: 8349

Karl,

Alternatively, when I restore files/folders from full disk backups, I double click the .tib file from Windows Explorer (or mount if you prefer, but I usually just open them directly).  From there, it opens up with the settings you have enabled in Windows Explorer so I see "appdata" directly that way since I have hidden files and system files shown by default on my user profile.

I'm guessing what you're seeing in the application is by design as well (same for me when I tried to do it just now).  That way, users won't accidentally restore file system files/folders that are meant to be hidden.

Forum Star
Posts: 443
Comments: 1832

Ok thank you everyone. I can confirm that ATIH will use the Explorer settings. 

Forum Hero
Posts: 70
Comments: 8349

Sweet! Thanks for the confirmation Karl! 

Forum Moderator
Posts: 187
Comments: 6088

Hello Everyone,

just to confirm, currently it's the expected behavior 62120: Acronis True Image: viewing hidden files in program interface

 

Forum Star
Posts: 443
Comments: 1832

Ekaterina, thank you for the article. it is very helpful!

Beginner
Posts: 0
Comments: 1

Hi folks,

It appears the behaviour is not the same for me.

I ran a backup on Win7 witch Acronis 2020 and tried to restore files in c:\User\XXX\AppData folder (wich is hidden) after having upgraded to Win10 (actually, via a clean install).

Hidden folders won't appear in Acronis, I can only find one by search by its name in file restore option.

I activatred "View hidden files" in Explorer and rebooted.

Thanks for you advice ;)

Forum Moderator
Posts: 187
Comments: 6088

T Zorglub wrote:

I ran a backup on Win7 witch Acronis 2020 and tried to restore files in c:\User\XXX\AppData folder (wich is hidden) after having upgraded to Win10 (actually, via a clean install).

Hidden folders won't appear in Acronis, I can only find one by search by its name in file restore option.

I activatred "View hidden files" in Explorer and rebooted.

Hi! Make sure the "Hide protected operating system files" box is unchecked as suggested here https://forum.acronis.com/comment/105746#comment-105746 

Beginner
Posts: 0
Comments: 2

Ekaterina wrote:

Hi! Make sure the "Hide protected operating system files" box is unchecked as suggested here https://forum.acronis.com/comment/105746#comment-105746 

Hi Ekaterina,

question, is this applicable for True Image 2020?

I have followed the above recommendation, I do see hidden folders e.g. AppData in File Explorer, however I don't see such a folder in True Image 2020.

 

Thanks a lot,

Libor

Forum Moderator
Posts: 187
Comments: 6088

Hello Libor,

thank you for your posting! If the files are shown in Windows explorer, they should be visible in the UI of Acronis True Image too. Have you installed the product as Administrator? I'd suggest running a repair installation from the administrative account (right click the installation file and select Run as Admin even if you are already logged in as administrator, this will elevate the additional level of privileges)

Forum Star
Posts: 443
Comments: 1832

I agree with Ekaterina. Enable hidden files in the Explorer ribbon also enable protected system files in Explorer.

then you should are able to see the folders. If you do not have local admin rights, you need to start ATIH elevated with local admin rights. Please let us both know if this helped.

Beginner
Posts: 0
Comments: 2

Ekaterina wrote:

Hello Libor,

thank you for your posting! If the files are shown in Windows explorer, they should be visible in the UI of Acronis True Image too. Have you installed the product as Administrator? I'd suggest running a repair installation from the administrative account (right click the installation file and select Run as Admin even if you are already logged in as administrator, this will elevate the additional level of privileges)

Ekaterina, thanks a lot. The repair installation did the trick. Now I can see and backup e.g. AppData directory.

 

Cheers,

Libor

Forum Star
Posts: 443
Comments: 1832

Hi Libor, great to hear this solved it for you. It is always good to have a feedback on solutions.

Beginner
Posts: 1
Comments: 1

Hi,

I have the same problem.  I selected c:\programdata and other folder (same level from c:\) but I don't see "programdata" folder when trying to restore it because it was hidden.  I've tried to search as suggested by Karl but still don't see it.  Any idea?

 

Paul