Skip to main content

Unable to change backup destination when changing NAS

Beginner
Posts: 3
Comments: 4

Situation: Backups were stored on a Synology NAS that went haywire.

Switched to another NAS (different name and IP).

When trying to change the backup destination of a file and folder backup TI 2019 repeatedly tells me 'Backup destination not available', 'Can't open backup image' etc. pp. Even when trying to take a look at the backup options I receive the very same error messages without a chance to actually change the backup destination.

The procedure does work with partition and drive backup; in this case after the above mentioned error message actually the dialog for choosing a new backup location pops up. It does NOT work in case of a file and folder backup.

The only chance to actually shift to a new backup destination is to delete the backup and create it anew.

??!?

Another annoying point: Even though already connected and even though accessible in Windows Explorer or any other file manager without any problems, the choosen NAS does NOT show up in Acronis backup destination finder; neither in 'Network neighborhood' nor in 'My NAS connections'. For newly defined backups I have to type in the complete NAS backup path manually over and over again.

??!?

Forum Hero
Posts: 34
Comments: 6821

@Therese Telepski

Hi,  To resolve your problem I have 2 suggestions.  They appear below:

  • Select your problem task in the True Image application and click on the Destination location area in the GUI.  This should be shown as your old NAS device.  Since you cannot see your new NAS in the application and you obviously know how to locate it using the address field do that and I believe that once you get the address filled in and hit Enter a Credentials window will appear in which you can enter the new credentials for the new device.  Test the connection once you have entered the credentials to insure that the app can establish a connection.  Once passed click on the connect button.  The credentials window should disappear at this point and you should have successfully modified the backup task to now run to your new device.
  • If that does not work then your next option is to edit the script file of the backup task.  You should make note of the backup task name as you will use it to locate the correct script to edit.  You will use Windows File Explorer and NotePad to edit the script file.  Navigate to C:\ProgramData\Acronis\TrueImageHome\Scripts.  In the scripts folder you will see all the script files that True Image uses for the backup tasks you have defined.
  1. Temporarily turn off Acronis Active Protection prior to performing the steps below
  2. Locate the task script that matches your problem task.  Since you probably have tried my first suggestion the task you want is probably the first one in the list.  I have Date modified in list view enabled in Explorer to help in this regard.
  3. Double click on the script file and it should open in NotePad or prompt you to do so.  Once open, look for the line <display>followed-by-your-task-name.  If the name matches your task then you have the correct script file open.
  4. Next scroll down the file and find the line that reads <volume_locations>.  Looking two lines below that line you will see a line that reads <volume_location partition_id="" password="secure-ID-string" uri="your-device-address/name+your task-name" username="secure-ID-string" volume_id="0" />
  5. Edit the "your-device-address/name....." with the path address/name you use to connect to your device.
  6. Once complete, Save and Exit NotePad.

This should modify the script for the task so that it will run correctly to the new device.

As for why the device does not show up in the application, that is probably related to how your devices Network Discovery method is set.  My guess is that your device uses the NetBIOS discovery method meaning that it has SMB version 1.0 enabled.  If you are running Windows 10 this is an issue as Windows 10 after version 1803 has deprecated that version of SMB  meaning that Network Discovery is effected.

The easiest way to remedy that issue is to first see if you can disable SMB 1.0 on the device in favor of SMB 2.0 or higher.  Next, using Windows File Explorer, map a network drive letter to the share on the new device on which you desire to store backups.  Once you do that the drive letter will become visible in the application allowing you to navigate it.