Skip to main content

suddenly stuck in an endless uncompleted backup loop

Thread solved
Beginner
Posts: 2
Comments: 6

I'm using Acronis True Image 2020, Build 22510, on a Windows 7 Pro 64 system. running fine for months, then a couple days ago out of nowhere -- no changes in settings, or to anything, really -- my daily incremental boot partition backup will no longer complete. I mean, it SEEMS to complete, the program runs normally RIGHT until the end -- but then it just stops with this message: "THE LATEST BACKUP HAS BEEN STOPPED. IT WILL BE RESTARTED AT [time = now] A BACKUP ERROR." And then the backup DOES restart, and it completely rescans the partition again, updating the backup, and when it's done it stops and... that error message appears again; rinse and repeat, ad infinitim (for sure it recycled all night long last night, anyway).

At this point I have tried starting fresh (creating a new initial backup file), and I have tried a repair reinstallation of ATI. Then I did a full uninstall with product IDs and everything. And THEN I did aNOTHer full uninstall using the cleanup tool. But the issue persists: the backup just reaches the end, and then the error message appears and the backup recycles.

When I click STOP and disrupt the eternal backup, I have verified the file that's there, and it verifies every time (green check mark, "the backup is valid.")

When I click RECOVERY, a message says "There are no versions of this backup." Then I click IGNORE, and it says, "DUE TO AN INTERNAL ERROR YOU CAN ONLY RECOVER FILES FROM THIS BACKUP. TO RESOLVE THIS ISSUE, RESTART YOUR COMPUTER AND RECREATE THE BACKUP." The program then seems to try to access the backup data, for hours, but it never seems to succeed in accessing any data at all. (I have restarted my computer and recreated the backup 3 times now, but nothing about any of this ever changes at all. it's been a great evening. ;>{ )

I have tried to create a successful backup on numerous drives at this point, so "destination" does not seem to be a factor.

When I click on the backup file I was using on Tuesday (when this started) it still funcions normally: it opens a fresh windows explorer pane and I can access all of the data from any date going back to the beginning of the file, inCLUDing this Tuesday, when it would not complete. All "new" backup files which I have created since then: when I click on them, they too open a fresh explorer panes, but thos panes reports 0 items (ie, cannot access data).

0 Users found this helpful
Forum Star
Posts: 178
Comments: 3864

#1

Without looking at the logs, I can only speculate what the problem may be. Given the actions you have already taken, I suspect there is a problem the HDD/SSD being backed up. This error could be on one of the hidden partitions on the system drive (assuming they are included in the backup), which means you will not find problems on hidden partitions using utilities that check partitions rather than the HDD.

Most drive manufactures have utilities that can be used to check the integrity of the drive and correct many of the possible problems.

You can view log using the MVP tool that can be downloaded via MVP User Tools and Tutorials. The log files are not a helpful as they are in older versions of ATI but they may give a hint of what is causing the problem.

Ian

Regular Poster
Posts: 4
Comments: 138

#2

Delete

Beginner
Posts: 2
Comments: 6

#3

Ian --

Thank you very much for your input.  Testing your analysis, I tried a 1/2 TB backup NOT involving my C: drive, and that worked fine, so that seems to fit.  The disk (my C:) is just a couple of months old and has consistently seemed fine (till now?  although other than Acronis it STILL seems fine...) -- it's a WD, and I found a WD utility called "Data Lifeguard Diagnostic for Windows."  I also DLed another, independent utility called Crystal Disk Info, but neither of these seems to identify any issues with my disk (unfortunately?) -- jpgs of the respective diagnostic reports are attached -- I don't know what a lot of it means, but the disk does seem to "pass" on all of the metrics they are testing, at least.  (btw, I have also run windows check disk more than once, and that does not identify/correct any file system issues.  I'm also attaching the view of my drive from the windows disk management utility.)

Finally, I'm attaching the contents of 3 log files from today (in 1 txt file):  a) D: file backup success, b) C: disk backup fail, and c) C: disk backup recycle (the beginning, before I stopped it).  Hopefully this will provide some clues, because I don't have any idea how to proceed from here.  ;>{

 

Attachment Size
528060-178866.txt 7.99 KB
528060-178869.jpg 136.41 KB
528060-178871.jpg 565.46 KB
528060-178872.jpg 434.62 KB
Legend
Posts: 100
Comments: 22029

#4

Geoffrey, sorry but the log files do not tell us very much more with just the information in your text file.

Some questions:

Is this a Disks & Partitions backup or a Files & Folders one?
If Disks & Partitions, was this originally created on an earlier version of ATI or on ATI 2020?
What type of backup files are being created, .tib or .tibx?

Please zip up the log files from the following folders covering the period where the backup was working fine and when it started failing.

C:\ProgramData\Acronis\TrueImageHome\Logs\ti_demon
C:\ProgramData\Acronis\TrueImageHome\Logs \backup_worker

(Please do not just add the log files as text attachments to the forum as they lose their original file names, hence why to use zip).

I would also recommend downloading the Acronis VSS Doctor tool and running this on your computer as Administrator as the log indicates a potential snapshot issue, which is the province of the Microsoft VSS service.

Beginner
Posts: 2
Comments: 6

#5

Steve:

The C: backup in question is a disks & partitions backup, and it was created in ATI2020, although my original backup config was wiped out when I reinstalled, so the current settings are from this week.  it creates a .tibx file.

 

>  I would also recommend downloading the Acronis VSS Doctor tool

 

wow.  This tool seem to have gotten at (and FIXED!) the root of my problem -- it found LOTS of issues (like 5 out of 10??), and apparently fixed them all, because I am now able to execute a perfect backup again.  I'm attaching a VSS Doctor report -- you can see what it fixed in the EVENTS LOG section.  I'm also attaching all my zipped logs for good measure -- pre- & post- fail zip files for each directory you mentioned (I had to get the pre- logs from my last successful backup (1/21) because apparently they were wiped out "live" during one of my many re-installs since that time).

 

Anyway, THANK YOU!  for the moment, at least, I am good to go, which feels great (it's been a trying week).  I don't know how whatever happened to my disk HAPPENED, but in any event VSS Doctor seems to be my magic bullet.

Attachment Size
528192-178893.zip 847.91 KB
528192-178896.zip 343.29 KB
528192-178899.zip 237.2 KB
528192-178901.zip 281.69 KB
528192-178902.txt 15.58 KB
Legend
Posts: 100
Comments: 22029

#6

Geoffrey, the VSS log does not show that it fixed any issues unless this is from running it again after it did so?  It does show a potential disk controller problem on one of your drives.

Timestamp: 1/29/2020 3:03:19 PM
Type: Error
Source: Disk
Message: The driver detected a controller error on \Device\Harddisk10\DR10.
InstanceId: -1073479669
SearchLink: https://www.google.com/#newwindow=1&q=Disk+event+id+3221487627

You should follow the google link given and take a look at some of the hits this produces.

Just looking at a couple of the backup_worker logs from today & yesterday shows some issues for your C-WIN7-ALL backup task.

01/29/2020 18:19:50  type=log; level=err;  message=  
ar#1: failed to delete archive path="\\?\D:\Cback\/C-WIN7-ALL.tibx", err=-5022 (File not found);  
 
01/29/2020 18:19:50  type=log; level=err;  message=  
unable to delete archive (err -5022);  
 
01/29/2020 18:19:50  type=retcode; value=5022; id=1580321989;   
01/29/2020 18:19:50  >>> exit   
01/29/2020 18:20:05  >>>  id=1580322005   
action=delete-archive   
agent="Acronis True Image 2020 24.5.1.22510 Win"   
archive="D:\\Cback\\C-WIN7-ALL.tibx"   
 
01/29/2020 18:20:05  type=log; level=inf;  message=  
ar#1: deleting archive path="\\?\D:\Cback\/C-WIN7-ALL.tibx";

Yesterday the same task looks to have run to the point where it is trying to close the backup file then fails..

01/28/2020 21:04:23  type=log; level=inf;  message=  
ar#1: archive close (commit_seq=14, reuse_seq=14, file_size=274892726272, uuid=7b89e4fe83307d4e2b5e21a2faaedd55);  
 
01/28/2020 21:04:23  type=commonerror;  value=  
Base64 decode: " ??(? ???Operation is canceled. $module Adisk_backup_vs_650 $file Ac:\jenkins_agent\workspace\mod-disk-backup\650\product\core\resizer\archive3\backup_partition.cpp $func A`anonymous-namespace'::PartitionBackuper::ReadDrive $line NW       
 
01/28/2020 21:04:23  type=log; level=inf;  message=  
lsm#1: dedup_map nr_lookup=26136 nr_found=12055 false+=12004 (45.93%/99.58%);  
 
01/28/2020 21:04:23  type=retcode; value=5012; id=1;   
01/28/2020 21:04:23  >>> exit 

Slightly different error on archive close for an earlier backup yesterday..

01/28/2020 20:58:25  type=log; level=inf;  message=  
ar#1: archive close (commit_seq=12, reuse_seq=0, file_size=274748010496, uuid=7b89e4fe83307d4e2b5e21a2faaedd55);  
 
01/28/2020 20:58:25  type=commonerror;  value=  
Base64 decode: ?5cA??@?A backup error. $module Adisk_backup_vs_650 $file Ac:\jenkins_agent\workspace\mod-disk-backup\650\product\core\da_api\backup.cpp $func Ada_backup::Commit $line Na       0 ???? ?The backup has been created but its data is inconsistent with the source. Backup will be automatically restarted. $module Adisk_backup_vs_650 $file Ac:\jenkins_agent\workspace\mod-disk-backup\650\product\core\resizer\archive3\backup.cpp $func Aresizer::Archive3ImageBuilder::CommitBackup $line N       Z? ??v???Failed to read the snapshot. $module Adisk_backup_vs_650 $file Ac:\jenkins_agent\workspace\mod-disk-backup\650\product\core\fdisk\win_snapshot.cpp $func Awin_snapshot_volume::IoOp $line N?              ?R?*{?Unknown status. code N?      $module Adisk_backup_vs_650 $file Ac:\jenkins_agent\workspace\mod-disk-backup\650\product\core\fdisk\ver2\arch\windows\win_errors.cpp $func AFdisk::AddKstatusError $line N(        ??  ??d??(?Insufficient system resources exist to complete the requested service code N??    $module Adisk_backup_vs_650 $file Ac:\jenkins_agent\workspace\mod-disk-backup\650\product\core\common\error.cpp $func ACommon::Error::AddWindowsError $line N3         
 
01/28/2020 20:58:25  type=log; level=inf;  message=  
lsm#1: dedup_map nr_lookup=2409344 nr_found=74294 false+=73942 (3.07%/99.53%);  
 
01/28/2020 20:58:25  type=retcode; value=4095; id=1;   
01/28/2020 20:58:25  >>> exit

Beginner
Posts: 2
Comments: 6

#7

Steve:

I neglected to save the VSS Dr. report from the "fix" run, so the fixes only appear in the (subsequent run) report I posted as prior events.  All seems good, though -- scheduled incremental backups are completing normally, and VSS Doctor (my new favorite utility -- I've been running it every few hours, just for good measure) seems happy now (current report attached).

And -- thanks to this fix from Mustang: https://forum.acronis.com/forum/acronis-true-image-2020-forum/how-repair-ti-2020-build-22510-boot-disk-created-windows-7-using-simple-option -- I even now actually have my rescue boot medium functioning normally for the first time in 2020.  (THAT feels good too.)

Attachment Size
528270-178959.txt 9.52 KB
Legend
Posts: 100
Comments: 22029

#8

Geoffrey, it does sound like the VSS Doctor has resolved this issue and good to read that Paul's advice for the rescue media has resolved that one too!  Thanks for the feedback.

Beginner
Posts: 1
Comments: 3

#9

I have this problem on my c drive SSD. have used VSS Doctor but still fails to complete backup. Think I will have to ask Acronis.