Skip to main content

access denied to "documents and settings/owner" folder in mounted image

Beginner
Posts: 2
Comments: 6

Hello Acronis Folks, I have not been here a long time as I have not had any problems. I use Acronis TI Home 9 build 3854 and have done many full disk image restorations on my XP desktop computer with out any problems. These are from images that have been stored on an external hard drive. But that desktop computer has bit the dust. So I connected the external hard drive to a different XP computer (laptop), fired up TI9 and mounted the most recent image as a drive, hoping to copy documents. I was able to access almost everything on the drive, except the main thing that I want. The "My Documents" folder. I have a separate folder that I named "Bill'sDocs", in which I had stored a large amount documents from older computers. And I can access every one of these without problem, as well as everything else in the mounted image that I tried. But, the my documents folder is accessed by way of C:\Documents and Settings\Owner\My Documents (actually, I:\......... on the mounted image, after Acronis gives it a different drive letter during mounting). Now this is slightly different tree than what shows on my laptop. On the lap top to which I'm trying to restore files, the tree is C:\Documents and Settings\My Name\My Documents". I notice that on the image Instead of "My Name", it has "owner". So under the documents and settings folder on my laptop it has the folders "administrator, all users, default user, my name"(which contains "My Documents"). Where as on the image the tree is the same, except "my name" isn't there, and instead there is a folder "owner". (As well as, for some reason "local service and network service folders). So "my documents" is under the folder "owner" on the image, while on the lap top I'm using "my documents" is under "My Name". I suspect that somehow this has something to do with the problem, but I don't know what to do about it. By the way, I'm not trying to restore anything to the "my documents" folder on the laptop, but to a special folder that has been set up on the desktop. I can RECOVER individual files when I don't mount the image, and I have tried going this route. "Owner" shows up with a plus sign beside it, and when I click on the + sign many other folders show up which includes all of "my documents". Then I can select these files to restore. I can't do anything else with them, like view,open or copy them. I can only restore them. The only trouble with that is, when I tried to restore a large number of them, I invariably get messages about the "can not restore, file names being too long." I'm never quite sure which files that I might need are being left out.

For some odd reason, when I mount the image, the "owner" folder does not have a plus sign beside it any longer, and when I try to click on it I get the "access denied" message. Accessing the Acronis image file on the external drive (without mounting it as an image) from my laptop, I have tried all kinds of techniques to claim ownership and change permissions of both the image file, as well as the entire external hard drive tree. This all seems to go very well as I'm doing it. But still, nothing helps, once I mount the image and try to access "owner", I get "access denied". I can access everything else on the drive, but not the "owner" folder.

Any ideas? I have researched this in the knowledge base, where I got the idea about "claiming ownership". Also here http://kb.acronis.com/content/1549 and http://kb.acronis.com/content/1549. But so far can't find anything that works. I have mounted in both "read only" and also "write" mode, no difference.

Forum Star
Posts: 19
Comments: 2110

Top

BillyBob58:

You're really close to having a solution. The issue is NTFS permissions, which were set on the original disk for a specific user, and are being blocked by Windows on a different PC.

To work around this you should mount your image file as "read/write". After doing this, right-click on the folder that you can't access and choose the "Security" tab. Follow this Microsoft KB article to "Take Ownership" of the folder: http://support.microsoft.com/kb/308421

Beginner
Posts: 2
Comments: 6

Top

Thank you, Mark. I mounted the file as read/write, and got nowhere. If I left click on it I still get "access denied". But, I don't remember if I right clicked on it and saw a "security" tab. Hopefully I did not. I think I did right click it, but maybe I did just not see the security tab. Do you have to go to properties first? Anyway, I will try again later tonight or tomorrow and see if I can make some progress.
Bill

Forum Star
Posts: 19
Comments: 2110

Top

Bill:

Yes - the security tab is on the Properties dialog box. The Microsoft article that is linked to in my last reply has instructions on how to change the permissions on a folder. Next time that you look at this, take a look at the article for the details.

Beginner
Posts: 2
Comments: 6

Top

OK Mark, the problem is at least solved enough, following your directions more or less, to make things workable. But it was all a bit complicated because things finally worked, but not without a battle. First, I was unable to mount the partition I needed, the one with owner/Documents, in read/write mode. Of course, I could mount the other 2 partitions on the disk image, the ones I didn't need. Insanity! So, remembering that the directions for taking ownership required safe mode, I tried going to safe mode. But it would not allow me to mount an image there either. I got some message to reinstall Acronis. I can't remember all of it now, but I gave up and rebooted to normal windows. Still could not mount the partition in write mode. Tried an older image, it mounted( still denied access to owner) and allowed me to right click to a security tab. This allowed me to choose sharing this folder with other users on the network. Which changed "permissions". OK, that was encouraging. Went back to the newest image and partition (the one I need), and FINALLY it mounted in write mode! ARRGGGGGGH! Still no access to "owner". There was no security tab under properties. But, when I right clicked and chose "security/sharing" from the menu, and selected "allow sharing", it first gave me the access denied message, but when I clicked OK on the message, it started changing permissions. It took quite a while, but when it was done, I had full access! WhooHooo!

For more craziness, after I had done what I needed and closed it, I went back, mounted in read only, and was denied access to owner! So it looks like the changes were not permanent? Crazy stuff!

I wonder why I can not mount any image in safe mode, or safe mode with networking? I think this would really help, to take ownership and change permission for "owner", if i could do this. I'll keep playing with it and maybe figure it out. Maybe I should uninstall/reinstall?

Also, I figured out a way around the "file name too long" message during a normal recovery. I moved the recovery folder from the desktop and put it right under C:, which took a lot of folders out of the official full folder name. Then I got no more messages like that. YAY! On about a dozen files, I got a message about "can not find path" or something like that. But, it still restored these files, but the "modified" dates were changed. Good enough.

Any other ideas? Regardless, this helped me enough to access my files long enough to do what I needed. Thanks again!

Now I will have to look into a newer version of Acronis for my new Win 7 laptop. I guees ver 9 won't work on win 7?
Bill

Forum Star
Posts: 19
Comments: 2110

Top

BillyBob58 wrote:
...For more craziness, after I had done what I needed and closed it, I went back, mounted in read only, and was denied access to owner! So it looks like the changes were not permanent?

Bill:

When you mount an image in read/write mode, TrueImage will make an incremental image to contain any of the changes made. For example, if your original image file is called "MyBackup.tib" then TI will create the file "MyBackup2.tib". If you want the permissions changes to be remembered, mount this incremental image file. If you mount the original image in read-only mode it will be opened in the state that it was saved in (access to a particular user's documents will be denied to everyone but that user).

You can use TI version 9 on Windows 7 but only from the recovery CD; it won't install. For Windows 7 you will probably want to investigate the newest version, TI 2010.

Beginner
Posts: 2
Comments: 6

Top
Mark Wharton wrote:

Bill:

When you mount an image in read/write mode, TrueImage will make an incremental image to contain any of the changes made. For example, if your original image file is called "MyBackup.tib" then TI will create the file "MyBackup2.tib". If you want the permissions changes to be remembered, mount this incremental image file. If you mount the original image in read-only mode it will be opened in the state that it was saved in (access to a particular user's documents will be denied to everyone but that user).

You can use TI version 9 on Windows 7 but only from the recovery CD; it won't install. For Windows 7 you will probably want to investigate the newest version, TI 2010.

OK, Mark, that worked! I saw that image#2, but it had not occurred to me to click on it for mounting. Comes right up now! You sir are a treasure house of helpful info!
Bill

Beginner
Posts: 3
Comments: 6

Top

Now wait a sec...

Since windows machines routinely get infected, I make full .tib image backups onto a separate pc. This separate pc is used to mount the image partitions in r/w mode and perform virus scans and fixups. Once clean, the image is umounted then restored onto the original infected computer and life is good. If life becomes worse, then I simply restore back to the base image file and huddle up again.

Recently with Vista, 7, etc. workstations, mounting the partitions r/w gives "access denied" when trying to access their docs and other protected directories. I understand the need for these security but I need to scan the filesystem. If I "take ownership" of all those files, I can't simply restored that fixed image file back overtop the infected system. Since I took ownership, that means that system's user no longer owns it. Gosh, will it even login?? Will I have to do another "take ownership" for this original user after the prior infected system is back up in, say, in safe mode? Are you seeing this dilemma.

Basically, I'm trying to "do no harm" to the patient by adulterating the permissions from the start. Is there not a slick way to mount the tib partition in r/w mode whilst *using the credentials* of the original computers Backup or Administrator user? Also, I have a USB boot stick which removes NT passwords from Administrator or any user account. Real slick but does will removing these passwords prior to backing up avoid these "access denied" hurdles? (I guess I could try it...)

Thanks for reading.
=eric

Forum Hero
Posts: 613
Comments: 8748

Top

Eric,

The reason you can't read write a mounted image on a 'foreign' computer is that Vista and W7 have a far tighter security system than XP. The SSID for all the files in the mounted tib partition don't have the same SSID as the actual computer files, therefore the only normal way of running read/write is to attach permissions as you mentioned. Note to others this doesn't effect just mounting an image for reading.

I would suggest that if you run your AV before making an image you have a high level of safety. Instead of mounting the file to double check you might get the same amount of confidence just scanning the actual image file.

One major way of reducing susceptibility to virii is to disable the Windows restore function as this is where many 'nasties' like to hide and spawn from.

Beginner
Posts: 0
Comments: 2

Top

To the great comments of Mark, I would wish to add a caveat for users migrating from Win XP to Win7 and exploring a Win7 archive, while having been accustomed with Win XP: in the image there's a "Documents and Settings" directory and a "Users" directory. There's an "Own documents" and a "Documents" directory. Choosing the former over the latter leads you in a dead end (0 files found). That's because the "Docs & Settings" and "Own docs" folders are, actually, junctions in Win7, to preserve compatibility with the Win XP directory structure (same applies for various other directories). And the Acronis Explorer (both double-click and file restore) does not seem to resolve those junctions properly.

So make sure you aim for the right directory! If using a localized version (I have German), it becomes more obvious, as you have to choose between "Dokumente und Einstellungen" and "Users" or between "Eigene Dateien" and "Documents" and so on.

Beginner
Posts: 0
Comments: 2

Top

To the great comments of Mark, I would wish to add a caveat for users migrating from Win XP to Win7 and exploring a Win7 archive, while having been accustomed with Win XP: in the image there's a "Documents and Settings" directory and a "Users" directory. There's an "Own documents" and a "Documents" directory. Choosing the former over the latter leads you in a dead end (0 files found). That's because the "Docs & Settings" and "Own docs" folders are, actually, junctions in Win7, to preserve compatibility with the Win XP directory structure (same applies for various other directories). And the Acronis Explorer (both double-click and file restore) does not seem to resolve those junctions properly.

So make sure you aim for the right directory! If using a localized version (I have German), it becomes more obvious, as you have to choose between "Dokumente und Einstellungen" and "Users" or between "Eigene Dateien" and "Documents" and so on.

Beginner
Posts: 0
Comments: 1

Top

Hi all,

There is an easy workaround. Mount the Acronis image and open a Windows (admin) command line and go to the root folder of the mounted image (by issuing a "G:" command if the mounted drive is G:). If you know the exact path, enter "CD path". If not, enter "CD Documents and Settings", and when in that folder, enter "CD owner" (where 'owner' is your user owner name). Then enter "start ." to open a Windows Explorer window to proceed normally. (This workaround works the same way for Windows C: drive and its mounted counterpart).