Skip to main content

Acronis unable to access XP shares

Posts: 1
Comments: 0

After spending hours trying to troubleshoot this issue by myself and spending several more with an Acronis tech via remote session, I finally thought posting here may prove more effective...

This is the scenario:

XP "server" machine (SP3)
Win7 x86 Client
Win7 x64 Client

Acronis True Image Home 2011 - latest build installed on all machines.

Pretty simple, both Win7 machines are supposed to dump scheduled backups onto a share on the XP "server".
The problem starts when trying to access the share on the XP machine from either of the Win7 machines via Acronis. Acronis requests credentials in order to access the share where credentials should not be required...
The XP user account is password protected, yet as far as I know XP network shares do not require credentials. In any case, typing in the credentials fails every single time.
Miraculously, sometimes Acronis is able to access the share and does its thing without credentials at all!
Obviously scheduled tasks become totally useless and unreliable...
I already tried eliminating firewalls, security, etc..
That's not the issue.
Tried uninstalling everything...that's not it either...

I should also mention that while Acronis struggles to access the shares windows can easily browse them and create/modify files without any issues.

Any ideas at all?

Forum Star
Posts: 24
Comments: 3268


Hello User99,

Thank you for reporting about the issue on Forum, I sincerely appreciate it and will be glad to assist you.

I have found your case in our system and forwarded it to the Management team, they will make sure it's handled in a proper way.

I have also checked all our internal resources, and apparently in case you're specifying the UNC path (not the mapped drive), and the permission on the shared folder are set to "Full access - Everyone", then everything should work like a charm. I can see that your issue has been escalated to the Experts team.  I have passed it to the Testers team, and at the moment they are working on reproducing the issue. I will keep tracking the situation, and will update you as soon as I have any news. 

Should you need anything else or have any further questions - feel free to contact us at your earliest convenience, we will be happy to help you!

Thank you!

Forum Star
Posts: 24
Comments: 3268


Dear User99,

I have good news: we have tested the issue and found the cause of the problem.

Apparently the issue was caused by Windows XP limitation. Here's the error in the log file you've kindly submitted: 

>> No more connections can be made to this remote computer at this time because there are already as many connections as the computer can accept

Acronis True Image Home tried to access the share. It sees it and makes an attempt, but Windows XP is already busy with the connections from other resources. ATIH gets puzzled: it sees the share, but cannot get to it. So it assumes that it missed the credentials, and starts to ask for them.

The issue is caused, as I have already mentioned, by Windows XP limitations. Win XP Pro has only 10 connection attempts to the network share, Win XP Home - just 5.

In order to solve the issue we would advise you to do the following: 

  1. Decrease if possible the number of network connections to the Win XP machine during the backup
  2. Increase the number of the max limit for concurrent TCP connections according to these instructions

This should solve the problem. I have also forwarded this information to the case you've opened with support. You should be contacted shortly regarding the problem.

It's important for us to know that you're all set and the product is working. Please let us know in case the issue remains, we will be glad to help.

Should you need anything else or have any further questions - feel free to contact us at your earliest convenience, we will be happy to help you!

Thank you!