Skip to main content

Automatic Cleanup Stopped Happening

Thread needs solution
Forum Member
Posts: 18
Comments: 56

Looking at the activity page used to show automatic cleanup happening after every backup. See first attached file for an example.

This no longer happens. Second attached file show what I think are the relative settings. Not that at the bottom I can turn OFF automatic cleanup so I assume it is ON.

A few days ago I got help from Acronis support with a problem about not being able to download protection updates. The solution was to un-install then re-install Acronis. That did the job. I believe it is ever since then that automatic cleanup stopped working.

Attachment Size
Activity.png 27.59 KB
backup method automatic clean.png 34.25 KB
0 Users found this helpful
Legend
Posts: 105
Comments: 24719

Robert, if you have protection updates, then you have ATI 2021 so not sure why your topic has been posted in the forum for obsolete old products?

Your two images do not match correctly!

The Activity page image is for a Cloud backup but the automatic cleanup settings are for a different, local backup task as this uses different cleanup settings to those for Cloud tasks which are found in the Options > Advanced page settings.

Each backup task has its own full set of configuration settings.

Forum Member
Posts: 18
Comments: 56

Steve Smith wrote:

Robert, if you have protection updates, then you have ATI 2021 so not sure why your topic has been posted in the forum for obsolete old products?

Your two images do not match correctly!

The Activity page image is for a Cloud backup but the automatic cleanup settings are for a different, local backup task as this uses different cleanup settings to those for Cloud tasks which are found in the Options > Advanced page settings.

Each backup task has its own full set of configuration settings.

Sorry about getting my question in the wrong forum. I thought I picked the only one for "subscription" as that's what I think I have.

I guess I don't understand the local vs cloud distinction. I have only ONE type of backup configured, a local backup to disk, but it specifies that replication (to the cloud) should be done. There is only ONE option for cleanup. It is under "Backup Scheme." Even though that option appears to be on (as it gives me the choice to turn it off) no cleanup is shown in the activity log, as it was before I re-instsaled. I don't see two places to configure cleanup.

When you say "advanced" I don't know exactly which "advanced" you are referring to. See attached.

Attachment Size
567986-212100.png 61.24 KB
Legend
Posts: 105
Comments: 24719

Robert, thanks for the further information / image, which helps clarify matters more!

The Activity page references to the Cloud are simply given because you have setup Replication for your local backup to go to the Acronis Cloud.  My confusion was in thinking this was just a Cloud Backup without thinking of the replication aspect!  Much about 'seeing' but not 'seeing' when looking at your image which mentions replication!

That brings us back to the local backup task and the retention / cleanup settings you have set.

The task is running on a daily schedule where you are creating a Full backup followed by 13 Incrementals per version chain, and have set to keep 6 such version chains, so a total of 6 x Full plus 6 x 13 Incrementals to be created, plus one further Full backup before the oldest chain of files will be deleted, so after the 15th run of the task once you have created the 6 chains / after the 7th Full has been created successfully for the task.

Forum Member
Posts: 18
Comments: 56

Steve Smith wrote:

The task is running on a daily schedule where you are creating a Full backup followed by 13 Incrementals per version chain, and have set to keep 6 such version chains, so a total of 6 x Full plus 6 x 13 Incrementals to be created, plus one further Full backup before the oldest chain of files will be deleted, so after the 15th run of the task once you have created the 6 chains Thanks for the reply. / after the 7th Full has been created successfully for the task.

Thanks for the reply. That explains things pretty much as I understood them, but doesn't answer the question I started this thread with.

The question is ...

Why does my activity log no longer show an entry for "Cleanup successful" after every daily backup, like it did before I re-installed Acronis? See blue checkmark in attached file. 

Attachment Size
568085-212186.png 27.87 KB
Legend
Posts: 105
Comments: 24719

Robert, was the latest screen image taken from the same backup task or a different one?

If the same task then when was the last local cleanup activity reported?

Cleanup should not occur after every daily backup if you are making daily Incremental backups, it should only occur after a new Full backup is created and the number of version chains to be stored is exceeded.