Skip to main content

Bootable CD 2012 won't let me restore all 3 parts of partition

Thread needs solution
Beginner
Posts: 3
Comments: 1

Hi,

I created a partition backup of Windows 7, back in March.  I also created another one more recently, but it already had bad sectors, which I ignored during the backup.  So after the drive crashed, I tried restoring from the March backup.

I have the latest version of Acronis, but the Windows 7 PC already had 2012, so I used that.  I had created both the Partition, and the bootable CD.

 

When starting the restore, in the What to Recover section, I tried selecting all 3 of
NTFS (OS) (C:) ; Flags: Pri, Capacity: 687.3 GB ; Used Sp…:616 GB ;  Type: NTFS
MBR and Track 0 ; Type: MBR and Track 0
NFTS (System), Flags: Pri, Acct ; Capacity: 100 MB ; Used Sp…: 25.21 MB NTFS
 

, but in the partition size section on the Partition 1 – 1 screen, it said 

Partition size
Free space before : 1 MB
Partition size: 931.5 GB
Free space after: 728 KB
, and after clicking Next, it wouldn’t go any further.

So I unchecked the restore of MBR and Track 0 & the NTFS 100 MB Pri, Acct option, and restored the main part of of the Partition.

When it finished about 5 ½ hours later, the black screen said that the BootMgr is missing.

So I went back into the bootable CD, to restore the MBR & Track 0.  That seemed to work ok.  But it still won’t boot up.  Same errors.

What am I missing?  I did a full partition backup, which included the main partition, the MBR, and whatever that Pri, Act partition is.  But it won’t let me recover everything.  The full partition is now on the new drive - and I think the MBR is on there too - but it won’t boot.

The backup and restore are both being done, on the same Windows 7 PC.

 

0 Users found this helpful
Legend
Posts: 46
Comments: 15737

Please see forum topic: [How to] recover an entire disk backup which is the better method of recovery instead of having to size individual partitions.

If you have ATI 2018 and have created the Rescue Media for this version, then you should be able to use that media to do the recovery as it should be able to read your 2012 backup image file.

One assumption here is that you have replaced your original failed drive with another of sufficient size to hold all your data while leaving free space available?

From your description of the partitions, you have a Legacy BIOS system using MBR, so the small 100MB partition is the Microsoft System Reserved one where the Boot Configuration Data store is held. 

You need to ensure that the Acronis rescue media is booted in Legacy mode (not in UEFI mode if your system is capable of this), to avoid any conversion from MBR to GPT partitioning.

In reply to by Steve Smith

Beginner
Posts: 3
Comments: 1

Thanks, I solved it last night. The official instructions on this are wrong. 

I had to restore the 100 Mb system partition first, and adjust the default size to be exactly 100 mb, starting 1 mb offset.

 

Immediately after that, comes the main partition with all the programs and data.  I had to adjust the default size on that, because it was set at the size of the used space.

 

The target drive is more than the original partition, and it all worked out fine, upon waking up this morning. 

Legend
Posts: 46
Comments: 15737

Glad to hear you have got back to a working system.